Old 18th January 2010, 17:28   #1
stopasking
Banned
 
Join Date: Jun 2008
Posts: 446
Crash while importing media library

here's the top of the stack. looks like a missing null pointer check.


CDDBControlWinamp.dll!10022ef1()
CDDBControlWinamp.dll!10024284()
CDDBControlWinamp.dll!100251dd()
CDDBControlWinamp.dll!1002cba5()
CDDBControlWinamp.dll!1002cbe9()
CDDBControlWinamp.dll!1001cc76()
CDDBControlWinamp.dll!100205e8()
stopasking is offline   Reply With Quote
Old 18th January 2010, 17:30   #2
stopasking
Banned
 
Join Date: Jun 2008
Posts: 446
oh yeah, winamp 5.571 on x86
stopasking is offline   Reply With Quote
Old 18th January 2010, 17:45   #3
DrO
 
Join Date: Sep 2003
Posts: 27,880
there's a 5.572 out which superceeds the version you're trying and there might have been some fixes which may relate to the issue you're seeing.

-daz
DrO is offline   Reply With Quote
Old 18th January 2010, 19:15   #4
stopasking
Banned
 
Join Date: Jun 2008
Posts: 446
5.572 seems to have a memory leak.

the virtual memory size grew to 700MB+ on a library with 13k songs before i stopped it. it was at phase 4/4 about 3000 songs in.
stopasking is offline   Reply With Quote
Old 19th January 2010, 18:13   #5
stopasking
Banned
 
Join Date: Jun 2008
Posts: 446
I've run this a few times and confirmed that this leaks memory BADLY in the 4/4 processing step.
stopasking is offline   Reply With Quote
Old 19th January 2010, 19:31   #6
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,758
What are you doing exactly?

It sounds more to me like you're doing a Playlist Generator scan,
and not doing a Local Media "Watch Folders" scan... yes?
DJ Egg is offline   Reply With Quote
Old 20th January 2010, 15:29   #7
stopasking
Banned
 
Join Date: Jun 2008
Posts: 446
Correct, a playlist generator scan.

It consistently leaks memory on step 4/4, very badly, until it crashes.
stopasking is offline   Reply With Quote
Old 27th January 2010, 13:15   #8
stopasking
Banned
 
Join Date: Jun 2008
Posts: 446
have you guys been able to reproduce this?

is it going to get fixed for the next release?
stopasking is offline   Reply With Quote
Old 15th July 2014, 16:36   #9
Pryda
Junior Member
 
Join Date: Jul 2014
Posts: 1
This is still happening on 5.666, however it was fixed by installing an update.


http://puu.sh/acwEI/22acb45ffd.png

This was fixed by installing "http://forums.winamp.com/showthread.php?t=373755#updates" the required updates linked in DrO's signature.

Thanks.
Pryda is offline   Reply With Quote
Old 15th July 2014, 16:38   #10
DrO
 
Join Date: Sep 2003
Posts: 27,880
your issue is different from what this thread was about (library import is not the same as playlist generator calculations).

though like you note, anyone installing v5.666 should ensure it's build 3516 + required plug-in updates.
DrO is offline   Reply With Quote
Old 28th September 2015, 22:15   #11
NiMareQ
Junior Member
 
Join Date: Nov 2012
Posts: 17
Can't seem to find the "required updates" in DrO's signature. Can you assist me? The import still crashes after installing winamp5666_full_en-us_redux.exe


/edit
never mind me. Installing the two Update Patches from here on top of the "Fully patched build" of Winamp 5.666 fixed the importing.
NiMareQ is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump