Go Back   Winamp & SHOUTcast Forums > SHOUTcast > SHOUTcast Discussions

Reply
Thread Tools Search this Thread Display Modes
Old 5th February 2017, 22:17   #41
Desavil
Junior Member
 
Join Date: Nov 2016
Posts: 21
Bug: Stats
SHOUTcast keep sometimes all source informations but source not broadcasting.

No source: https://i.snag.gy/tIMyvH.jpg
But stats show that source is connected: https://i.snag.gy/Lbvz3C.jpg
Desavil is offline   Reply With Quote
Old 13th February 2017, 11:58   #42
eddr
Junior Member
 
Join Date: Nov 2002
Posts: 7
Hello,

SHOUTcast Server v2.5.1.724/posix(linux x64)

There seems to be an issue using Safari (On OSX, iPhone, iPad etc) whereby the SHOUTcast server thinks there's a listener just by visiting the stream status page.

For example, on a iDevice (Or MacBook in OSX) open Safari and go to http://stream.releasefm.net - You will see the listener count of Stream 1 increase - then open a new tab and go to http://stream.releasefm.net - the listener count increases again. The listener count will not go back down until Safari is hard closed!

Testing other browsers (Chrome, Firefox etc) does not have the issue and it seems to only be effected by Safari.

Any ideas what is going on?! This is effecting our stats as it thinks there are more listeners than there is (and listening for longer than they are).

Edit: This only seems to happen if shoutcast is running on port 80!

Thanks
Edd

Last edited by eddr; 13th February 2017 at 13:14.
eddr is offline   Reply With Quote
Old 13th February 2017, 15:27   #43
neralex
Senior Member
 
Join Date: Mar 2011
Posts: 474
@eddr: This is an issue of safari itself.
neralex is online now   Reply With Quote
Old 13th February 2017, 15:58   #44
eddr
Junior Member
 
Join Date: Nov 2002
Posts: 7
Yep I would say so.... But why? Safari isn't listening to the stream and only looking at the stats page - why does safari do it and no other browser? And why only on port 80?
eddr is offline   Reply With Quote
Old 15th February 2017, 03:31   #45
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,260
Perhaps safari is "prefetching" links in the page - to make the browser appear fasterer

Is it just me or are shoutcast users getting dumber?
jaromanda is offline   Reply With Quote
Old 24th February 2017, 15:42   #46
outpostradio
Junior Member
 
Join Date: Sep 2016
Posts: 13
Segfault with build 724

I attempted to upgrade from build 723 to build 724 last night. However, build 724 crashed with a segfault almost immediately. I made two attempts and the logs from both are attached. Unfortunately, core dumps were not enabled. I then reverted to build 723 which run with no problems.
Attached Files
File Type: log sc_serv_2.log (7.7 KB, 112 views)
File Type: log sc_serv_3.log (13.8 KB, 117 views)
outpostradio is offline   Reply With Quote
Old 10th March 2017, 13:22   #47
maloti
Junior Member
 
Join Date: Jan 2015
Posts: 12
DNAS Update

Hello everybody,
I have the version SHOUTcast Server v2.4.7.256 / posix (linux x86)
What are the steps to make the update for the new version 2.5.1.724?

I tried but did not want to upgrade. Can anyone help ?
maloti is offline   Reply With Quote
Old 16th March 2017, 13:58   #48
outpostradio
Junior Member
 
Join Date: Sep 2016
Posts: 13
Made another attempt to run 724 - this time successful. Not sure why the difference.

Noticed this version uses much less memory -- about half -- of 723 so far. A welcome change. v723 had been observed to grow without limit until killed by OS after several weeks.

Quote:
Originally Posted by outpostradio View Post
I attempted to upgrade from build 723 to build 724 last night. However, build 724 crashed with a segfault almost immediately. I made two attempts and the logs from both are attached. Unfortunately, core dumps were not enabled. I then reverted to build 723 which run with no problems.
outpostradio is offline   Reply With Quote
Old 21st March 2017, 00:49   #49
outpostradio
Junior Member
 
Join Date: Sep 2016
Posts: 13
Still getting segfaults

Yesterday I needed to reboot the server that shoutcast runs on. sc_serv failed to start FIVE times. See attached log. I kept trying, hoping that I wouldn't need to go back to v723, and finally, on the 6th attempt, it came up OK. Kernel message log attached.

THIS SUCKS! Releasing a fix should be top priority.

scserv-segfault.txt
outpostradio is offline   Reply With Quote
Old 21st March 2017, 11:21   #50
cefeidas
Junior Member
 
Join Date: Feb 2005
Posts: 40
Why doesn't the newest SHOUTcast DNAS v.2 support the following Titles definition yet (SHOUTcast DNAS v.1 didi it!):
$if2(%artist%,){$if2(%track%,)}$if2(%title%,){by}$if2(%originalartist%,) $if2(%lyricist%,)$IfStrEqual2(%composer%,%lyricist%,,; %composer%){$if2(%year%,)}$if2(%album%,)
???!!!
cefeidas is offline   Reply With Quote
Old 21st March 2017, 14:45   #51
juvenal teixeira
Junior Member
 
Join Date: Mar 2017
Posts: 2
suceso radio

oi amigos
juvenal teixeira is offline   Reply With Quote
Old 21st March 2017, 15:25   #52
juvenal teixeira
Junior Member
 
Join Date: Mar 2017
Posts: 2
oi amigos

O http://suceso.listen2myradio.com
juvenal teixeira is offline   Reply With Quote
Old 28th March 2017, 22:03   #53
cefeidas
Junior Member
 
Join Date: Feb 2005
Posts: 40
Why doesn't the newest ShoutCast DNAS v.2.5.1 (it was also the one I meant in my, till now, unanswered by the technical support team previous question) do like v.1 i.e. correctly list all stations when doing a Search e.g. by artist: it's been happening that to me long ago.
So, even as v.2 has had already several updates, but really not having solved several issues as these 2 I've pointed out in comparison with the last v.1 i.e. v.1-9-8, why not leeting at least this one be still supported until solving such issues?
Hoping for a technical support team answer, thank you in advance!
cefeidas is offline   Reply With Quote
Old 3rd April 2017, 14:40   #54
couch-potato
Senior Member
 
couch-potato's Avatar
 
Join Date: Feb 2002
Location: mother earth
Posts: 100
on SHOUTcast DNAS 2.5.1 (Build 724) I'm observing a strange thing about CPU usage.

I can compare two different VM's
VM1 OS Centos 6.8 64bit - 300 Listeners - approx 50 Mbit's > CPU usage 50%
I can compare two different VM's
VM1 OS Debian 8 64bit - 300 Listeners - approx 50 Mbit's > CPU usage 5%

On a Centos System we have 10 times more CPU usage.
Anyone else is using Centos and discovery high CPU usage for sc_serv ?

##.:: www.lounge-radio.com ::.##
couch-potato is offline   Reply With Quote
Old 5th April 2017, 19:11   #55
outpostradio
Junior Member
 
Join Date: Sep 2016
Posts: 13
couch-potato: Same cpu on both systems?
My server typical:
Centos 6.8 64-bit (cpu: Intel i3, 3 gHz, 4-core)
150 listeners
12% cpu
outpostradio is offline   Reply With Quote
Old 5th April 2017, 20:30   #56
couch-potato
Senior Member
 
couch-potato's Avatar
 
Join Date: Feb 2002
Location: mother earth
Posts: 100
Quote:
Originally Posted by outpostradio View Post
couch-potato: Same cpu on both systems?
My server typical:
Centos 6.8 64-bit (cpu: Intel i3, 3 gHz, 4-core)
150 listeners
12% cpu
VM 1 has 8 CPU cores > CPU usage 50%
VM 2 has 1 CPU cores > CPU usage 5%
Both has more or less the Same CPU on the host System.

##.:: www.lounge-radio.com ::.##
couch-potato is offline   Reply With Quote
Old 18th April 2017, 20:01   #57
outpostradio
Junior Member
 
Join Date: Sep 2016
Posts: 13
Shoutcast failing on startup - but not always

After rebooting my server, I typically have trouble getting Shoutcast started and running properly. It appears to start and be running, but net connections to it fail - including the admin page and streams. See the first attachment - sc_serv.log. Note the many ERROR lines like:
YP2 error code is 480 [Cannot see your station/computer (URL: http://listen.57fm.com:80/acop) from the Internet
In this instance, some streams did eventually become available.

The second attachment sc_serv_good.log is a subsequent startup which has no problems. It has none of the ERROR messages, and the admin page was reachable immediately.

I'd like to know if the Shoutcast developers have any insight regarding this.
Attached Files
File Type: log sc_serv.log (20.1 KB, 66 views)
File Type: log sc_serv_good.log (33.0 KB, 56 views)
outpostradio is offline   Reply With Quote
Old 22nd April 2017, 01:28   #58
howard334
Junior Member
 
Join Date: Sep 2002
Posts: 11
While DNAS updates are good (for the most part), I feel dumping an .EXE file onto peoples servers without asking first is a security hole just begging to be breached.

Just my 2 cents....

Howard,
Retro Rock n Remember
howard334 is offline   Reply With Quote
Old 19th August 2017, 09:48   #59
ThiefMaster
Junior Member
 
Join Date: Mar 2003
Posts: 21
Send a message via ICQ to ThiefMaster Send a message via AIM to ThiefMaster Send a message via Yahoo to ThiefMaster
What is this bullshit with having to register to download shoutcast? Why would you want my personal data and address just to /download/ shoutcast? Why do you care about my "station" when maybe all I want to do is stream music in my home network? Or maybe I just want to test things locally and don't even have a name etc yet!
ThiefMaster is offline   Reply With Quote
Old 19th August 2017, 09:58   #60
ThiefMaster
Junior Member
 
Join Date: Mar 2003
Posts: 21
Send a message via ICQ to ThiefMaster Send a message via AIM to ThiefMaster Send a message via Yahoo to ThiefMaster
Also, registering with an existing authhash is broken. When I click the "check" button an XHR POST request is sent to https://rmo.shoutcast.com/Settings/Radio/CheckAuthHash just to be 302-redirected to /Settings/Radio/create which servers some HTML - that doesn't seem to be what it's supposed to do, considering that nothing on the page changes... (also, the JavaScript code handling the response is clearly expecting a JSON payload, not a HTML page)
ThiefMaster is offline   Reply With Quote
Old 19th August 2017, 10:18   #61
gulbis37
Junior Member
 
Join Date: May 2016
Posts: 3
I use Shoutcast 2.5.1 724 posix/linux x64,when I try to make summary(description) or put tags,and update info,I launch pop-up-THE WEBSITE MUST SPECIFY HTTP OR HTTPS.
gulbis37 is offline   Reply With Quote
Old 21st August 2017, 10:24   #62
gulbis37
Junior Member
 
Join Date: May 2016
Posts: 3
Sorted,thanks.
gulbis37 is offline   Reply With Quote
Old 12th September 2017, 17:34   #63
JCAlexandres
Junior Member
 
Join Date: Mar 2017
Posts: 3
Don't give up!

Quote:
Originally Posted by awake4real View Post
I'm giving up maybe because the winamp (can't actually even find the download link for Linux) let alone the dsp for shoutcast. actually got a way down the road with dnas but the linux system seems unable to implement the things necessary to get an online radio up and running. so discouraged. dan
I am sure the Linux gurus will be able to help you, or come with a solution to your issue if not that already done. I am using Windows 7 x86, it just works fine, no sweat
JCAlexandres is offline   Reply With Quote
Old 12th September 2017, 19:33   #64
dopelabs
Senior Member
 
dopelabs's Avatar
 
Join Date: Oct 2006
Location: Silicon Valley
Posts: 493
Send a message via AIM to dopelabs
Quote:
Originally Posted by awake4real View Post
I'm giving up maybe because the winamp (can't actually even find the download link for Linux) let alone the dsp for shoutcast. actually got a way down the road with dnas but the linux system seems unable to implement the things necessary to get an online radio up and running. so discouraged. dan
plenty of linux tools... send me a msg of what functionality you are trying to achieve and ill let you know what tools are available for you to do so.

also priv msg for that linux dnas download link
dopelabs is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > SHOUTcast > SHOUTcast Discussions

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump