Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Bug Reports

Reply
Thread Tools Search this Thread Display Modes
Old 29th September 2014, 18:14   #1
franpa
Member
 
Join Date: Feb 2007
Location: australia, brisbane
Posts: 56
Send a message via Yahoo to franpa
Adding multiple songs simultaneous via windows explorer adds them in the wrong order

When adding a group of files to Winamp by selecting a bunch of songs in Windows Explorer and pressing Enter, the songs are added to the playlist in an order that is reverse to the order that they are listed in in Windows Explorer (When Windows Explorer is configured to sort files by type and the files are all the same type).

Adding the same files via the "Add" button at the bottom of the Playlist and than "Add Dir" results in the files being loaded in to the Playlist in the same order that they appear in in Windows Explorer.

I believe the latter behaviour should occur regardless of how the files are added to Winamp...

Windows 7 x64
franpa is offline   Reply With Quote
Old 29th September 2014, 20:22   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
this has come up numerous times over the years... Winamp processes the files in the order Explorer provides to them. which varies between different methods.

if you want a specific order then you need to have the selection focus at the start of the selection before you use the Explorer menu action and then it should provide them in the expected order.

as such, there is no way that i'm aware off for Winamp to know the specific selection details and so it has to process them in the way that Explorer passes the details to it.

[edit]
i vaguely remember someone mentioning about using a shell extension to get around it but i'm not at all certain that is true and then there's the whole thing of needing to provide a shell extension... (which i had started on a few years back but it never worked all that well).
DrO is offline   Reply With Quote
Old 30th September 2014, 09:48   #3
franpa
Member
 
Join Date: Feb 2007
Location: australia, brisbane
Posts: 56
Send a message via Yahoo to franpa
Quote:
Originally Posted by DrO View Post
if you want a specific order then you need to have the selection focus at the start of the selection before you use the Explorer menu action and then it should provide them in the expected order.
Ah, that is indeed a pretty weird issue, the work around works without major issue (It will place the last item at the top of the queue but the remaining items will be in the expected order).
franpa is offline   Reply With Quote
Old 30th September 2014, 11:38   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
its just how explorer has done things for years and Winamp gets the blame for it. why it uses the selection mark as the first item of a selection I don't know - I guess its assumed to be the important item but that's just how it works. so as long as the selection mark is at the start of the selected items then you should get what you expect.
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump