Old 30th March 2011, 14:32   #1
BWK
Junior Member
 
Join Date: Mar 2011
Posts: 2
Video issues

I am having some issues with WINAMP.

1: MKV videos will not play. The audio plays fine, but no video at all.

2: I have an .avi encoded with xvid. When winamp tries to play it, it crashes.
BWK is offline   Reply With Quote
Old 30th March 2011, 15:41   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,912
Hi

FAQ - Info required for problems with video playback
http://forums.winamp.com/showthread.php?t=161361#video

Are you using Winamp Free or Pro version?

Please refer to the above link for a list of more required info, eg.
Windows OS, Winamp version (5.61), Installed codecs, etc etc.
DJ Egg is offline   Reply With Quote
Old 30th March 2011, 16:00   #3
BWK
Junior Member
 
Join Date: Mar 2011
Posts: 2
Winamp free 5.61
Winamp essesntials pack installed


MKV is

Video codec: V-MPEG4/ISO/AVC
Audio codec: A_AAC

AVI is
Video: MPEG-4 Visual (XviD)
Audio: PCM (Microsoft)
Attached Files
File Type: txt DxDiag.txt (34.3 KB, 173 views)
BWK is offline   Reply With Quote
Old 30th March 2011, 22:03   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,912
Ok, thanks for the info...

http://forums.winamp.com/showthread.php?t=155680#mkv
http://forums.winamp.com/showthread....d=315355#video

Winamp Pro has native support for MPEG4 video formats (xvid, h264/avc, divx, mp4v, etc) in MKV, AVI, MP4 & FLV containers.

For the free version you need to use DirectShow instead.

Go to: Winamp > Prefs (Ctrl+P) > Plugins > Input

Although your issue isn't with MP4 videos, we might as well address it at the same time....
Double-click "Nullsoft MP4 Demuxer" to enter in_mp4 config
Remove MP4 & M4V from the list so it just says: M4A

Click OK

Now double-click "Nullsoft DirectShow Decoder" to enter in_dshow config

Your extension list wants to look something like this:

MPG;MPEG;M2V;AVI;MP4;M4V;FLV

Change it accordingly (copy+paste my list in)
Click OK
Close the Prefs
Close Winamp

Now go to the "C:\Program Files\Winamp\Plugins" folder.
Create a new "Backup" subfolder in there.
Cut+Paste (move) the following files from Plugins into the new Backup folder:

in_avi.dll
in_mkv.dll
in_flv.dll

Now install the following:

Haali Matroska Splitter - http://www.free-codecs.com/download/...a_Splitter.htm
FLV Splitter: http://www.free-codecs.com/download/...o_Splitter.htm
FFDShow Tryouts - http://sourceforge.net/projects/ffdshow-tryout/files/

When installing the Matroska Splitter, it asks you what extensions/formats to use the splitter for.
Uncheck AVI
Keep MKV checkmarked (MP4 & OGM are optional, up to you...)

When installing FFDShow, the default install options should suffice.
If I remember correctly, it auto enables support for H264/AVC & Xvid video decoding.
Though you may need to enable/checkmark AAC under the audio section
(you'll see what I mean when you install it).

Once they're installed, you should be able to reopen Winamp and play both videos.

Let me know how it goes....
DJ Egg is offline   Reply With Quote
Old 1st April 2011, 19:15   #5
dennisyx
Junior Member
 
Join Date: Apr 2011
Posts: 3
Don't know about BWK, but it worked for me, same issue.


Thanks..!
dennisyx is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump