Old 20th October 2012, 00:45   #1
POetics
Junior Member
 
Join Date: Oct 2012
Posts: 2
Stream URL set to local IP address

Good afternoon!

I have recently created a SHOUTcast station on my Slackware linux server, forwarded ports 8000-8001 on my router, and ensured that everything seemed to work on my (local network) end. When I asked several friends to connect from outside my network however, they reported that their players (mostly VLC or Xmms) reported an error, similar to the following:

"Unable to open the MRL 'http://192.168.2.101:8000/stream/1/'"

While 192.168.2.101 is the server where I have the transcoder and server running, it obviously won't work for people outside my network trying to connect. I have configured my domain name's DNS records such that music.domain.com points to my IP. If my friends replace the IP address with the fully-qualified domain name in their players, it works.

My question: What variables/arguments should I set in the server or transcoder configs to ensure that the stream publishes the FQDN and not the local host IP address?

I have attached my two configuration files below, and in theory the correct stream listen URL is http://music.msmbnetworks.com:8000/listen.pls?sid=1
Attached Files
File Type: conf sc_serv.conf (862 Bytes, 182 views)
File Type: conf sc_trans.conf (1.2 KB, 127 views)
POetics is offline   Reply With Quote
Old 20th October 2012, 10:30   #2
hrace009
Junior Member
 
Join Date: Oct 2012
Posts: 4
hmmm looks like you have same problem with me.

i already setup my shoutcast server.
i can hear music from my android phone and WinAmp.
but i wanna use my flash player on my web http://www.pwtwilight.com
i set the url to http://www.pwtwilight.com:8083/stream/1/ or http://www.pwtwilight.com:8083 and my web flash player won't load. but i try use other URL out there. it was work. what wrong with my configuration?

here my config:
sc_serv.conf
code:
portbase=8083
logfile=logs/sc_serv.log
w3clog=logs/sc_w3c.log
banfile=control/sc_serv.ban
ripfile=control/sc_serv.rip
password=password1
adminpassword=password2
streamid=1
streampath=/hrace009.aac
publicserver=always
streamauthhash_1=45645646



sc_trans.conf
code:
calendarrewrite=0
encoder_1=aacp
bitrate_1=56000
outprotocol_1=3
serverip_1=www.pwtwilight.com
serverport_1=8083
password_1=password1
streamid_1=1
streamtitle=Perfect World Twilight
streamurl=http://www.pwtwilight.com
genre=Misc
playlistfile=playlists/hrace009.lst
adminport=8999
adminuser=admin
adminpassword=password2
djport=8084
djlogin_1=dj
djpassword_1=password3
djpriority_1=1



can someone help?
hrace009 is offline   Reply With Quote
Old 20th October 2012, 10:35   #3
hrace009
Junior Member
 
Join Date: Oct 2012
Posts: 4
---remove---
sory double post

Last edited by hrace009; 20th October 2012 at 12:34.
hrace009 is offline   Reply With Quote
Old 20th October 2012, 12:10   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
POetics: you're hitting a likely bug in the DNAS. you could try setting destip=music.msmbnetworks.com but that still may not work and really it requires a newer DNAS to be used to get all of that working as expected.

hrace009: either the DNAS isn't running or you've not opened port 8083 to the machine the DNAS is running on. additionally, if you've set it to be public then i would hope that you've created an authhash for the stream (as per http://wiki.winamp.com/wiki/SHOUTcas...ash_Management) as without that all client connections will be blocked (which could also explain your issue).

-daz
DrO is offline   Reply With Quote
Old 20th October 2012, 12:21   #5
hrace009
Junior Member
 
Join Date: Oct 2012
Posts: 4
Quote:
Originally Posted by DrO View Post
POetics: you're hitting a likely bug in the DNAS. you could try setting destip=music.msmbnetworks.com but that still may not work and really it requires a newer DNAS to be used to get all of that working as expected.

hrace009: either the DNAS isn't running or you've not opened port 8083 to the machine the DNAS is running on. additionally, if you've set it to be public then i would hope that you've created an authhash for the stream (as per http://wiki.winamp.com/wiki/SHOUTcas...ash_Management) as without that all client connections will be blocked (which could also explain your issue).

-daz
my port 8083 already open and i can hear my radio tru WinAmp.
-A INPUT -p tcp -m tcp -d 175.103.58.230 -i eth0 --dport 8083 -j ACCEPT

but my browser on htttp://www.pwtwilight.com can't hear anything on Media player

and i was setup my own auth streamauthhash_1= [ my hash ]
hrace009 is offline   Reply With Quote
Old 20th October 2012, 12:30   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
now that it seems to be running (wasn't when i replied) and i was able to connect to it, then it is most likely that your player doesn't / cannot play AAC+ streams as i'm seeing the player try to play the stream for ~15seconds before it gives up.

-daz
DrO is offline   Reply With Quote
Old 20th October 2012, 12:33   #7
hrace009
Junior Member
 
Join Date: Oct 2012
Posts: 4
Quote:
Originally Posted by DrO View Post
now that it seems to be running (wasn't when i replied) and i was able to connect to it, then it is most likely that your player doesn't / cannot play AAC+ streams as i'm seeing the player try to play the stream for ~15seconds before it gives up.

-daz
ohhh got it. so basicly my web player not support with aac+
realy painfull

thanks for explanation. i will find the way to make it work
hrace009 is offline   Reply With Quote
Old 20th October 2012, 20:54   #8
POetics
Junior Member
 
Join Date: Oct 2012
Posts: 2
Thank you for the suggestion, DrO -- I had used destip in the past, but had dismissed it out of hand for some reason. After including it in my serv.conf everything seems to be working properly.

Much appreciated!
POetics is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > SHOUTcast > SHOUTcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump