Old 7th January 2005, 15:39   #1
RR4
Junior Member
 
Join Date: Dec 2004
Posts: 5
Streaming NSV playlist AND live video

Hi there,
I looked in the forum and the documentation, but I couldn't find the solution.

Here is what I'd like to do:
I have a linux host on which I'm running the shoutcast DNAS server. I know how to send NSV files (playlist) to the server using nsvscsrc.exe, but I'd like to send them 'locally' to limit bandwidth usage. IE running on the host a linux software that would act like nsvscsrc.exe. Is there any linux version of NSVTools? (if there is I couldn't find it )

Another more important thing I'd like to do is to be able to send live content (with nsvenc.exe on a windows computer) to the host.
How does the Shoutcast DNAS server act when it receives several sources?
Suppose I have one source for the playlist, and one for the live content, will it switch from one to another?

To resume, I'd like to have DNAS server and nsvscsrc running on the same linux computer, and streaming a NSV playlist. And sometimes, I'd like to run nsvenc on a windows computer to stream live content with the host.
Do you think there's any solution to do this?

Thanks in advance for all your answers
PS: sorry for my english, I hope I made myself clear, at least
RR4 is offline   Reply With Quote
Old 7th January 2005, 18:05   #2
sankt
Moderator
 
sankt's Avatar
 
Join Date: Apr 2003
Location: www.ScenicTelevision.com
Posts: 2,976
Here is a guide for switching between live sources and video files with NSV.

www.scvi.net/vid_switch.htm

Scenic Television is your ambient window to the world - - www.ScenicTelevision.com
sankt is offline   Reply With Quote
Old 7th January 2005, 18:54   #3
RR4
Junior Member
 
Join Date: Dec 2004
Posts: 5
Thanks Sankt
I tried doing as told in the tutorial, but my clients are still disconnected when I stop one source to start another... weird...

PS: I found 'sc_nsv' from radiotoolbox to replace nsvscsrc.exe under linux
RR4 is offline   Reply With Quote
Old 7th January 2005, 21:35   #4
sankt
Moderator
 
sankt's Avatar
 
Join Date: Apr 2003
Location: www.ScenicTelevision.com
Posts: 2,976
you have to configure the dnas ini file so that there are no stream interupts.

Scenic Television is your ambient window to the world - - www.ScenicTelevision.com
sankt is offline   Reply With Quote
Old 7th January 2005, 21:46   #5
RR4
Junior Member
 
Join Date: Dec 2004
Posts: 5
If, by this, you mean: set the value of AutoDumpUsers to 1, then I've already done that (see my last post) without success...

EDIT: I just tried with AutoDumpUsers set to 0 (the default value), and the clients are no longer disconnected when the first source is shut down, but when the new source is up...
I don't really understand this variable, the link you gave me says that it should be set to 1 in order to prevent users dumping...
RR4 is offline   Reply With Quote
Old 8th January 2005, 10:38   #6
RR4
Junior Member
 
Join Date: Dec 2004
Posts: 5
Am I the only one having troubles with AutoDumpUsers?
RR4 is offline   Reply With Quote
Old 8th January 2005, 12:06   #7
RR4
Junior Member
 
Join Date: Dec 2004
Posts: 5
To resume the situation:
I've set AutoDumpUsers to 0, here is what I get when I try to switch between two sources when somebody is watching the stream:
<01/08/05@12:25:55> [source] connected from 127.0.0.1
<01/08/05@12:25:56> [source] Read 2236416 bytes from Intro File
<01/08/05@12:25:56> [source] Read 2165342 bytes from Backup File
<01/08/05@12:26:08> [dest: *.*.*.*] starting stream (UID: 1)[L: 1]{A: MPEG OVERRIDE}(P: 0)
<01/08/05@12:27:16> [source] source dropped connection. disconnecting.
<01/08/05@12:27:16> [source] connected from 127.0.0.1
<01/08/05@12:27:17> [dest: *.*.*.*] connection closed (69 seconds) (UID: 1)[L: 0]{Bytes: 1360926}(P: 0)
<01/08/05@12:28:00> [active] 0 listeners (0 unique)

Notice:
1. that I've also set a backupfile which is playing fine when no source is connected
2. that the client is disconnected when the new source connects... but not when the old source disconnects
Please help, what am I doing wrong?
RR4 is offline   Reply With Quote
Old 31st January 2005, 18:08   #8
Viper.at
Junior Member
 
Join Date: Jan 2005
Posts: 7
Quote:
Originally posted by RR4
Am I the only one having troubles with AutoDumpUsers?
no,
http://forums.radiotoolbox.com/viewtopic.php?t=812
not exectly dumusers, but the same, swiching sources -> video stops, and the spectator must push the play button again, to watch the stream again :/


how do you fix to stream live at the sourcemount and when no source comes in from the dj wo sends the live source, that the backup is played and the stream stay online with a intro file or so on?
Viper.at is offline   Reply With Quote
Old 4th February 2005, 07:42   #9
Jeeper One
Major Dude
 
Jeeper One's Avatar
 
Join Date: May 2003
Location: Denver, Colorado
Posts: 1,055
Hi everyone:

A simpler solution I would think would be to run TWO instances of the SHOUTcast DNAS and basically run two streams (one public, the other private). If you know how to properly configure the server for relay (something even I have yet to figure out how to do with the DNAS I might add), you could simply have the public server instantly relay the private one when needed.

I know this sounds like comsuming twice the resources (and I'm probably off base here), but that's essentially what you're gonna have to do to avoid dumping viewers when switching from one mode to another (especially if you're doing a LIVE TV show with video clips).

Terrestrial TV stations do pretty much something similar to this all the time (particularly when doing a live shot for the local news). Think of it as the Internet TV equivelent to that.

Hope this helps

Cheers for now

Pat Cook
Englewood, CO
Jeeper One is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast TV / Nullsoft Video

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump