Old 13th August 2016, 23:48   #1
pietertvl
Junior Member
 
Join Date: Jun 2008
Posts: 30
Shoutcast links to Winamp player issue

Hi all.
I'm having issues getting Shoutcast/search result links to play in Winamp.
Win7, FF 42, winamp5.666.
Associations for pls, m3u, etc are to Winamp.

When I hit the links from the shoutcast/search results,

---In the winamp mp3 case, it pulls up a new tab on FF, loads it with VLC, and plays it there.
If I take the URL from that tab,

http://yp.shoutcast.com/sbin/tunein-....pls?id=265205 (psychedelik.com ambient)

and go to winamp and use Play URL, it will not play it.

---If I try the m3u option, it goes to Winamp, opens the media library, then times out.

However, this m3u link from Soma plays fine as a bookmark entry.

http://somafm.com/m3u/secretagent130.m3u

Same problematic results going to the AAC alternative. VLC opens in FF instead.

http://yp.shoutcast.com/sbin/tunein-....pls?id=344617

Is there a way to get to direct stream URLs? In general I seem to have problems with .pls files. The pls file association is correct, but I've had issues before with those not being accepted in Winamp. Anything I need to check in Winamp prefs?
Thanks!
pietertvl is offline   Reply With Quote
Old 14th August 2016, 01:13   #2
pietertvl
Junior Member
 
Join Date: Jun 2008
Posts: 30
re PLS

I also just check Prefs, General, File Types, and Associated File Types had PLS on the list, and in highlighted blue along with many others.
pietertvl is offline   Reply With Quote
Old 15th August 2016, 17:09   #3
CJ_Man
Senior Member
 
Join Date: Aug 2008
Location: Perth Australia
Posts: 167
Not sure why it wont work for you. When I click on the Psychedelik link in your post (I didn't go to the site) it opened the stream fine in Winamp. This was in Cyberfox (a 64 bit version of Firefox) running on Windows 10 with Winamp 5.666.

As a matter of interest that url resolved to http://195.154.166.226:8060/relay.mp3
CJ_Man is offline   Reply With Quote
Old 15th August 2016, 17:34   #4
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,823
Go to Firefox > Options > Applications
Make sure all things like M3U File, audio/x-scpls, audio/x-mpegurl, audio/m3u, etc are set to Winamp instead of VLC.
DJ Egg is offline   Reply With Quote
Old 15th August 2016, 18:33   #5
pietertvl
Junior Member
 
Join Date: Jun 2008
Posts: 30
Thanks, Dr Egg

That would appear to be the solution. Found it on my own a few minutes ago. "Everything" audio was somehow set to VLC Web Plugin. Have no idea how that came to be, as I've never been on this settings page before.

But found it after seeing CJ's response and searching about for FF related clues. Your note to me hadn't gotten to me yet via email alert. But found that page and all the settings were consistent with the behavior I reported.

Appreciate the help, as always. PS - the lag times from posting to appearance on the forum, and delays in email alerts is new to me (relative to a year ago) and doesn't seem ideal.

Regards
P
pietertvl is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump