Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Reply
Thread Tools Search this Thread Display Modes
Old 25th August 2014, 16:13   #1
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,648
Does Volume Control Cause Track Notification Popup to Appear?

I normally don't use the Winamp volume control. I prefer to leave it at 100% and use my computer's master volume controls or my keyboard's multimedia keys.

I clicked the Winamp volume control by accident and saw the track notification popup window appear. This is the window (if enabled) that briefly shows the album art and other info associated with the song selected in the playlist.

This only happens when the selected song is not playing. Is this normal behavior or something unique to me? I click on the volume control slider and the popup appears. I wait for the popup to go away and click the slider again and the window pops up again. This is weird behavior, imo, but I kinda like it.

I only see this with SUI modern skins (Bento and 3rd party). I don't think classic skins have a notification popup unless a plug-in is used. If they do, I can't get them to work with the classic skins I'm using.

Another strange thing is that with the Winamp Modern modern skin I can only get this to happen once. Only on the first click on the volume control after the skin is loaded does the popup appear.

The notification popup otherwise consistently works as I expect (with modern skins), since a fix (suggested by pjn123) was put in several versions ago. Namely, it appears when songs change during playback and when I use the next or previous controls to move thru a playlist when songs are not playing. Before the fix, the popup would sometimes not appear in response to these events.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 25th August 2014, 16:17   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
it shouldn't show for volume changes and so far i've not been able to get it to happen (i thought i had at one point and then realised i'd accidentally clicked on the seeker bar when focusing Winamp).
DrO is offline   Reply With Quote
Old 25th August 2014, 16:33   #3
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,648
Wow, thanx for the quick response. Does a bell go off somewhere near you whenever a post is made?

So it may be unique to me and my combination of things and/or settings. Ok, it doesn't seem to be hurting anything and I kinda like it

Edit:
You may have a version of what I'm seeing. I can't get it to happen when clicking on the seeker bar (or where the bar would be if a song was playing).

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 25th August 2014, 16:47   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
just coincidental timing

it looks like it might be down to the focus handling of different parts of the UI and what they may additionally trigger e.g. changing volume and clicking on the seeker will only trigger it once until you de-focus Winamp and do something similar again (based on my quick checks).
DrO is offline   Reply With Quote
Old 25th August 2014, 17:53   #5
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,648
I hate to say it, but this is starting to sound like something that may need more of your time than you have to give at the moment. Possible random actions due to the focus handling of different parts of the UI does not sound good. This one is benign, others may not be.

Are you saying you get a notification popup when clicking on the seeker bar to bring the focus to Winamp and it only happens once. If so, this does not happen with me whether a song is playing or not. It probably doesn't matter, but what skin are you using?

I consistently get the popup when clicking on the volume control as I have described above whether Winamp was already in focus or not and moving Winamp in and out of focus. It just needs the playback to be off or stopped.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 25th August 2014, 20:21   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
it's probably we're not doing it in the same way (as it seems to happen with the current Bento version and my modified version). but the Bento skin is covered in such things where different actions on a control can then trigger a script action like updating the ticker or triggering a move of the current song position (and the related actions it triggers, etc).

though with a bit more playing, it might be that changing the volume will also reset the state, but i'm not at all sure. oh how i prefer classic skins which don't have these weird issues.
DrO is offline   Reply With Quote
Old 12th November 2014, 16:39   #7
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,648
I finally determined the cause of the behavior discussed in this thread. It is an inadvertent result of disabling volume control in the DirectSound output plug-in.

I don't use Winamp's UI volume control and before discovering the Mouse Wheel Blocker plug-in (which is now a native feature), I had disabled this DS plug-in option to prevent accidental volume changes due to using the mouse wheel in the wrong places. The UI volume control still indicates a volume change, but the actual volume stays at 100%. After installing the Mouse Wheel Blocker plug-in, I didn't re-enable the DS plug-in's volume control. This was all done years ago and I had forgot all about it.

I don't think this bug has always been there (I think I would have noticed it). It's probably a result of fairly recent updates to the modern skin support and/or notifier code. This bug is benign, but the modern skin support logic should not be triggering a track change notification in response to moving the UI volume control when Winamp's volume control is disabled. However, disabling Winamp's volume control is something very few people would do.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 12th November 2014, 17:09   #8
DrO
 
Join Date: Sep 2003
Posts: 27,873
i doubt that's the reason as i've got out_ds volume control enabled. it's most likely a side-effect of the numerous notifications which can happen when certain things are changed and that the volume one must in some cases be triggering enough to cause the notifier to think something new is going on.
DrO is offline   Reply With Quote
Old 12th November 2014, 17:22   #9
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,648
Quote:
Originally Posted by DrO View Post
i doubt that's the reason as i've got out_ds volume control enabled.
Did you mean to write 'disabled'? If you're working with your internal build maybe that doesn't have the bug.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 12th November 2014, 17:29   #10
DrO
 
Join Date: Sep 2003
Posts: 27,873
i meant enabled and i've not changed anything in relation to such things and my reproduction of the quirk was with both public and internal builds.
DrO is offline   Reply With Quote
Old 12th November 2014, 17:35   #11
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,648
Then disable it and move the volume control in Bento (with nothing playing) and you should see the new track notification pop-up appear. Let it fade, then move the volume control again and it should pop-up again.

I can't get this quirk to happen when out_ds volume control is enabled.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 12th November 2014, 17:38   #12
DrO
 
Join Date: Sep 2003
Posts: 27,873
whereas i can get it to happen in normal cases. there's nothing i can do about the issue and if it gets fixed i don't know (at the moment it probably won't be something that will be fixed).
DrO is offline   Reply With Quote
Old 12th November 2014, 17:51   #13
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,648
Ok, understood, np. Your reproduction before was not quite the same and I was just saying what I now see that makes it happen consistently (at least for me).

There are bigger fish to fry.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 12th November 2014, 18:16   #14
Victhor
Late skinner & Moderator
 
Victhor's Avatar
 
Join Date: May 2003
Location: Argentina
Posts: 1,601
It happens with Bento too? I thought it might be a cPro thing. I see the same happening from time to time, specially when skinning /testing: some random actions trigger the notifier (in my case not just volume, also shuffle or repeat).
Despite my tendency to distraction I didn't pay much attention to it when happened,but it could be related to 2 things I guess: 1-Having another instance opened. 2-Pieter's script to fix right click killing the notifier..
Victhor is offline   Reply With Quote
Old 12th November 2014, 20:06   #15
DrO
 
Join Date: Sep 2003
Posts: 27,873
i'd go with the script fix (which as it happens with Bento and Modern would make sense since they do the same thing) and the core not distinguishing things enough.
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump