Go Back   Winamp & Shoutcast Forums > Winamp iPod Plugin Discussion

Closed Thread
Thread Tools Search this Thread Display Modes
Old 1st June 2006, 16:08   #41
kaatinthehaat
Major Dude
 
kaatinthehaat's Avatar
 
Join Date: Jul 2004
Location: Vancouver, Canada
Posts: 504
Abu, you're doing some great work here. This plugin just keeps getting better and better. I only wish I had a video ipod to try the new features.

80GB 5.5 generation Video iPod

4GB and 8GB gen 2 Nano's with ****+

Winamp 5.52 Pro ; ml_iPod 3.05
kaatinthehaat is offline  
Old 1st June 2006, 19:18   #42
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Quote:
Originally posted by kaatinthehaat
I only wish I had a video ipod to try the new features.
So do I!

Your posting is really encouraging, thanks

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline  
Old 2nd June 2006, 03:24   #43
Amaiznblue50
Junior Member
 
Join Date: Sep 2002
Posts: 14
Send a message via AIM to Amaiznblue50 Send a message via Yahoo to Amaiznblue50
Okay I just downloaded the alpha release 1.33a8

*The transfering of movies to the iPod does work now. Got pretty decent speed at 6000 kb/s.

*The autofill still causes Winamp to close. I can't even hit print screen quick enoughto see if it says anything. (Also what exactly does autofill do?)

As for my playlist request. Yes, take an already formed M3U playlist and just transfer it to the iPod. Because I have the same files on the hard drive and the iPod, I dont see why it wouldn't work. But then again I know the iPod will be looking for the songs in different places.

I'm very impressed by this plugin and the dedication you have towards making our lives easier. If you need some hosting, I'm more then willing to help. I can host your updates if that is becoming a problem for you.
Amaiznblue50 is offline  
Old 2nd June 2006, 09:00   #44
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Quote:
Originally posted by Amaiznblue50
*The autofill still causes Winamp to close. I can't even hit print screen quick enoughto see if it says anything. (Also what exactly does autofill do?)
Ok, I digged a bit deeper. The crash happens with the default settings for Autofill ("Fill whole albums only") and when there are songs in the library that have an empty "album" value. That is why I've never seen the crash: I do not use the "Fill whole albums" setting.

It is fixed now (hopefully), a new version 1.33a9 is up.

BTW: Autofill is used for small iPods (Shuffle, Nano) to fill the available space with randomly selected songs. So you will probably never need it, as you have all your songs on the iPod. But it would be nice if you gave it another try, simply to make sure that it doesn't crash any more.

Quote:
As for my playlist request. Yes, take an already formed M3U playlist and just transfer it to the iPod. Because I have the same files on the hard drive and the iPod, I dont see why it wouldn't work. But then again I know the iPod will be looking for the songs in different places.
Yeah, that is actually the problem. After transfer to the iPod, the files are there under completely different names and directories. No way of getting back the original filename.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline  
Old 4th June 2006, 16:34   #45
Reaper
Forum King
 
Join Date: Apr 2002
Posts: 2,928
I've noticed a new bug with ml_ipod in both a8 and a9 (as far as I know). When I use Explorer to right click on a folder and 'Play in Winamp,' the metadata of the files will not be loaded. Yet, when I disable ml_ipod (ml_ipod.dll.off method) all the metadata of the files in the playlist load fine.

ml_iPod - [Homepage] | [Forums] | [Wiki]
Reaper is offline  
Old 5th June 2006, 07:55   #46
Reaper
Forum King
 
Join Date: Apr 2002
Posts: 2,928
Working correctly with a11, now. Thanks

ml_iPod - [Homepage] | [Forums] | [Wiki]
Reaper is offline  
Old 5th June 2006, 09:14   #47
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Hi, Reaper,
thanks for reporting this. You're right, that happened when playing songs that are not yet in the ML.
Great to have a community like this, where alpha releases can be tested in such a productive and constructive way. Thanks to all!

This issue is fixed in the latest build, 1.33a11, as you already said.

And I think it's time for a new official release now. Within the next few days, I'll generate one. I guess it'll be called 1.40, not 1.33, because it is a major upgrade. A lot of new stuff in it.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline  
Old 6th June 2006, 02:19   #48
Amaiznblue50
Junior Member
 
Join Date: Sep 2002
Posts: 14
Send a message via AIM to Amaiznblue50 Send a message via Yahoo to Amaiznblue50
I can't wait to see whats going to be in 1.40
Amaiznblue50 is offline  
Old 6th June 2006, 08:42   #49
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Quote:
Originally posted by Amaiznblue50
I can't wait to see whats going to be in 1.40
I guess you'll be disappointed, though. It's merely a renaming of the latest 1.33alpha build

When I said "a lot of new stuff", I was refering to the last official release 1.32.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline  
Old 6th June 2006, 13:48   #50
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Quote:
Originally posted by abu
And I think it's time for a new official release now. Within the next few days, I'll generate one. I guess it'll be called 1.40, not 1.33, because it is a major upgrade. A lot of new stuff in it.
It will be the 1.33a15 version, if no new bug reports come in. I'll be away for some days, so please test this version and comment on it (positive or negative).
Download it here...

After my vacation I'll make the official release. But as some people had unreproducable crashes (http://forums.winamp.com/showthread....hreadid=247894), I would like to hear some positive news first. Does it work for you? (No wishlist here, please, simply tell me that it works, and what iPod and Winamp version you have.) Thanks for your support!

See 'ya soon.
-abu

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline  
Old 6th June 2006, 22:52   #51
kaatinthehaat
Major Dude
 
kaatinthehaat's Avatar
 
Join Date: Jul 2004
Location: Vancouver, Canada
Posts: 504
Abu,

In the ipod configuration under podcasts, there is a selection area for the path to where podcasts are stored on the PC and an option to select setting the genre to "podcast". Can you tell me how this works to update the podcast and if it looks in subfolders?

Thanks.

80GB 5.5 generation Video iPod

4GB and 8GB gen 2 Nano's with ****+

Winamp 5.52 Pro ; ml_iPod 3.05
kaatinthehaat is offline  
Old 7th June 2006, 05:33   #52
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Did you read the release notes?
Excerpt:
----
How is it supposed to work, now?

• Download your podcasts to a specific directory on your computer.
I’m not using the Winamp ShoutcastWire for this, because it is too much focused on streaming. You need a podcatcher that downloads all new episodes to your hard disc. I’m using Juice (http://juicereceiver.sourceforge.net/) for this.
• Set up this download folder as a watch folder in the media library preferences, to make sure that downloaded episodes show up in Winamp automatically.
• Tell ml_ipod about this directory on the config page (Preferences->iPod support->Speech tab->Top folder for podcasts)
• Connect your iPod and switch to the iPod page in media library
• Click on “Sync podcasts” button.
o All files under the top folder for podcasts are automatically tagged with genre “Podcast” now
o All new podcast episodes are transferred to the iPod.
• After you have listened to an episode on the iPod, the playcount is automatically increased by iPod. (Only if you listen right to the end! That is different to Winamp’s behaviour).
• During the next “Sync podcasts”, this episode is automatically removed from iPod.
• This removal can be prevented on the options page, uncheck “Remove played podcasts from iPod during podcast sync”
---

So, to your question:
Yes, it scans all subfolders, and the tagging takes place when hittingthe "Sync podcasts" button.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline  
Old 7th June 2006, 14:45   #53
bardlet
Junior Member
 
Join Date: Jun 2006
Posts: 8
It disabled all my lyrics of ipod nano 2G,
bugfixes?
not yet!
How to fix it?
bardlet is offline  
Old 7th June 2006, 16:35   #54
kaatinthehaat
Major Dude
 
kaatinthehaat's Avatar
 
Join Date: Jul 2004
Location: Vancouver, Canada
Posts: 504
Abu,

Thanks for the reply. Sorry, I had forgotten about your release notes which I had read a long time ago. My main question was about the subfolders. Thanks.

80GB 5.5 generation Video iPod

4GB and 8GB gen 2 Nano's with ****+

Winamp 5.52 Pro ; ml_iPod 3.05
kaatinthehaat is offline  
Old 7th June 2006, 16:53   #55
kaatinthehaat
Major Dude
 
kaatinthehaat's Avatar
 
Join Date: Jul 2004
Location: Vancouver, Canada
Posts: 504
Interesting....

In Winamp ML the genre of my podcasts shows up as "Podcast" but on some of them if you right click to see the file details, the ID3v1 and v2 tags both show "Blues" as the genre. Why is that?

80GB 5.5 generation Video iPod

4GB and 8GB gen 2 Nano's with ****+

Winamp 5.52 Pro ; ml_iPod 3.05
kaatinthehaat is offline  
Old 8th June 2006, 03:39   #56
skywalker6705
Junior Member
 
skywalker6705's Avatar
 
Join Date: Oct 2002
Posts: 35
Send a message via AIM to skywalker6705 Send a message via Yahoo to skywalker6705
I short, you responded to my post int he ml_pmp topic, I came here, and I love you.

The end. Lol.
Seriously though, in like a month you've made me A)Able to finally update. B)Able to use features which weren't there for years. C)Quickly shifted focus onto this project once again, and for free no less.
skywalker6705 is offline  
Old 11th June 2006, 12:11   #57
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Quote:
Originally posted by bardlet
It disabled all my lyrics of ipod nano 2G,
Which ml_ipod version are you using?
I've never had any lyrics on my iPod, so some dumb questions: How do you put them there, with iTunes? Manually, or automatically (getting them from internet)?
Do you know where they are stored, in the iTunesDB or in the files as ID3 tags? Do you have *.mp3 songs or Apples AAC stuff? If possible, send the iTunesDB which has all the lyrics ok.

Anyhow, there is no support for lyrics in ml_ipod yet. Please submit a feature request at SourceForge for this, with the above requested info.
https://sourceforge.net/tracker/?gro...28&atid=644707

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline  
Old 11th June 2006, 12:19   #58
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Quote:
Originally posted by kaatinthehaat
In Winamp ML the genre of my podcasts shows up as "Podcast" but on some of them if you right click to see the file details, the ID3v1 and v2 tags both show "Blues" as the genre. Why is that?
That's "expected" behaviour, ml_ipod only changes attributes in the ML, not the files themselves.

Background:
The genre that is displayed in Winamp is always the one that is stored in the ML. Initially (when a file is added to the library), Winamp reads the ID3 tags from the file and sets the internal ML fields (like genre) accordingly.
You can edit the ML entries by using "Edit selected items... Ctrl-E" If you have "Update file tags (if supported)" checked in this dialog, the ML entries are edited AND the ID3 tags are updated. But ml_ipodnever touches the ID3 tags, it acts as if the "Update file tags" is not checked in this dialog. Only the ML internal data is modified.
Updating the ID3 tags would require to use a ID3 library (which I don't want). Winamp's interface does not allow it, I think.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline  
Old 11th June 2006, 17:45   #59
Amaiznblue50
Junior Member
 
Join Date: Sep 2002
Posts: 14
Send a message via AIM to Amaiznblue50 Send a message via Yahoo to Amaiznblue50
Just to let you know that 15 is working good. I can still transfer movies and songs onto my ipod. Now on to the lyrics... You can actually add them in the ID3 tag in the mp3. Or many programs can help you add them, but none the less they are in the ID3 tag along with the album art. Now iTunes did automatically upload whatever ID3 tags that were attached to the mp3 (album art and lyrics) So as for how to make this work with your plugin, i'm not to sure.
Amaiznblue50 is offline  
Old 11th June 2006, 20:46   #60
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Thanks, Amaiznblue50, good to hear.

@bardlet: I tried it with the lyrics and iTunes now. They are stored in the *.mp3 file indeed. And ml_ipod does not delete that.
With 1.33a15, there seems to be no problem with lyrics.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline  
Old 12th June 2006, 12:51   #61
bardlet
Junior Member
 
Join Date: Jun 2006
Posts: 8
"ml_ipod does not delete that"

That's right,but my ipod can't show them on the screen after use it.
I must check the lyrics via iTunes to make them reactivation!
bardlet is offline  
Old 12th June 2006, 14:00   #62
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Still my question, which version are you using? With the latest alpha release, I can see the lyrics without problems, even after using ml_ipod. No need for iTunes again.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline  
Old 12th June 2006, 14:21   #63
bardlet
Junior Member
 
Join Date: Jun 2006
Posts: 8
latest version
Maybe you should find a ipod nano to test it
Thanks for your care
bardlet is offline  
Old 12th June 2006, 14:24   #64
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
So, please answer all the above given questions, and send the iTunesDB. That could help solve the issue
And, hey, "latest version" is no good answer, latest changes 3 times a day Give the exact version, please.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline  
Old 12th June 2006, 15:10   #65
bardlet
Junior Member
 
Join Date: Jun 2006
Posts: 8
How do you put them there, with iTunes? Manually
in the iTunesDB or in the files as ID3 tags?ID3 tags
stuff link:
http://www.box.net/public/static/qgshi8ly1x.mp3

iTunesDB link:
http://www.box.net/public/static/pzm7ksfij1.rar
version:
ml_ipod 1.33alpha
bardlet is offline  
Old 12th June 2006, 17:47   #66
Reaper
Forum King
 
Join Date: Apr 2002
Posts: 2,928
Quote:
Originally posted by bardlet

version:
ml_ipod 1.33alpha
But which alpha version?

ml_iPod - [Homepage] | [Forums] | [Wiki]
Reaper is offline  
Old 12th June 2006, 19:54   #67
bardlet
Junior Member
 
Join Date: Jun 2006
Posts: 8
1.33 alpha 1
bardlet is offline  
Old 12th June 2006, 19:59   #68
Reaper
Forum King
 
Join Date: Apr 2002
Posts: 2,928
The latest version is alpha17, which you can get here

ml_iPod - [Homepage] | [Forums] | [Wiki]
Reaper is offline  
Old 12th June 2006, 21:07   #69
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
v1.40 is out just now, please see
http://forums.winamp.com/showthread....hreadid=248568

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline  
Old 13th June 2006, 11:25   #70
bardlet
Junior Member
 
Join Date: Jun 2006
Posts: 8
Thanks,I'll try
It solve the problem
Now I don't need ml_pmp.dll
Thanks again

Last edited by bardlet; 13th June 2006 at 12:32.
bardlet is offline  
Old 13th June 2006, 12:35   #71
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Just to make sure that we are talking about the same stuff, this is what I tried without any problems:[list=1][*]Add lyrics to a song in iTunes[*]eject iPod[*]Lyrics get displayed on iPod (I have a Nano, so it works fine) with middle button[*]Attach iPod to computer[*]Run Winamp with ml_ipod 1.33a17 or 1.40[*]Edit something with ml_ipod (like removing a song from a playlist), which causes a rewrite of the database[*]eject iPod (Eject button in Winamp)[*]play the prepared song on iPod[*]lyrics are still there and get displayed when pressing middle button twice[/list=1]So I can't see any problems with lyrics.
Is that what you wanted, or am I missing anything here???

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline  
Old 13th June 2006, 13:59   #72
bardlet
Junior Member
 
Join Date: Jun 2006
Posts: 8
Eveything is ok after I use ml_ipod 1.40

U add lyrics like that.so do I

Now I wanna try foo_dop

Anyway,thanks for your reply
bardlet is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Winamp iPod Plugin Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump