Old 16th September 2014, 14:19   #1
stuart87
Junior Member
 
Join Date: Aug 2012
Posts: 4
shoutcast relay failing on public stream

Hi

I currently pull 3 feeds from a SHOUTcast Server v2.2.0.107/posix(linux x64) server using relays. If I have the stream set to public I have found the relay can lock up and cause the stream to reject connections for days. The streams which I have set to private seem far more reliable than the public streams.

Looking through the logs I can see:

SHOUTcast 1 client connection rejected. Stream not available as waiting on a Directory response.

When I look in the admin interface I see the server trying to pull a relay. If i abort that and then enable the stream comes straight back up and works.

I am currently running version SHOUTcast Server v2.2.0.83/win32 but I have setup a linux version SHOUTcast Server v2.4.0.147/posix(linux x64) to see if that version is more stable with relays.

In the mean time is there anything specific I need to ensure is setup? I have checked that the authhash is set in the configuration file for the public stream.

Thanks for your help in advance
stuart87 is offline   Reply With Quote
Old 16th September 2014, 14:35   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
you really need to be using 2.4 on all of the instances as 2.2.0 could in cases block client connections (as your relay connections essentially are) when there wasn't a valid YP connection (which was fixed in the 2.2.1 update) along with it having issues with connecting to the YP on some setups (which 2.2.2 and newer resolve, though it's best to go with 2.4 as 2.2.2 had some other YP related issues).

so simple summary: update to 2.4 and if issues still persist then we can try to triage the issue as 2.2.0 is three versions behind where the DNAS now is.
DrO is offline   Reply With Quote
Old 16th September 2014, 14:48   #3
stuart87
Junior Member
 
Join Date: Aug 2012
Posts: 4
Thank you for the speedy response!

No problem. To confirm to upgrade the SHOUTcast Server v2.2.0.107/posix(linux x64) I just simply need to copy and replace the existing sc_serv with the new one?
stuart87 is offline   Reply With Quote
Old 16th September 2014, 14:51   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
correct and as you're running the Windows version, you can just run the new installer and use that to update over the top of the existing install (as it also ensures you've got the update documentation and support files as needed).
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Tags
relay

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump