Old 30th August 2013, 14:35   #1
morsmodre
Junior Member
 
Join Date: Aug 2013
Posts: 2
Winamp year tag is not fully shown

Hi ~ I have some music files whose year tag has the format YYYY-MM-DD. This format is, as far as I know, part of the standard year format although usually an abbreviated form - YYYY - is used. This format is recognized in the MP3tag program [1] I use and in the standard Tag library TagLib [2] API.

My problem is that both winamp library and playlist do not recognize the full format. If I place the advanced title display format as [%year% - %artist% - ]$if2(%title%,$filepart(%filename%))

Only the YYY part of the tag appears although in the 'view info' the whole of the tag - YYYY-MM-DD - appears.

Is this a bug? Is there any configuration I'm not giving?


[1] http://www.mp3tag.de/en

[2] http://taglib.github.io/
morsmodre is offline   Reply With Quote
Old 30th August 2013, 14:48   #2
DrO
 
Join Date: Sep 2003
Posts: 27,874
the Winamp Library doesn't store the year like that [YYYY-MM-DD] since the library has to cope with other formats than ID3v2.3 and so it just showing YYYY is expected and by design.

if the files are not in the library then it's possible it may display that way, but as the titles of the items shown in the playlist editor are primarily based off what is in the library first (if known) then there is no config option, etc to alter this behaviour (which is how it's been since the library was added in v2.9.
DrO is offline   Reply With Quote
Old 3rd September 2013, 13:58   #3
morsmodre
Junior Member
 
Join Date: Aug 2013
Posts: 2
That's a pitty :x
Are there plans to change the display according to the file-format used in future versions?

morsmodre is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Tags
m4a, tag, year

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump