Old 13th August 2006, 02:53   #1
lexis
Junior Member
 
Join Date: Jan 2006
Posts: 5
nsv not connecting to server

Hello, I am not able to connect to my server. Here is what I have done. I am trying to stream live video.

I have read the documentation on both the winamp, shoutcast and the scvi.net site as that always gets the first reply.

On my home windows machine, I downloaded the updated repack of nsvtools from the scvi.net site. then I downloaded the updated vp3 video codec from the same site and installed as the instructions. I have downloaded the nsv_codec_sdk but not sure what to do with this.
I have set the headers:
mypassword
content-type:video/nsv
icy-metadata:0
icy-name:My NSV Stream
icy-genre:Video
icy-pub:0
icy-br:96
icy-url:http://www.mydomain.com
icy-irc:#chan
icy-icq:1234567
icy-aim:SomeUser
icy-reset:1

I have set the ip and port# to 8007 to upload to and password.
I have set the video format to VP3 3.1 since the 6. I cannot config as nothing comes up when I try to.

I hook up my cam, select it in the capture source and start capture. It shows to be capturing frames.

I downloaded the latest winamp 5 bundle and set the url to http://serverip:8006/;file.nsv And selected video.

I have configured the sc-serv.conf file on my linux web server. Set pwd, admin pwd, ip set to any+ port#.

I can login to the admin page. Here is the log: it always shows the server as down.

08/12/06@21:14:21> [SHOUTcast] DNAS/Linux v1.9.5 (Dec 27 2004) starting up...
<08/12/06@21:14:21> [main] pid: 28634
<08/12/06@21:14:21> [main] loaded config from sc_demo.conf
<08/12/06@21:14:21> [main] initializing (usermax:32 portbase:8006)...
<08/12/06@21:14:21> [main] No ban file found (sc_serv.ban)
<08/12/06@21:14:21> [main] No rip file found (sc_serv.rip)
<08/12/06@21:14:21> [main] opening source socket
<08/12/06@21:14:21> [main] source thread starting
<08/12/06@21:14:21> [source] listening for connection on port 8007
<08/12/06@21:14:21> [main] opening client socket
<08/12/06@21:14:21> [main] Client Stream thread [0] starting
<08/12/06@21:14:21> [main] client main thread starting
<08/12/06@21:14:40> [main] SIGHUP; Flushing Log Files
<08/12/06@21:16:58> [dest: 216.97.176.132] server unavailable, disconnecting
<08/12/06@21:17:01> [dest: 216.97.176.132] server unavailable, disconnecting
<08/12/06@21:17:22> [dest: 216.97.176.132] server unavailable, disconnecting
<08/12/06@21:17:40> [source] invalid password from HEAD /;file.nsv HTTP/1.0 216.97.176.132
<08/12/06@21:17:40> [source] invalid password from GET /;file.nsv HTTP/1.0 216.97.176.132
<08/12/06@21:17:49> [source] invalid password from GET /;file.nsv HTTP/1.0 216.97.176.132
<08/12/06@21:17:55> [dest: 216.97.176.132] server unavailable, disconnecting
<08/12/06@21:18:07> [dest: 216.97.176.132] server unavailable, disconnecting
<08/12/06@21:39:18> [dest: 216.97.176.132] server unavailable, disconnecting

Any help is much appreciated.

Thanks, Kevin
lexis is offline   Reply With Quote
Old 13th August 2006, 03:01   #2
drewbar
Sawg 2.0
Major Dude
 
Join Date: Mar 2004
Posts: 5,916
There is no stream connected to the server currently.

Count with us!
Jan 1st, 12AM (PST, GMT -8) 2010 - 282,246
drewbar is offline   Reply With Quote
Old 13th August 2006, 03:03   #3
lexis
Junior Member
 
Join Date: Jan 2006
Posts: 5
exactly my point. When I open nsvcap and start the capture process, should this not create the stream?
lexis is offline   Reply With Quote
Old 13th August 2006, 12:33   #4
sankt
Moderator
 
sankt's Avatar
 
Join Date: Apr 2003
Location: www.ScenicRadio.com
Posts: 2,975
Is your source computer ( not the shoutcast server host ) behind a router or firewall ?

Scenic Television is your ambient window to the world - - Television.ScenicRadio.com
sankt is offline   Reply With Quote
Old 13th August 2006, 16:40   #5
lexis
Junior Member
 
Join Date: Jan 2006
Posts: 5
Yes, it is on a network.
lexis is offline   Reply With Quote
Old 14th August 2006, 02:51   #6
hhb
Senior Member
 
hhb's Avatar
 
Join Date: Jan 2006
Posts: 133
You might try this to see if proper network ports are open:

http://www.radiotoolbox.com/online_t...ntheygetin.php

hhb
hhb is offline   Reply With Quote
Old 14th August 2006, 11:41   #7
john@ROCKNTV1
Registered User
 
john@ROCKNTV1's Avatar
 
Join Date: Apr 2006
Location: i have broken not a single rule and you deleted my sig craigF.. OK MY TURN CRAIGF and smelter thank for bumping bulks flame post
Posts: 641
remedy the pass word issue to start with and look for source to announce success at opening the pls/m3u file
....if you dont get sucess you arent sourcing
john@ROCKNTV1 is offline   Reply With Quote
Old 14th August 2006, 18:20   #8
lexis
Junior Member
 
Join Date: Jan 2006
Posts: 5
I am not sure about the pwd error as I am using the correct pwd. I have not gotten that error since. I am unable to connect to my home pc from the link provided. How do I open the port in my router/fw?
lexis is offline   Reply With Quote
Old 14th August 2006, 22:15   #9
sankt
Moderator
 
sankt's Avatar
 
Join Date: Apr 2003
Location: www.ScenicRadio.com
Posts: 2,975
You can get more information on router configuration here : www.scvi.net/router.htm

Scenic Television is your ambient window to the world - - Television.ScenicRadio.com
sankt is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast TV / Nullsoft Video

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump