Old 18th April 2017, 07:56   #1
weke
Junior Member
 
Join Date: Apr 2017
Posts: 2
Missing mapped drive letter on elevated Windows 10

I tested my own setup created with NSIS 3.01 on two machines. First on Windows 7 Pro 64Bit and on Windows 10 Pro 64 Bit.
Both use a network share created in a login script with the following command:
code:
net use N: \\MyServer\SharedFolder\


When I test the setup only on windows 7 the Drive N: could selected or entered manually as a Directory. On Windows 10 N: isn't allowed and was not shown in Drive List (only in NSIS, Drive N was shown in Explorer).

Is this a known bug or did I miss an Option in my script, which I coundn't found in the help files and forum?
The same behavior I could found with the official installer of NSIS 3.01.

Here my test script:
code:
!include "MUI2.nsh"
Name "Test Setup"
OutFile "Setup.exe"
InstallDir $PROGRAMFILES\test
InstallDirRegKey HKLM "Software\test" "Install_Dir"
RequestExecutionLevel admin
;--------------------------------
!insertmacro MUI_PAGE_WELCOME
!insertmacro MUI_PAGE_LICENSE license.txt
!insertmacro MUI_PAGE_DIRECTORY
!insertmacro MUI_PAGE_INSTFILES
!insertmacro MUI_PAGE_FINISH
!insertmacro MUI_LANGUAGE "English"
;--------------------------------
Section "Files"
SectionIn RO
SetOutPath $INSTDIR
File "install\ReadMe.txt"
WriteRegStr HKLM SOFTWARE\test "Install_Dir" "$INSTDIR"
SectionEnd

weke is offline   Reply With Quote
Old 18th April 2017, 12:04   #2
Anders
Moderator
 
Anders's Avatar
 
Join Date: Jun 2002
Location: ${NSISDIR}
Posts: 4,611
Mapped drives are not necessarily available to elevated processes, this is just how Windows works: https://support.microsoft.com/en-us/...als-in-windows

IntOp $PostCount $PostCount + 1
Anders is offline   Reply With Quote
Old 18th April 2017, 18:15   #3
weke
Junior Member
 
Join Date: Apr 2017
Posts: 2
Hi Anders,

thanks a lot, that is the result.
I'm wondering that I've got this behavior only with my win 10 and not with win 7 ??
I will check my configuration of both systems, but now I know what I have to look for.
weke is offline   Reply With Quote
Old 19th April 2017, 08:36   #4
broski
Junior Member
 
Join Date: Apr 2017
Posts: 31
Thanks Anders, It works fine now.
broski is offline   Reply With Quote
Old 19th April 2017, 12:39   #5
Anders
Moderator
 
Anders's Avatar
 
Join Date: Jun 2002
Location: ${NSISDIR}
Posts: 4,611
Quote:
Originally Posted by broski View Post
Thanks Anders, It works fine now.
For future reference, did you change the registry or some other hack to fix it?

IntOp $PostCount $PostCount + 1
Anders is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Developer Center > NSIS Discussion

Tags
mapped drive, share, smb, uac, unc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump