Old 6th January 2018, 09:22   #1
djmentos
Junior Member
 
Join Date: Jul 2009
Posts: 15
DNAS pidfile config variable does not accept $ sign

Hello,

I want to report bug related to DNAS, there are such entries in config file:
code:

logfile=/home/stream/domains/x.pl/logs/$_sc.log
w3clog=/home/stream/domains/x.pl/logs/$_w3c.log
banfile=/home/stream/domains/x.pl/control/$.ban
ripfile=/home/stream/domains/x.pl/control/$.rip
pidfile=/home/stream/domains/x.pl/configs/$.pid



But on DNAS view of config:
code:

adaptivebuffersize=10
adminpassword=KZ550207
banfile=/home/stream/domains/x.pl/control/18028.ban
buffertype=0
fixedbuffersize=1048576
logarchive=1
logfile=/home/stream/domains/x.pl/logs/18028_sc.log
logrotates=14
maxbitrate=128000
maxuser=300
password=kz550207
pidfile=/home/stream/domains/x.pl/configs/$.pid
portbase=18028
publicserver=never
relayreconnecttime=0
requirestreamconfigs=1
ripfile=/home/stream/domains/x.pl/control/18028.rip
unique=18028
w3clog=/home/stream/domains/x.pl/logs/18028_w3c.log



And there is also a file:
code:
# ls -la .. | grep pid
-rw-rw-rw- 1 stream stream 6 Jan 6 10:15 $.pid



So pidfile variable ignores variable sign. DNAS version: 2.5.5.733.
djmentos is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Bug Reports

Tags
bug, dnas

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump