Old 19th June 2017, 13:26   #1
Mircea M
Junior Member
 
Join Date: Aug 2014
Posts: 44
Issue with MessageBox /SD and goto parameters

Hi all,

I'm trying the following:
Quote:
MessageBox MB_ICONEXCLAMATION|MB_ABORTRETRYIGNORE "Update for Universal C Runtime installation finished with unknown Exit Code $0" /SD IDIGNORE done IDRETRY start
This throws an error:
Quote:
Usage: MessageBox mode messagebox_text [/SD return] [return_check label_to_goto_if_equal [return_check2 label2]]
mode=modeflag[|modeflag[|modeflag[...]]]
modeflag=(MB_ABORTRETRYIGNORE|MB_OK|
MB_OKCANCEL|MB_RETRYCANCEL|MB_YESNO|
MB_YESNOCANCEL|MB_ICONEXCLAMATION|MB_ICONINFORMATION
|MB_ICONQUESTION|MB_ICONSTOP|MB_USERICON|MB_TOPMOST|
MB_SETFOREGROUND|MB_RIGHT
As soon as I remove "/SD" the script compiles successfully. And idea why?
Thanks,
Mircea
Mircea M is offline   Reply With Quote
Old 19th June 2017, 14:32   #2
Anders
Moderator
 
Anders's Avatar
 
Join Date: Jun 2002
Location: ${NSISDIR}
Posts: 4,529
Invalid parameters? Syntax is [/SD IDx] [IDx label [IDx label]]

Quote:
MessageBox MB_ICONEXCLAMATION|MB_ABORTRETRYIGNORE "Update for Universal C Runtime installation finished with unknown Exit Code $0" /SD IDIGNORE IDIGNORE done IDRETRY start

IntOp $PostCount $PostCount + 1
Anders is offline   Reply With Quote
Old 19th June 2017, 14:48   #3
Mircea M
Junior Member
 
Join Date: Aug 2014
Posts: 44
OMG, in my face!

Thanks!
Mircea M is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Developer Center > NSIS Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump