Old 16th November 2008, 23:55   #1
jnyce01
Junior Member
 
Join Date: Nov 2008
Posts: 4
Send a message via AIM to jnyce01
Problem Editing ID3's...

well, I followed the guidelines for the forum, searched my problem and nothing came out of it so here goes.

Whenever I try to edit the tags on my mp3's, I constantly get this error:

"Cannot Save Metadata: Error Opening File"

I think it may have something to do with me reformatting my PC a month or so ago, because all the new mp3's I download, I'm able to edit without a problem, but all the ones I've had since the reformat I'm unable to edit. Also, all my music is on an external HD and I've tried editing my tags with WinAmp, WMP and other 3rd party editors, but to no avail..

If someone already has posted this problem, I sincerly apologize, but I attemped to search the forums and couldn't find anything under my error message.

If any of you guys have a fix or can offer help, IM me on AIM (jnyce01) if you want
jnyce01 is offline   Reply With Quote
Old 17th November 2008, 03:25   #2
marz045
Junior Member
 
Join Date: Jan 2008
Posts: 33
make sure the files you're trying to update are not 'read only' files. go to explorer right click a song file and click 'properties'. In 'Attributes' see whether the 'Read Only' checkbox is checked or not. if it is, unselect it. to do this to a whole folder, right click the folder go to 'properties' again unselect 'read only' (this time it may be a box and not a check mark, just unselect it, make sure the box is empty). click apply this time it'll ask you if you want to apply changes to this folder only or all its subfolders and files select the second one. then try editing the ID3 tags.
marz045 is offline   Reply With Quote
Old 17th November 2008, 14:32   #3
jnyce01
Junior Member
 
Join Date: Nov 2008
Posts: 4
Send a message via AIM to jnyce01
Quote:
Originally posted by marz045
make sure the files you're trying to update are not 'read only' files. go to explorer right click a song file and click 'properties'. In 'Attributes' see whether the 'Read Only' checkbox is checked or not. if it is, unselect it. to do this to a whole folder, right click the folder go to 'properties' again unselect 'read only' (this time it may be a box and not a check mark, just unselect it, make sure the box is empty). click apply this time it'll ask you if you want to apply changes to this folder only or all its subfolders and files select the second one. then try editing the ID3 tags.
ok I tried this and as soon as I uncheck the 'Read Only' box and apply the settings, I'll check back and the 'Read Only' box is checked again. I've tried this about 4-5 times and it happened each time. Is it something to do with my external HD perhaps? Also I'm using Vista, if that clears anything up or helps out.

Last edited by jnyce01; 17th November 2008 at 14:52.
jnyce01 is offline   Reply With Quote
Old 18th November 2008, 12:23   #4
jnyce01
Junior Member
 
Join Date: Nov 2008
Posts: 4
Send a message via AIM to jnyce01
nevermind...fixed it on my own, i didn't have full rights or access or whatever for my external hd
jnyce01 is offline   Reply With Quote
Old 27th December 2008, 12:11   #5
WeVe
Junior Member
 
WeVe's Avatar
 
Join Date: Jan 2006
Posts: 9
Quote:
Originally posted by jnyce01
nevermind...fixed it on my own, i didn't have full rights or access or whatever for my external hd
Actually I have the exact same problem now, so if you could tell me exactly how you worked it out with the persmissions etc. I'd be most thankful!
WeVe is offline   Reply With Quote
Old 27th December 2008, 13:32   #6
jnyce01
Junior Member
 
Join Date: Nov 2008
Posts: 4
Send a message via AIM to jnyce01
i forgot how or what I did, but just go to the properties for your external hd and basically give yourself all the rights and usages
jnyce01 is offline   Reply With Quote
Old 29th December 2008, 19:02   #7
WeVe
Junior Member
 
WeVe's Avatar
 
Join Date: Jan 2006
Posts: 9
I'm using a Lacie 1 TB external HD. I checked it for user rights, but there's no setting in Properties for user rights. If I select all containing folders and give all the needed read/write rights, it seems to work, but when I select them again, everything is read only again, so I can't seem to change this.

Can anyone tell me what to do (besides copying all my music to my PC's HD again :P) ?
WeVe is offline   Reply With Quote
Old 29th December 2008, 23:15   #8
GODJonez
Junior Member
 
Join Date: Dec 2008
Location: Finland
Posts: 38
I guess the problem was NTFS permissions; in the previous Windows installation the original user was given full access to the files, but in the new Windows the user ID is different, so the file permissions are to not allow writing.

If you are using Windows XP Home edition, then changing the rights is not so easy, you need to edit them in safe mode. In Windows XP Pro and in Vista (I guess it works in all versions) if you have simple file sharing disabled, you can edit the permissions of individual files and folders from the Properties.
GODJonez is offline   Reply With Quote
Old 30th December 2008, 19:22   #9
WeVe
Junior Member
 
WeVe's Avatar
 
Join Date: Jan 2006
Posts: 9
Quote:
Originally posted by GODJonez
In Windows XP Pro and in Vista (I guess it works in all versions) if you have simple file sharing disabled, you can edit the permissions of individual files and folders from the Properties.
That seems to work, but when I Apply and OK, I reopen the Properties and see that they're ReadOnly again.
How is that possible?
WeVe is offline   Reply With Quote
Old 30th December 2008, 19:24   #10
GODJonez
Junior Member
 
Join Date: Dec 2008
Location: Finland
Posts: 38
I am not referring to the "Read only" attribute, but user permissions, on Security tab. If the user permissions deny writing, then the "Read only" box will always have a checkmark on it, showing that the current user is not allowed to modify the file.
GODJonez is offline   Reply With Quote
Old 30th December 2008, 19:40   #11
WeVe
Junior Member
 
WeVe's Avatar
 
Join Date: Jan 2006
Posts: 9
Quote:
Originally posted by GODJonez
I am not referring to the "Read only" attribute, but user permissions, on Security tab. If the user permissions deny writing, then the "Read only" box will always have a checkmark on it, showing that the current user is not allowed to modify the file.
Ah ok.

Well, I tried giving everyone all permissions needed, but it does the same thing: it resets to original settings when I click OK.
WeVe is offline   Reply With Quote
Old 25th May 2009, 20:06   #12
geoffasaurus
Junior Member
 
Join Date: May 2009
Posts: 1
Hey all,

Sometimes its a simpler solution than it seems. For those of you running Vista and not able to make changes to ID3 tags, simply run Winamp as an administrator. This gives you the necessary permissions to edit the ID3 tags (even if your account is an admin account you still need to specifically run Winamp itself as an administrator)

To run Winamp (or any other program) as an admin, you need to find either the .exe file of the program, or the shortcut, or start menu entry. Right click on "Winamp" and select properties. Under the compatibility tab, select 'Run as Administrator'. Close the dialogue box and start the program up as usual. You will be prompted to give winamp permission to continue. Click accept, and happy editing!
geoffasaurus is offline   Reply With Quote
Old 10th January 2012, 14:59   #13
gerg-uk
Junior Member
 
Join Date: Jan 2012
Posts: 1
Big thanks to geoffasaurus as I was having the same problem in Windows 7!
gerg-uk is offline   Reply With Quote
Old 25th June 2012, 04:41   #14
Gabe84
Junior Member
 
Join Date: Jun 2012
Posts: 1
I was getting so frustrated with this problem, an then I found this thread and geoffasaurus' solution worked perfectly!
Gabe84 is offline   Reply With Quote
Old 23rd August 2012, 12:00   #15
ianbule
Junior Member
 
Join Date: Aug 2012
Posts: 1
i solve the problem

first Go to the folder contain music or file
- Go to PROPERTIES
- Open Security tab
- Go to group or user name
- Edit group or user name
- Check box full control ("allow")
- Apply and ok

taraaaaaaaaaaaa now u can edit id mp3....
i recomended u to us tag & rename sofware. u can edit perfectly
ianbule is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump