Old 8th November 2010, 13:49   #1
Yathosho
Forum King
 
Yathosho's Avatar
 
Join Date: Jan 2002
Location: AT-DE
Posts: 3,353
AVS 2.83 is killing me

i just noticed that avs 2.83 (is this the latest version?) no longer comes with version resource (2.81b did), which puts me into a horror scenario. pimpbot installers (and maybe others) rely on that version resource in order to check which plugins (APEs) to install and to avoid duplicates.

avs 2.7 (and older) had no version resource included either, but they also didn't have any APEs integrated (channelshift, colorreduction, multiplier, videodelay). i have never upgraded from 2.81b (and don't plan to do so) and i did expected some consistency in the avs sources.

please fix this in an upcoming version AND please stick to that! i'm not willing to add a workaround to pimpbot everytime the winamp-devs make a mistake! while you're at it, add a version resource to milkdrop and maybe all other plugins, it's a good common practice to do that - and it might be needed in the future.
Yathosho is offline   Reply With Quote
Old 8th November 2010, 14:43   #2
Yathosho
Forum King
 
Yathosho's Avatar
 
Join Date: Jan 2002
Location: AT-DE
Posts: 3,353
ps: cockos happy is labeled 2.9, but the version resource is set to 2.7.9.2. this mistake is still better than having no version - it won't break installers
Yathosho is offline   Reply With Quote
Old 8th November 2010, 14:59   #3
DrO
 
Join Date: Sep 2003
Posts: 27,880
there's no point as 2.8.whatever should really be removed. as for there being the 2.9 from justin, it's just adding to the confusion as now there's too many versions floating about without any standardisation - should just be one version with related fixes, etc and have it done like that or did i miss something with open sourcing most of the source code (only difference with the officially shipped version is localisation and incompatibility with unsupported apes).

if the one officially bundled could be fixed to work ok without having to do weird VC6 compiles (ideally VS2008) then maybe someone would add a version resource back (though only the main .exe and a few ml plug-ins inconsistently do it with later 5.5x builds).

also the resource was removed since no one remembered to update it with the later 2.8x builds and the build system kept mangling the resource so it was simpler to just remove the resource than have it reporting it was the same version as winamp.exe (which i'm sure you'd find even more annoying). that's what i remember being the reason for the removal 3+ years ago.

really AVS should be made an optional download from the installer for legacy purposes due to the issues and lack of support of it but that's just my view. either way i'm sure you're not going to be happy with this response but no one else bothers with AVS now (was tempted to not bother replying in all honesty).

-daz
DrO is offline   Reply With Quote
Old 8th November 2010, 16:27   #4
Warrior of the Light
Forum King
 
Warrior of the Light's Avatar
 
Join Date: Aug 2002
Location: The Netherlands
Posts: 4,051
Ideally, the default version would be the update Justin promised with a fixed rand() function (and perhaps more?)

Jesus loves you [yes, you] so much, he even died for you so that you will not need to die, but live forever
Warrior of the Light is offline   Reply With Quote
Old 8th November 2010, 16:34   #5
DrO
 
Join Date: Sep 2003
Posts: 27,880
the ideal would be AVS using ns-eel2 (as 2.9 does i believe) with all required bug fixes (and the guarantee that it doesn't break support with existing apes so people don't moan about their presets not working or it crashing all the time) and being correctly localised (so it's consistant with the rest of the Winamp support).

-daz
DrO is offline   Reply With Quote
Old 28th January 2011, 20:04   #6
GuiTwo
Junior Member
 
Join Date: Jun 2010
Location: In a house
Posts: 10
Send a message via MSN to GuiTwo
I had the avs 2.81d
now I downloaded the new winamp that comes with 2.83
and I'm having some problems with eeltrans.ape (trans/autonomation), and conv.filter doesn't work
okay, I have the 2.81d saved, so let's replace...
but winamp crashes always when I start avs
c'mon, I won't use milkdrop!
GuiTwo is offline   Reply With Quote
Old 29th January 2011, 09:02   #7
Yathosho
Forum King
 
Yathosho's Avatar
 
Join Date: Jan 2002
Location: AT-DE
Posts: 3,353
Quote:
Originally Posted by GuiTwo View Post
I had the avs 2.81d
now I downloaded the new winamp that comes with 2.83
and I'm having some problems with eeltrans.ape (trans/autonomation), and conv.filter doesn't work
no news here, 2.82 and 2.83 are unusable. stick with 2.81b or give 2.9 a try
Yathosho is offline   Reply With Quote
Old 29th January 2011, 17:04   #8
GuiTwo
Junior Member
 
Join Date: Jun 2010
Location: In a house
Posts: 10
Send a message via MSN to GuiTwo
I tryed the 2.9 but still crashing
if 2.83 are unusable why the guys of winamp still using it?
oh, programming a dll is so hard... why they don't fix it?
lazyness, better things to do, lazyness
GuiTwo is offline   Reply With Quote
Old 29th January 2011, 17:26   #9
DrO
 
Join Date: Sep 2003
Posts: 27,880
because no one has a compiler setup that builds it properly anymore as reading existing posts would have shown. if you know so much if 'oh, programming a dll is so hard' doesn't apply to you (why else say something like that) then get the source code and fix things yourself. simple enough really.

either way, AVS is just a complete mess especially if there's a forked v2.9 based on ns-eel2 (which most likely can be built with newer MS compilers than 2.8x which requires MSVC6) and that there's no source code for most of the apes which cause the crashes.

personally, i think it should just be removed from the distro and provided as an external download as there's no interest to work on it and obviously my attempts in the past haven't worked out leading to more issues *shrugs*

-daz
DrO is offline   Reply With Quote
Old 29th January 2011, 17:57   #10
GuiTwo
Junior Member
 
Join Date: Jun 2010
Location: In a house
Posts: 10
Send a message via MSN to GuiTwo
regrettable situation
now I don't have enough knowledge but maybe I will, I want
sorry I haven't read existing posts, I have 56K connection
GuiTwo is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Visualizations > AVS

Tags
avs, pimpbot, version, vis_avs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump