Old 22nd May 2011, 13:06   #1
TheRealPhoneCall
Junior Member
 
Join Date: May 2011
Posts: 2
Unhappy I need help about this issue.

I was arranging my song files and try putting them on organized folders. Then I realized my tracks on the playlists I made (and as well as the songs in my library) aren't playing anymore. I figured that it is due to my re-arranging of song locations. Now, can somebody help me (suggest, recommend, or anything) about a fast way to recover those songs in the playlist that I made? I got a lot of playlists that aren't working anymore because of that and it's very tedious to remake them all again. Any response will be very much appreciated and please let me know if this question doesn't make sense (because I'm new to Winamp). THANKS!
TheRealPhoneCall is offline   Reply With Quote
Old 27th May 2011, 22:25   #2
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,609
Send a message via AIM to MrSinatra
fyi: this sub forum is for the website, you wanted to post this in "tech support"

you might be out of luck. playlists work by knowing where the file is, so you might have to open them in a text editor and manually fix them. some playlists use "absolute" paths where the whole path is "hardcoded" like:

C:\music\file.mp3

some use "relative" paths. you'll have to read up on this on wikipedia, b/c i'm not a playlist expert.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 30th May 2011, 17:37   #3
TheRealPhoneCall
Junior Member
 
Join Date: May 2011
Posts: 2
...lots of thanks for your answer! I also figured that same way to solve this using winamp too: that is, changing the playlist entry of the song and manually fix it using the exact new location of the file. It works, but it could get tedious because I'll have to do that individually with the songs. Worst is that I rearanged the folders in a tricky manner

Anyway, I guess I'll switch back to remaking the playlist again. My only problem for that is that the songs in my library aren't playing anymore too...and it keeps pissing me off. Foolishly however, I didn't realize in the first place, that a simple way to repair this is to re-import the newly organized song files (and delete all the dead files) in the library so that all the songs in there are working. That way, it will just be some note taking, copy pasting, and drag and dropping.

Anyway, I'm talking too much now. I just dug in to the technicalities just newly. I really appreciate your response MrSinatra.


(and apologies for posting in the wrong place ^^)
TheRealPhoneCall is offline   Reply With Quote
Old 30th May 2011, 17:46   #4
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,609
Send a message via AIM to MrSinatra
personally, i don't use playlists much. i like "smartviews" which can dynamically create de facto playlists. unfortunately as per my sig, the smartview maker is broken, but it'll be fixed next release i'm sure.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Site Design

Tags
damaged tracks, not playing tracks, song files

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump