Old 22nd January 2011, 14:19   #1
scottandtisha
Junior Member
 
Join Date: Jan 2011
Posts: 1
Extremely Slow Sync

I have searched on these forums but have only discovered one other person who has expressed that syncing to their phone is extremely slow (and that was several months back). I have a Dinc and I'm syncing ~450 songs to my phone from Winamp. It is taking 60-90 minutes. This seems outlandishly long to me. If this is consistent, I'm afraid it'll be a deal-breaker for me. Are there any settings I can check/change or diagnostic tools I can use to try to discover the source of my problem.

For what it's worth, the delay doesn't seem to be the transfer itself (~5 seconds), but there appears to be a lag between the finishing of one song (Done) and the starting of the next transfer (where it says Starting Transfer). This lag is about 15 seconds.

I am running Winamp 5.601 on Vista w/ quad-core 2 machine with 6 GB of RAM.

I'm also wondering if subsequent syncs include only changes to my playlists or if it syncs ALL songs again. I certainly can't wait like this every time.

Thanks in advance,

Scott
scottandtisha is offline   Reply With Quote
Old 23rd February 2011, 04:02   #2
upchuck605
Junior Member
 
Join Date: Feb 2011
Posts: 1
Slow Transfer on EVO

I am also experiencing extremely slow USB transfer rate on my htc EVO. I am trying to transfer my library (approx. 4200 songs) to a 32GB microSD in my evo, but I am seeing a transfer time from 280 mins (I hope it's mins) to over 1000 mins (I REALLY hope it's mins). Is this typical? I would have thought that transfer by USB would be much faster than this. I agree with the OP that the transfer itself doesn't seem to be the problem, but rather there seems to be a large delay between transferring songs. Is there some setting that needs to be adjusted?

Phone is htc EVO running Android 2.2; computer is Dell vostro 1510 Core 2 Duo with 4GB RAM running Vista vista home basic. Winamp version 5.6, Winamp for Android version 0.9.2. Please help.
upchuck605 is offline   Reply With Quote
Old 11th March 2011, 23:28   #3
soullesssoldier
Junior Member
 
Join Date: Apr 2009
Posts: 32
USB sync is also painfully slow for me on my X10a Android 2.1. The problem is the same as the OP with the delay in between Done and the next transfer.

The problem, as I have confirmed, is related to the album art. If the songs have no art then it will sync perfectly fast, but if there is art, and in my case a single .jpg in the album folder, it will have the huge delay which I assume has to do with trying to embed the art into the song or something.

Winamp Team, please provide us with a fix for this problem. I would prefer not having to delete all my album art or to manually embed all my songs with art.

Edit: At least WIFI Sync doesn't suffer from this problem. Winamp Team, can you update the pmp_usb to work the same as the pmp_wifi?
soullesssoldier is offline   Reply With Quote
Old 15th March 2011, 04:47   #4
mucdude
Junior Member
 
Join Date: Mar 2011
Posts: 3
I have the same problem with my Nexus One. Fast transfer but has a 10 sec. delay between song transfers.

This is regardless if my Nexus in Connected via USB or I have the SD Card in my Laptop's card reader.

Please fix this, as Winamp is the best program to manage my music collection!

Thanks
mucdude is offline   Reply With Quote
Old 22nd March 2011, 19:01   #5
e10kstarfire
Junior Member
 
Join Date: Mar 2011
Posts: 1
Got the same problem here with a HTC desire.

Extremely slow sync via USB. The actual transfer is fast but then it sits there on "Done" for a number of seconds, sometimes longer, before moving on to the next song. Sometimes, rarely, it will transfer a number of songs quickly but then go slow again.

I can sync songs via Windows Media Player very fast and also transfer large files via copy/paste in Windows with no issues so this does look like a Winamp issue - how can it be fixed/resolved? (running latest 5.61)

Thanks!
e10kstarfire is offline   Reply With Quote
Old 15th August 2011, 14:07   #6
soullesssoldier
Junior Member
 
Join Date: Apr 2009
Posts: 32
Resurrecting an old thread in hopes of a Winamp dev seeing it and maybe helping get this fixed. Recently upgraded my X10 to android 2.3.3 with the most recent Winamp 5.621 and this issue still persists.
soullesssoldier is offline   Reply With Quote
Old 31st August 2011, 16:30   #7
InsanityOnABun
Junior Member
 
Join Date: Aug 2011
Posts: 5
I'm having this problem as well, on my HTC Incredible 2 running Cyanogenmod 7. Any updates on it would be appreciated.
InsanityOnABun is offline   Reply With Quote
Old 6th September 2011, 01:08   #8
Patman27
Junior Member
 
Join Date: Sep 2011
Posts: 2
Hate to just add to the pile, but...

I'm having the exact same problem while synchronizing either my HTC Inspire 4G (Desire HD) or my Sony PSP 1001 (fat). As soullesssoldier said, it seems to have everything to do with whether there is album art for the album or not. Again, just a "Folder.jpg" in the folder will really make it take a long time.

Winamp Devs, please look into this issue!

The only aftermarket plugin I have installed is Lyrik, and I'm running Winamp v5.621 (x86) from Jul 11, 2011 on an HP EliteBook with Windows 7 Professional.
Patman27 is offline   Reply With Quote
Old 6th September 2011, 03:32   #9
Patman27
Junior Member
 
Join Date: Sep 2011
Posts: 2
Just confirmed, the problem is the album art. Halfway through a slow-as-molasses album transfer, I moved the "Folder.jpg" from inside the album folder to one level above in the hierarchy. All of a sudden, it took off. By the time I finish this post, it'll - ... nevermind. Just finished.
Patman27 is offline   Reply With Quote
Old 14th September 2011, 00:19   #10
JohnnyUK
Junior Member
 
Join Date: Sep 2011
Posts: 1
Wow, this bug is still in here? I ditched winamp for syncing around 4 months ago, figured it'd be sorted in a later release. This has got to be a quick and easy paper cut to fix? o_O
JohnnyUK is offline   Reply With Quote
Old 10th October 2011, 09:54   #11
bipolarchucker
Junior Member
 
Join Date: Dec 2010
Posts: 3
Frustrating!

I have an HTC Desire running Oxygen 2.3 (Android 2.3.7) which exhibits the same symptoms as the OP's phone. The same was true with stock Android 2.2 as well as Android 2.3.4 and 2.3.5 on Oxygen.

I confirm that removing the folder.jpg file from the source folder (on disk) that the files are being transferred from immediately resolves this slow sync problem - the obvious side effect is that transferred tracks are devoid of their artwork.

This would be a great thing to fix!
bipolarchucker is offline   Reply With Quote
Old 16th January 2012, 23:32   #12
t0k3n98
Junior Member
 
Join Date: Jan 2012
Posts: 1
I would like to bump this thread, because I just got winamp and this process is taking entirely too long. To sync 619 songs it telling me its going to take 162 minutes! This seems like a bit much especially for the amount of time it takes for it to start syncing the next song...
t0k3n98 is offline   Reply With Quote
Old 17th January 2012, 01:55   #13
rayanbb
Junior Member
 
Join Date: Jan 2012
Posts: 9
are you using a usb 1.1 or 2 connection?

if you are using a 1.1 it will take quite a while
rayanbb is offline   Reply With Quote
Old 29th January 2012, 23:35   #14
sspikey
Junior Member
 
Join Date: Dec 2005
Posts: 3
yup same here
fix this and ill buy the pro version ONLY for the synching
yeah its that big of a deal for most of us
sspikey is offline   Reply With Quote
Old 29th June 2012, 14:57   #15
ThermoGel420
Junior Member
 
Join Date: Jun 2012
Posts: 1
Slow sync

Has anyone found a solution to this problem? I am syncing 435 songs and it says it will take 460 min. I have a 16GB class 10 micro sd card in my droid incredible.
ThermoGel420 is offline   Reply With Quote
Old 11th March 2013, 03:33   #16
yoghurtgoblin
Junior Member
 
Join Date: Jun 2005
Posts: 8
Bump! HTC Desire...class 10 SD card, but same problem: ridiculously slow transfer speeds on USB cable. Seems to pause between songs for ages. Moving album art for hundreds of albums is not a realistic possibility. Any other solution?
yoghurtgoblin is offline   Reply With Quote
Old 21st April 2013, 01:30   #17
EZSaturdayPM
Junior Member
 
Join Date: Apr 2013
Posts: 2
Thumbs down

Crazy that there is zero response after 2 years. I would gladly pay good money for a windows app that would sync to my Samsung S3 and the "8 second pause for every track you sync with album art feature" makes it literally impossible to load my new phone. Even with the microSD card out of the phone and in the reader of my laptop.

Anyway, I couldn't find another app that would do what I needed so I emptied my Recycle Bin, searched my music folder for *.jpg files, and deleted the 3,600 it found. Then I sync'd about 30 GB of music using my good old Winamp in a reasonable amount of time and went back to the Recycle Bin and "restored" everything so the art is back.

I'm running gonemad on my phone (happy to pay for stuff that works) and it grabs album art so fast it doesn't matter at all that I couldn't sync the pics, was just a huge pain..

A million thanks for the users above who figured out it is the album art!!!! I'd would have smashed my computer by now!
EZSaturdayPM is offline   Reply With Quote
Old 21st April 2013, 13:17   #18
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
It'll be because we embed the album art on usb transfers (pmp_android),
so the delay will be occurring whilst it's embedding the art into every file....
whereas we just copy over one external %album%.jpg file per album with wifi transfers.

Maybe 'embed art' should be an option instead, and off by default....?

Though we still also need to address the issue where album.jpg files end up appearing in the Gallery,
where the likely solution would be to transfer them with an extension that isn't recognized by the Android media scanner (e.g. album.art).
I think our workaround for this was to embed the art instead...

I will bring this thread to the relevant devs' attention tomorrow.
DJ Egg is offline   Reply With Quote
Old 21st April 2013, 21:33   #19
EZSaturdayPM
Junior Member
 
Join Date: Apr 2013
Posts: 2
Thumbs up

Quote:
Originally Posted by DJ Egg View Post
It'll be because we embed the album art on usb transfers (pmp_android),
so the delay will be occurring whilst it's embedding the art into every file....
whereas we just copy over one external %album%.jpg file per album with wifi transfers.
Doh, didn't even think. I always use wifi, I changed methods just for this one huge sync and later never thought to try the wifi.

Quote:
Maybe 'embed art' should be an option instead, and off by default....?
Sounds perfect to me.


Quote:
I will bring this thread to the relevant devs' attention tomorrow.
Very cool, thanks DJ! Winamp has been my #1 for a LONG time (a lot of free years at first!) and I'm a developer too so I shouldn't be so whiny.

I think I was offended because my first workaround was to taint my machine with *cough* Windows Media Player 12 *cough* only to discover (the hard way) that it syncs the .mp3s, but will not send your actual bleeping playlists to the phone! Manually moving the playlists fails because Media Player changes the folder structure when it writes the mp3s to the phone! Can't manage music on the phone with no bleeping playlists.
EZSaturdayPM is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp for Android

Tags
latency, slow, transfer

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump