Old 23rd May 2015, 12:22   #1
makinistfanlari
Junior Member
 
Join Date: May 2015
Posts: 6
No One Can Connect To My Server! Help.

I opened a shoutcast server to my computer. I can connect to my own server via using google chrome with my hamachi IP. How I can connect with my normal IP? Because my other friends cannot connect to broadcast. Thanks for support. (I am using SAM2 with shoutcast server)
makinistfanlari is offline   Reply With Quote
Old 23rd May 2015, 16:58   #2
neralex
Major Dude
 
Join Date: Mar 2011
Posts: 576
You must open the port in your router, where the DNAS is running.

http://wiki.winamp.com/wiki/SHOUTcas...ything_Else.3F

http://portforward.com/english/routers/port_forwarding/
neralex is offline   Reply With Quote
Old 23rd May 2015, 17:12   #3
makinistfanlari
Junior Member
 
Join Date: May 2015
Posts: 6
Quote:
Originally Posted by neralex View Post
I already opened an UDP Port 8888 (my port).
makinistfanlari is offline   Reply With Quote
Old 23rd May 2015, 18:53   #4
makinistfanlari
Junior Member
 
Join Date: May 2015
Posts: 6
I opened the following ports:

TCP 8000-8001

UDP 8000-8001

still not working on my normal IP. works on my hamachi and local IP.
makinistfanlari is offline   Reply With Quote
Old 24th May 2015, 05:38   #5
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
connecting to external IP from internal network wont work on most routers because they don't do loopback on port forwarding

don't worry if you don't understand what I just said, just get someone not on your LAN to test for you ... or learn basic networking, which I would say is a must if you're going to host services, but that's just my opinion -then you may know that forwarding UDP ports is not required for DNAS, and forwarding port 8001 is probably not required unless you're sourcing the stream from outside your LAN and using legacy DNAS (i.e. not DNAS 2)

"If you don't like DNAS, write your own damn system"

So I did
jaromanda is offline   Reply With Quote
Old 24th May 2015, 08:04   #6
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,021
Send a message via Skype™ to thinktink
https://www.google.com/search?q=Remo...utf-8&oe=utf-8

Use one of the listed services (probably the first one) to check if your router is actually forwarding your port correctly. Do it while you have the DNAS running.
thinktink is offline   Reply With Quote
Old 24th May 2015, 09:55   #7
makinistfanlari
Junior Member
 
Join Date: May 2015
Posts: 6
Says "Port 8000 is closed ..." . I can only connect with my localIP and hamachi IP. (I opened port ^^)
makinistfanlari is offline   Reply With Quote
Old 24th May 2015, 12:08   #8
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
Quote:
Originally Posted by makinistfanlari View Post
Says "Port 8000 is closed ..." .
then it's not opened
Quote:
Originally Posted by makinistfanlari View Post
(I opened port ^^)
no you didn't ^^

"If you don't like DNAS, write your own damn system"

So I did
jaromanda is offline   Reply With Quote
Old 24th May 2015, 14:03   #9
makinistfanlari
Junior Member
 
Join Date: May 2015
Posts: 6
Quote:
Originally Posted by jaromanda View Post
then it's not opened

no you didn't ^^
makinistfanlari is offline   Reply With Quote
Old 24th May 2015, 14:42   #10
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
looks like you've opened port 8000 and redirected it to 8001 to me - that's what 8000->8001 looks like

are you sure you've selected 8000 and 8001, and forwarded them to the correct LAN ip address (the ip address of the computer running DNAS)


edit: maybe I wasn't clear earlier, whilst it makes no difference, there's really no reason to do anything with UDP regarding port 8000 (or 8001)

"If you don't like DNAS, write your own damn system"

So I did
jaromanda is offline   Reply With Quote
Old 24th May 2015, 14:49   #11
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
Quote:
Originally Posted by makinistfanlari View Post
I opened the following ports:
you need to FORWARD the ports from WAN to a SPECIFIC LAN ip address

"opening" ports is meaningless in this context

post a screenshot of your router port forwarding page where you've forwarded the ports

"If you don't like DNAS, write your own damn system"

So I did
jaromanda is offline   Reply With Quote
Old 25th May 2015, 14:49   #12
makinistfanlari
Junior Member
 
Join Date: May 2015
Posts: 6
Uhh.. My modem doesnt accept new ports. I tried to open for Minecraft, it ignored again. Theres a problem with my modem. (I have one more in the house) I will try with the other modem.
makinistfanlari is offline   Reply With Quote
Old 25th May 2015, 16:21   #13
DrO
 
Join Date: Sep 2003
Posts: 27,873
you will probably be better off using a hosting service than trying to run the DNAS on your own home setup (especially if you're not being able to make the DNAS accessible to the internet - which depending on the country and ISP you're using may not allow you to do what you're trying to do anyway).
DrO is offline   Reply With Quote
Old 18th September 2015, 23:40   #14
mast
Junior Member
 
Join Date: Sep 2015
Posts: 2
hello ,
i am new to this forum. i have setup a shout cast server with static ip , i open the required port. now any machine connected to same network can get access to stream while no body els can get access .i disabled the firewall on my server and on the router. but it did not work.
if any body can help?

____________________________________________

[Moderator comment]

Double-posted and responded to here
http://forums.winamp.com/showthread.php?t=382467
mast is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump