Old 26th November 2002, 23:03   #1
sweetooth
Junior Member
 
Join Date: Nov 2002
Posts: 3
Streaming variable bitrate ogg vorbis files

Winamp 3 both release version and Winamp3 Developer Build #491 crash when playing a variable bitrate ogg vorbis file that is being streamed. The crash effect is a long hang with no responsivness from the application, failure to repaint etc. The application can only be killed at this point. Playing the same file locally doesn't crash the player but the player doesn't display the bitrate as it changes, just the first rate it determines. The same files play locally and stream properly using Winamp 2.
sweetooth is offline  
Old 26th November 2002, 23:36   #2
peter
ist death
 
peter's Avatar
 
Join Date: May 2000
Posts: 3,704
supposedly fixed for #492. you should be able to "workaround" it by deleting cnv_mp3pcm.wac (which is taking over all http:// streams).
peter is offline  
Old 26th November 2002, 23:48   #3
sweetooth
Junior Member
 
Join Date: Nov 2002
Posts: 3
I'll definatly give that a try here in a little bit. Sorry if this was already posted, I searched for similar topics but didn't find what I was looking for.
sweetooth is offline  
Old 27th November 2002, 00:18   #4
sweetooth
Junior Member
 
Join Date: Nov 2002
Posts: 3
Removing (I actually just renamed the file .old) cnv_mp3pcm.wac stopped any mp3 files from playing from an http stream, and variable bitrate oggs still wouldn't play causing winamp to crash. I did a little more testing and encoded a few fixed rate vorbis files. None of those would play streamed either.
sweetooth is offline  
 
Go Back   Winamp & Shoutcast Forums > Winamp3 > Winamp3 Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump