Old 12th June 2006, 16:36   #1
aircav
Junior Member
 
Join Date: Jun 2006
Posts: 2
SLOW song changes, lags comp

hey i've been using winamp since winamp 3, and i just downloaded winamp 5 (the newest one like .23 or something), and every time it changes songs, whether i'm playing BF2 or browsing the web, it lags up my computer and i cant type or do anything for about 3-5 seconds. i do NOT use any 3rd party programs, but i do use the clearONE skin.

if this helps, heres the jist:
win xp sp2
amd 3700+
nvidia geforce 7600 gt
2gb ram


so my computer is more than qualified to handle multiple processes at once. does anyone know whats going on?

crossfade is also on, if that makes a difference.

thanks
aircav is offline   Reply With Quote
Old 12th June 2006, 16:56   #2
TheUniqueTiger
Senior Member
 
Join Date: Mar 2006
Location: India
Posts: 431
Have you tried disabling crossfade?
Also try setting a buffer length more than the crossfade time. (you must probably have DirectSound output selected), also try setting a larger 'bufer ahead on track change' in the same dialog box (full, if that works for you)

Also try setting the priority to High in Prefs->General Preferences->Priority class.

You have only One Life... So before You are History, make sure you get into History books. - TheUniqueTiger
My personal website, HiFiBB ... Simply Hifi!, HiFiBB
TheUniqueTiger is offline   Reply With Quote
Old 12th June 2006, 17:32   #3
aircav
Junior Member
 
Join Date: Jun 2006
Posts: 2
aight... i disabled crossfade but it still was really laggy, so i went to directsound (yes thats the output i'm using ^^) and i set the buffer ahead on track change to 500 (from 100), and changed the buffer length to 800 (from 2000)... its a bunch better now, but still lags for about a second, i guess its more a minor annoyance now :/

any other suggestions?
aircav is offline   Reply With Quote
Old 12th June 2006, 20:26   #4
TheUniqueTiger
Senior Member
 
Join Date: Mar 2006
Location: India
Posts: 431
I meant to change the 'buffer-ahead' to full. In your case I think let the buffer-length be 1000ms (default:2000ms) & the 'buffer-ahead' be also 1000ms (default:500ms)
You may also check 'Enable CPU usage control' in the same window. Remember for crossfade, the crossfade time should always be less than buffer-length.

You have only One Life... So before You are History, make sure you get into History books. - TheUniqueTiger
My personal website, HiFiBB ... Simply Hifi!, HiFiBB
TheUniqueTiger is offline   Reply With Quote
Old 16th June 2006, 17:54   #5
gameplaya15143
Major Dude
 
gameplaya15143's Avatar
 
Join Date: Apr 2005
Location: Earth
Posts: 753
to stop/prevent winamp from doing that, you have to set the priority to normal, and the priority of each input plugin to normal (most are on high, this is to prevent other programs from making your music 'skip')
gameplaya15143 is offline   Reply With Quote
Old 20th November 2009, 20:06   #6
mario0318
Junior Member
 
Join Date: May 2008
Location: within the State
Posts: 30
Send a message via AIM to mario0318
I know this is an old post but having had the same issue with Winamp and searching for the terms on google drew me to this thread and others might be interested to know how I fixed it.

For some reason, sometimes the Winamp sound Output plug-in for DirectSound has the option to Enable CPU usage control set to enabled. In my case this actually slows down my computer for some seconds on each track change, and even longer when closing Winamp. Unchecking this option fixes the problem.

Just thought I might post this since only the high buffer solution was mentioned but did not work for me.

In my lifetime, we've gone from Eisenhower to George W. Bush.
We've gone from John F. Kennedy to Al Gore.
If this is evolution in terms of leadership, I believe that in twelve years we'll be voting for plants.
mario0318 is offline   Reply With Quote
Old 20th November 2009, 21:27   #7
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,341
CPU usage control is experimental (also labeled as experimental) and if I can remember, it's unchecked by default.

But maybe your info is useful for other people, who mistakenly enabled this option and have performance issues, because of it.
Koopa is offline   Reply With Quote
Old 20th November 2009, 23:52   #8
mario0318
Junior Member
 
Join Date: May 2008
Location: within the State
Posts: 30
Send a message via AIM to mario0318
Well, I think the problem with my setup is that I backup my Winamp configuration, in AppData, then I replace it whenever I reinstall Windows. I think sometimes that setup changes some things around, and for me sometimes it includes that CPU thing enabled.

In my lifetime, we've gone from Eisenhower to George W. Bush.
We've gone from John F. Kennedy to Al Gore.
If this is evolution in terms of leadership, I believe that in twelve years we'll be voting for plants.
mario0318 is offline   Reply With Quote
Old 2nd February 2012, 17:39   #9
impulse439
Junior Member
 
Join Date: Feb 2012
Posts: 1
Winamp still lagging

I still seem to be having this Problem, Winamp was working perfectly 2 days ago then all of a sudden it started to have these problems. I have done nearly everything to make this stop but to no avail
impulse439 is offline   Reply With Quote
Old 19th October 2013, 00:11   #10
Rafael_C_V
Junior Member
 
Join Date: Oct 2013
Posts: 1
Mostly problems like this, can be any damaged or not well done plugin.
Mine happened it with a plugin called gen_mirc.dll, "I noticed at the list, was showing like "not loaded".
After rename the file for "gen_mirc.dll.back" all is back to normal, no more "freeze" at change musics.
Rafael_C_V is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump