Old 12th July 2008, 05:15   #1
dypsis
Junior Member
 
Join Date: May 2008
Posts: 45
Last.fm/Audioscrobbler Plugin

Does Winamp have a Last.fm/Audioscrobbler Plugin?

I did a search of the plugins, but it returned nothing.
dypsis is offline   Reply With Quote
Old 12th July 2008, 14:40   #2
Kaminari
Junior Member
 
Kaminari's Avatar
 
Join Date: Mar 2003
Location: Paris, France
Posts: 49
Surprise:

code:
http://last.fm/download/
Kaminari is offline   Reply With Quote
Old 13th July 2008, 09:36   #3
dypsis
Junior Member
 
Join Date: May 2008
Posts: 45
I am only interested in a standalone plugin like some other players that I use have.
dypsis is offline   Reply With Quote
Old 13th July 2008, 09:50   #4
DrO
 
Join Date: Sep 2003
Posts: 27,880
http://nunzioweb.com/daz/AudioScrobb...oscrobbler.dll (though is provided as is with no support)

-daz
DrO is offline   Reply With Quote
Old 13th July 2008, 10:07   #5
dypsis
Junior Member
 
Join Date: May 2008
Posts: 45
Thanks DrO. Brilliant work. It is exactly what I am looking for.

And it is working well for me. Even better than some of the other players plugins that I use.
I thought there would be more requests for this.

BTW. I didn't notice it displayed on your site.
dypsis is offline   Reply With Quote
Old 13th July 2008, 11:45   #6
DrO
 
Join Date: Sep 2003
Posts: 27,880
it's an unofficial modification though it's been posted around the net a fair bit from what i've seen (even had someone do a blog post about it in the thread referenced) but was mainly for my own use so doesn't fall under the normal notification on my release pages

-daz
DrO is offline   Reply With Quote
Old 13th July 2008, 11:58   #7
dypsis
Junior Member
 
Join Date: May 2008
Posts: 45
Quote:
Originally posted by DrO
it's an unofficial modification though it's been posted around the net a fair bit from what i've seen (even had someone do a blog post about it in the thread referenced) but was mainly for my own use so doesn't fall under the normal notification on my release pages

-daz
So is this mod going to become official? It should do. I love it.
dypsis is offline   Reply With Quote
Old 13th July 2008, 12:01   #8
DrO
 
Join Date: Sep 2003
Posts: 27,880
no idea since they're still pushing the 1.1.10 old version on their site despite the tweaked 1.1.11 i did being referenced and now with that newer tweak plus if they're services, etc are meant to be changing there's no point until a newly rebuilt/updated plugin is made (which i doubt i'm ever going to personally do now)

-daz
DrO is offline   Reply With Quote
Old 14th July 2008, 12:27   #9
Kaminari
Junior Member
 
Kaminari's Avatar
 
Join Date: Mar 2003
Location: Paris, France
Posts: 49
And remember the standalone plugin is not Unicode compliant.
Kaminari is offline   Reply With Quote
Old 15th July 2008, 11:31   #10
samthepeach
Junior Member
 
Join Date: Jul 2008
Posts: 3
ah... Thanx for that one DrO.
samthepeach is offline   Reply With Quote
Old 17th July 2008, 02:32   #11
dypsis
Junior Member
 
Join Date: May 2008
Posts: 45
Great Work

After a few days of testing, I can say that it is going great here.

Keep up the great work DrO. I hope to see continued development of this, when required.
dypsis is offline   Reply With Quote
Old 20th July 2008, 20:55   #12
Wolfgang
Forum King
 
Wolfgang's Avatar
 
Join Date: Mar 2004
Location: England
Posts: 3,069
Whatever I do, I can't get this to work. Quite a few people over at last.fm seem to have issues as well. I've just done a clean install, wiping any reference to Winamp or Audioscrobbler or Last.fm from my hard drive (registry included). Clean install of Winamp, no other plugins, no other skins, and have not played with the AS settings except for putting my username and password in. I have no proxy or firewall.

It works with the Last.fm software and their plugin, but I really don't want to be running an extra process just in order to scrobble what I play. Could this be anything related to 5.54? Or is it just one of those "it works for some people and if not for you, tough" things?
Wolfgang is offline   Reply With Quote
Old 20th July 2008, 21:34   #13
gaekwad2
Foorum King
 
gaekwad2's Avatar
 
Join Date: Jul 2003
Location: bar2000
Posts: 11,377
It does work for me (with 5.54, see the spam buttons), are you perhaps using Vista?
gaekwad2 is offline   Reply With Quote
Old 20th July 2008, 22:07   #14
Wolfgang
Forum King
 
Wolfgang's Avatar
 
Join Date: Mar 2004
Location: England
Posts: 3,069
Nay, simply plain old XP SP2. Damnit. I'd be happier if I knew what it is, but since it's a mystery it's very annoying.

BTW, what's that Windows theme you're using?
Wolfgang is offline   Reply With Quote
Old 20th July 2008, 22:28   #15
gaekwad2
Foorum King
 
gaekwad2's Avatar
 
Join Date: Jul 2003
Location: bar2000
Posts: 11,377
XPMC (afaik he never formally finished it, it's complete as it is though)

I've got SP3, but the older version at least worked with SP2 (and older Winamp of course) as well.

One thing though, the older one could also be run as library plugin, iirc it only had to be renamed to ml_audioscrobbler.dll, which supposedly had some advantages.
No idea whether that would do the trick (or even work at all) here.
gaekwad2 is offline   Reply With Quote
Old 20th July 2008, 23:05   #16
dypsis
Junior Member
 
Join Date: May 2008
Posts: 45
Quote:
Originally posted by Wolfgang
Whatever I do, I can't get this to work. Clean install of Winamp, no other plugins, no other skins, and have not played with the AS settings except for putting my username and password in. I have no proxy or firewall.

It works with the Last.fm software and their plugin, but I really don't want to be running an extra process just in order to scrobble what I play.
Do you have "Enable Plugin" selected under Preferences?

For the record. I have it running on Vista SP1 without a problem.

And I agree with you about running another process just to scrobble. This is the best option IMO.
dypsis is offline   Reply With Quote
Old 20th July 2008, 23:10   #17
Wolfgang
Forum King
 
Wolfgang's Avatar
 
Join Date: Mar 2004
Location: England
Posts: 3,069
Thanks, it's brilliant.

Just tried that and it doesn't seem to be working, unfortunately. Shitloads of errors in the log file:

167.090 07/20/2008 23:05:52 CScrobbler::SubmitSong Cannot send - Handshake didn't complete
297.728 07/20/2008 23:08:03 CScrobbler::GetURL ERROR - ReqID 2, HttpSendRequest - A connection with the server could not be established (12029) -
297.778 07/20/2008 23:08:03 CScrobbler::ThreadCallback ReqID 2, Submission is '', Response is , Status Code 0
297.818 07/20/2008 23:08:03 CScrobbler::ParseReponse ERROR - Response was invalid
297.858 07/20/2008 23:08:03 CScrobbler::ThreadCallback ERROR - ReqID 2, Last response from the server was unreadable ()

Thanks for your help, gaek.

I've noticed something a bit odd: when I put in my last.fm password, then save and open the config window up again, the number of dot characters is longer than the number of characters in my password. Pretty weird.

Maybe Daz will see this and kindly throw some of his magic at it, if it's fixable and it's not just something stinking in my computer.
Wolfgang is offline   Reply With Quote
Old 3rd August 2008, 23:29   #18
Alkaloid
Junior Member
 
Join Date: Aug 2008
Location: Indiana
Posts: 4
I am trying to get DrO's Last.fm Audioscrobbler plug-in (v. 1.1.11) to read tags from AAC format streams originating from DI.fm.

The plug-in config screen says Playback State: Playing (Invalid - Cannot read file tag) [-1]

Any idea why? Think it's the plug-in? Or is the tags/streams at DI.fm Can the plug-in access AAC format tags?

Winamp picks up the file info just fine, so I would think it would be able to convey the data to the plug-in, or the plug-in could get the info from Winamp, or however it all works.

Last edited by Alkaloid; 3rd August 2008 at 23:51.
Alkaloid is offline   Reply With Quote
Old 15th August 2008, 08:30   #19
dypsis
Junior Member
 
Join Date: May 2008
Posts: 45
This is still working great for me.

Keep up the great work DrO.
dypsis is offline   Reply With Quote
Old 17th August 2008, 07:51   #20
MALditoNica
Junior Member
 
Join Date: Aug 2006
Posts: 2
audioscrobbler was working well in my winxp sp2 + winamp 5.x
Updated to sp3, and I noticed winamp crashing everytime the plugin tried to "call home".
MALditoNica is offline   Reply With Quote
Old 31st October 2008, 12:39   #21
drugo
Senior Member
 
Join Date: Dec 2006
Posts: 300
me too

i can't use the audioscrobbler with winamp

xp with sp3
drugo is offline   Reply With Quote
Old 31st October 2008, 13:13   #22
QOAL
[STILL a retard!]
 
QOAL's Avatar
 
Join Date: Apr 2002
Location: Bristol, UK
Posts: 1,168
Use the official one from here.

The media library one works perfectly fine for me on XP SP3.

count!last.fmdastylishplanner
QOAL is online now   Reply With Quote
Old 31st October 2008, 13:42   #23
drugo
Senior Member
 
Join Date: Dec 2006
Posts: 300
Quote:
Originally posted by QOAL
Use the official one from here.

The media library one works perfectly fine for me on XP SP3.
but i have to download the Last.fm client?
i don't like it
i mean i don't want the client
i would like only the plug to send my music to last.fm
drugo is offline   Reply With Quote
Old 31st October 2008, 18:07   #24
DrO
 
Join Date: Sep 2003
Posts: 27,880
this is the only standalone version that appears to work with newer winamp versions though i've not used it for a while so i've no idea how it works with 5.541 (and i've not checked the last.fm forums for an age to see what/if other issues have been reported about it other than it doesn't support unicode submissions unlike the offical plugin as i've not had the time *shrugs* )

-daz
DrO is offline   Reply With Quote
Old 1st November 2008, 09:02   #25
drugo
Senior Member
 
Join Date: Dec 2006
Posts: 300
Quote:
Originally posted by DrO
this is the only standalone version that appears to work with newer winamp versions though i've not used it for a while so i've no idea how it works with 5.541 (and i've not checked the last.fm forums for an age to see what/if other issues have been reported about it other than it doesn't support unicode submissions unlike the offical plugin as i've not had the time *shrugs* )

-daz
by the way when i run the client i found compatible player only wmp11 not winamp
i need to add wianmp manually

and don't know why , but crashes my winamp
now i have disabled renaming the file to old
it's sad that i can't use last.fm with winamp
drugo is offline   Reply With Quote
Old 1st November 2008, 13:01   #26
DrO
 
Join Date: Sep 2003
Posts: 27,880
Quote:
but crashes my winamp
that's not very helpful at all since when it crashes there should be information provided about it etc.

the last.fm client has been known to have issues if you have winamp in a non-standard location but should work once done manually. but if neither are working then you've more than likely got issues with your winamp install and should do a clean install and go from there. other than that, last.fm client issues need to be reported to them and issues with the plugin i linked to may be rectified if/when i find the time to do so.

-daz
DrO is offline   Reply With Quote
Old 2nd November 2008, 18:31   #27
drugo
Senior Member
 
Join Date: Dec 2006
Posts: 300
Quote:
Originally posted by DrO
that's not very helpful at all since when it crashes there should be information provided about it etc.

the last.fm client has been known to have issues if you have winamp in a non-standard location but should work once done manually. but if neither are working then you've more than likely got issues with your winamp install and should do a clean install and go from there. other than that, last.fm client issues need to be reported to them and issues with the plugin i linked to may be rectified if/when i find the time to do so.

-daz
seems that is audioscrobber to crash winamp
i uninstalled the plugins and winamp did not crash

i tried all kind of plugins the gen_audioscrobbler.dll 1.9 and 1.9 ml_audioscrobbler.dll


it's a shame , winamp the best player has such issues
i tried foobar and windwos media player 11 no problem
only winamp goes crash with the plugin


is there someone that can fix it?

to me gives me this generic error before crash
Quote:
Application that caused the error winamp.exe, version 5.5.4.2165 form that caused the error ntdll.dll, version 5.1.2600.2180, fault address 0x00011430.
and this
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 77 69 6e ure win
0018: 61 6d 70 2e 65 78 65 20 amp.exe
0020: 35 2e 35 2e 34 2e 32 31 5.5.4.21
0028: 36 35 20 69 6e 20 6e 74 65 in nt
0030: 64 6c 6c 2e 64 6c 6c 20 dll.dll
0038: 35 2e 31 2e 32 36 30 30 5.1.2600
0040: 2e 32 31 38 30 20 61 74 .2180 at
0048: 20 6f 66 66 73 65 74 20 offset
0050: 30 30 30 31 31 34 33 30 00011430
0058: 0d 0a ..
drugo is offline   Reply With Quote
Old 6th November 2008, 14:54   #28
Kaminari
Junior Member
 
Kaminari's Avatar
 
Join Date: Mar 2003
Location: Paris, France
Posts: 49
Quote:
Originally posted by drugo
is there someone that can fix it?
Fix what?

The Last.fm software (core client 1.5, winamp plugin 2.1) has been working perfectly with Winamp 5.54 and WinXP SP3 for months.
Kaminari is offline   Reply With Quote
Old 6th November 2008, 21:26   #29
Zero2FiftyIn4
Senior Member
 
Join Date: Sep 2007
Location: In my head....the voices there are nice
Posts: 170
you said you are using 1.9 dll....the link Dr.O gave you has the number 1.1.11 or something.

I'm not sure but I don't think you are following the advice/instructions correctly.

I believe the audioscobbler plugin you get from the last.fm site is 1.1.10, however that causes various problems for winamp. So you have to download the 1.1.11 dll file Dr.O linked you to. You take that file and open the plugin folder and put it there it will ask you if you want to replace the old file...click yes, all your problems should be solved.

"It is, in the end, whatever the Hell I want it to be,
And when I'm through with it, it's gonna blow a hole,
This wide, straight through the worlds own idea of itself.
They're throwing bottles at your house.
Come on, lets go break their arms."
Zero2FiftyIn4 is offline   Reply With Quote
Old 9th November 2008, 23:18   #30
Wolfgang
Forum King
 
Wolfgang's Avatar
 
Join Date: Mar 2004
Location: England
Posts: 3,069
I've had issues with the AS plugin, even DrO's, which worked with me for a while. I've gone back to previous versions on Winamp and fiddled with loads of stuff, to no avail. I dislike the idea of running separate software constantly just to be able to scrobble my songs, so I don't use the Last.fm software.

I now use AWAAS, which is a script to run with the brilliant ActiveWinamp plugin. It works very well.
Wolfgang is offline   Reply With Quote
Old 15th February 2009, 04:21   #31
ClintJCL2
Junior Member
 
Join Date: Aug 2002
Location: D.C.
Posts: 48
Send a message via ICQ to ClintJCL2 Send a message via AIM to ClintJCL2 Send a message via Yahoo to ClintJCL2
For you, perhaps. For me, it simply made Winamp crash at start until I found the AAAWS folder and ran the uninstall.

Nevermind that I've been scrobbling, without incident, for some 9 yeras, before the site was even called last.fm!

Stuff stopped working Jan 19ts -- and now it wont start again. Period. Regardless of unistalling and reinstalling.

Elapsed Date/Time Module Debug
=====================================================================================================
0.000 02/14/2009 23:00:38 Application Information AudioScrobbler for Winamp v1.1.10 (Build 634) ml_audioscrobbler.dll
0.031 02/14/2009 23:00:38 Application Information Winamp Version 5.04
0.031 02/14/2009 23:00:38 Application Information Windows XP (Professional), (Multiprocessor Free) v5.1 Build:2600 Service Pack:3
0.781 02/14/2009 23:00:39 CCacheManager::Load Loaded 5000 entries
0.875 02/14/2009 23:00:39 CScrobbler::StartScrobbling Startup Complete.
10.922 02/14/2009 23:00:49 CScrobbler::OnTrackPlay New song detected - Kreator - Twisted Urges (Coma Of Souls)
22.578 02/14/2009 23:01:01 CScrobbler::GetURL ERROR - ReqID 0, HttpSendRequest - A connection with the server could not be established (12029) -
22.656 02/14/2009 23:01:01 CScrobbler::ThreadCallback ReqID 0, Submission is '', Response is , Status Code 0
22.687 02/14/2009 23:01:01 CScrobbler::ParseReponse ERROR - Response was invalid
22.766 02/14/2009 23:01:01 CScrobbler::ThreadCallback ERROR - ReqID 0, Last response from the server was unreadable ()
86.062 02/14/2009 23:02:04 CScrobbler::SubmitSong Submitting 'Kreator - Twisted Urges (Coma Of Souls)'
86.078 02/14/2009 23:02:04 CScrobbler::SubmitSong Cannot send - Handshake didn't complete
141.078 02/14/2009 23:02:59 CScrobbler::OnTrackPlay New song detected - Tiamat - The Malicious Paradise (Sumerian Cry)
167.109 02/14/2009 23:03:25 CScrobbler::GetURL ERROR - ReqID 1, HttpSendRequest - A connection with the server could not be established (12029) -
167.234 02/14/2009 23:03:26 CScrobbler::ThreadCallback ReqID 1, Submission is '', Response is , Status Code 0
167.578 02/14/2009 23:03:26 CScrobbler::ParseReponse ERROR - Response was invalid
167.687 02/14/2009 23:03:26 CScrobbler::ThreadCallback ERROR - ReqID 1, Last response from the server was unreadable ()
266.484 02/14/2009 23:05:05 CScrobbler::SubmitSong Submitting 'Tiamat - The Malicious Paradise (Sumerian Cry)'
266.516 02/14/2009 23:05:05 CScrobbler::SubmitSong Cannot send - Handshake didn't complete

-Clint
AMD Athlon 900mHz, 256M RAM, 280GB, Win2K, SB Live Platinum 5.1, ATI All-In-Wonder Radeon 32M DDR.
ClintJCL2 is offline   Reply With Quote
Old 20th March 2009, 21:40   #32
tripptk
Junior Member
 
Join Date: Aug 2003
Location: Florida, USA
Posts: 34
Send a message via AIM to tripptk Send a message via Yahoo to tripptk
Just wanted to say this is working great for me on Windows 7 Beta with Winamp v5.55

I'm so glad I don't have to run their damn application just to scrobble my songs.

Thanks alot mate!
tripptk is offline   Reply With Quote
Old 28th May 2009, 18:20   #33
CarbonCapture
Junior Member
 
Join Date: May 2009
Posts: 2
Any update on the new version that'll support unicode? As Dr.O posted on last.fm:

Quote:
I've got a bit more testing to do on it but i believe i've now resolved the unicode issues so there will hopefully be a new version of my modified build out in a month or so (real life permitting).
And that was in January. (Yeah, yeah, I know. "real life permitting")
CarbonCapture is offline   Reply With Quote
Old 27th July 2009, 12:45   #34
CarbonCapture
Junior Member
 
Join Date: May 2009
Posts: 2
Quote:
Originally posted by CarbonCapture
Any update on the new version that'll support unicode? As Dr.O posted on last.fm:



And that was in January. (Yeah, yeah, I know. "real life permitting")
*bump*
CarbonCapture is offline   Reply With Quote
Old 26th November 2009, 20:08   #35
livettt
Junior Member
 
Join Date: Nov 2009
Posts: 1
hey guys,
i've got a little problem with scrobbling tracks from my ipod nano (4g) via ml_ipod/audioscrobbler (latest version) to last.fm and it would be great if someone could help me

after i sync my ipod with winamp the tracks i listened aren't scrobbled to last.fm. but when i look at the audioscrobbler plug-in all the tracks are listed at "last scrobbled tracks". however in the log file of the audioscrobbler they aren't. any ideas?
when i listen to tracks from my media library scrobbling works perfectly.

thanks in advance and pleeeaase help me

greets
livet
livettt is offline   Reply With Quote
Old 29th January 2010, 05:36   #36
BastardKidKris
Senior Member
 
Join Date: Sep 2005
Posts: 222
Send a message via AIM to BastardKidKris
What protocol does this plugin follow? 1.1 or 1.2?

ThinkPad T61, C2D @ 2.2GHz, 4GB DDR2, Win7x64Pro
BastardKidKris is offline   Reply With Quote
Old 29th January 2010, 10:45   #37
DrO
 
Join Date: Sep 2003
Posts: 27,880
the standalone plugin is the 1.1 spec from what i remember though never checked out the newer spec as the standalone is too hard coded for the earlier spec.

-daz
DrO is offline   Reply With Quote
Old 29th January 2010, 19:58   #38
BastardKidKris
Senior Member
 
Join Date: Sep 2005
Posts: 222
Send a message via AIM to BastardKidKris
Quote:
Originally posted by DrO
the standalone plugin is the 1.1 spec from what i remember though never checked out the newer spec as the standalone is too hard coded for the earlier spec.

-daz
are there plans to go to 1.2 at all?
BastardKidKris is offline   Reply With Quote
Old 3rd February 2010, 10:23   #39
DrO
 
Join Date: Sep 2003
Posts: 27,880
at the moment no as i've not looked into it and don't know what is involved - the current work i've been trying to do is to make the AS plug-in more like a 5.x style plug-in so moving the preferences into a proper location, resolving the issues with DEP crashes it experiences and just overall stripping the code to a minimum so that it hopefully should be easier (if i decide to do it) to implement new protocol handlers. however, getting the plug-in to not crash randomly as my build currently does is holding back any release of an updated unicode version of the plug-in (and not being able to do much coding this week doesn't help).

-daz
DrO is offline   Reply With Quote
Old 25th June 2010, 16:30   #40
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 198
Send a message via ICQ to ravermeister
*Bump
ravermeister is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump