Old 25th April 2006, 12:23   #1
{_trueparuex^}
Senior Member
 
{_trueparuex^}'s Avatar
 
Join Date: Dec 2005
Location: Glow
Posts: 285
SectionGroup and read only

How I can set SectionGroup to read only? SectionIn RO doesn't work and the SectionSetFlags doesn't work either. I know that this probably should be automated so that if all Sections in SectionGroup are read only, then the group checkbox also appear as read only, but it doesn't seem to be so.


Is there anything I can do about this?

I attached the scripts as well, but it is very complex and I doubt that anyone actually bothers to check the scripts out. I will write a simpler script with same method later.

Edit: Ok the SectionSetFlags seems to work after all, but why SectionIn RO doesn't work for SectionGroups?
Attached Files
File Type: zip source.zip (13.7 KB, 231 views)
{_trueparuex^} is offline   Reply With Quote
Old 27th April 2006, 09:23   #2
{_trueparuex^}
Senior Member
 
{_trueparuex^}'s Avatar
 
Join Date: Dec 2005
Location: Glow
Posts: 285
Now I know that SectionGroups aren't just meant to be read only. Read only SectionGroup would require a new checkbox state (read only partially selected) and there are no such checkbox in the check bitmaps. I attached a script what demonstrate the problem (note that all the SectionGroups are set to read only in the script).

So there really isn't much anyone can do about this problem.
Attached Files
File Type: nsi secgrouptest.nsi (1.5 KB, 248 views)
{_trueparuex^} is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Developer Center > NSIS Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump