Old 24th February 2015, 19:24   #1
JaysonPrichard
Junior Member
 
Join Date: Nov 2014
Posts: 2
Install program for 32 bit app on 64 bit OS

I have a currently working installation program (developed on Windows7 32-Bit) that installs a 32-Bit application.

I need to install my 32-Bit application on a Windows7 64-Bit machine.

When I execute the current installer, the program seems to hang at nsExec::Exec commands.

I have seen other posts with similar problems, but no real "solution".

Ideas? My head hurts.
JaysonPrichard is offline   Reply With Quote
Old 25th February 2015, 08:59   #2
Anders
Moderator
 
Anders's Avatar
 
Join Date: Jun 2002
Location: ${NSISDIR}
Posts: 5,090
How about providing a example command that fails or a link to the similar posts?

Have you checked in Process Explorer and/or Process Monitor to see if the child process is started correctly? Does it start but never finish? Are you starting a 64 or 32 bit program? Is this program somewhere in %windir% or %programfiles%?

This works fine for me on Win8-x64:
Quote:
Section
nsExec::ExecToLog '"arp.exe" -a'
SectionEnd

IntOp $PostCount $PostCount + 1
Anders is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Developer Center > NSIS Discussion

Tags
64bit

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump