Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Reply
Thread Tools Search this Thread Display Modes
Old 2nd July 2005, 00:25   #201
Chris000001
Senior Member
 
Join Date: Nov 2003
Location: CA
Posts: 105
Thanks for the reply jmatthews112. I already remove the menus I don't like from the registry. I could probably add the menu I want through 'folder options - file types' in explorer. I thought it might be another good feature, but you're right it should've been in the wishlist forum...

Thanks again, and thanks to DrO.
Chris000001 is offline   Reply With Quote
Old 2nd July 2005, 12:10   #202
DrO
 
Join Date: Sep 2003
Posts: 27,873
i'm not around much over the next day or so, so here's a quick response to a few things...

Chris000001: i've part implemented the ability to remove any of those registry options ie Open, Enqueue, Play and ListBookmark but need to finish the code so that it can be controlled as to what is/isn't shown easily and also to get the code to add the entries back in if re-enabled after a forced removal plus a few other little tweaks.

niktheguru: at the moment it's just going to have to be a manual search for the file (opening the playlist entry dialog now supports a browse for file button. may be i will expand the handling for things like that but there's a lot more important core feature fixes/updates that need to be done

fisher819: not sure on why/how that's happened... was the missing file highlighting enabled at the time since that's been the main cause of crashes for me

¿¢?: option is already internally added for the normal font to be used (default mode again)

the purpose of the external file modification tracking updater is to highlight entries in the playlist that aren't valid entries anymore ie if you move a folder from c:\a to c:\b then when the timer re-scans the viewable portion of the playlist (which is done that way for speed) then it would notice the change and any of the c:\a entries would have their colouring changed to indicate they've moved.

macaroon: fixed that (see up a few comments) and also from testing on 2.81 i fixed a few issues with the preferences fallback code so that's complete now as well


extended/international character searching: i'm re-coding again the whole of the custom search function to implement a request by TazDevil and also wildcard (?) support (which is linked to TazDevil's request). i'll be going through the posts made about the issues and extra information i've been provided to see if i can get things dealt with

-daz
DrO is offline   Reply With Quote
Old 2nd July 2005, 15:47   #203
roytam1
Member
 
Join Date: Aug 2003
Posts: 81
Quote:
Originally posted by DrO
extended/international character searching: i'm re-coding again the whole of the custom search function to implement a request by TazDevil and also wildcard (?) support (which is linked to TazDevil's request). i'll be going through the posts made about the issues and extra information i've been provided to see if i can get things dealt with

-daz
I have a question on the wildcard support. If I DO want to search the wildcard character ("?" in this case), what can I do?
roytam1 is offline   Reply With Quote
Old 4th July 2005, 01:17   #204
DrO
 
Join Date: Sep 2003
Posts: 27,873
Build 11 is out:: release info

------------------------------------------------------------

really the main thing is to test the search function with extended character sets (it will now convert the strings to lowercase based on the user locale of the machine which seems to be the suggested way to do it).

TazDevil: i'll finish implementing the thing we were mailing about once i know the extended searching is sorted

roytam1: for the wildcard you use the asterisk * and if it's just an asterisk you want to search for then just enter * as the search otherwise use it like a**e for a wildcard search (this may seem a bit wierd at times due to the code working on the playlist and title text since that's what winamp passes to the function so some wildcard searches display some seemingly random results)

-daz
DrO is offline   Reply With Quote
Old 4th July 2005, 02:11   #205
electricmime
Major Dude
 
Join Date: Mar 2004
Posts: 991
thanks for the queue album support, but the media library option seems to put the albums in the queue backward(last track is the first queued, second to last is the second queued, etc)

There is no reset button on life... but the graphics kick ass
electricmime is offline   Reply With Quote
Old 4th July 2005, 02:14   #206
DrO
 
Join Date: Sep 2003
Posts: 27,873
heh, i'd wrongly assumed the ml would parse me the files in order like it does in all of my tests. i'll have to have a deeper look into it for one of the next builds

-daz
DrO is offline   Reply With Quote
Old 4th July 2005, 09:50   #207
fisher819
Senior Member
 
fisher819's Avatar
 
Join Date: Sep 2004
Location: Lebanon
Posts: 225
Send a message via Yahoo to fisher819
@ drO: the problem i stated above dissapeared after a restart of my computer.

but i have a request: is there a way to eliminate separators from JTFE because in a huge playlist they become annoying because they are all in the start of the list.

help us count :Click here
fisher819 is offline   Reply With Quote
Old 4th July 2005, 09:58   #208
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Added an option on the 'Display' tab to filter out separator:// based entries (manually altering the current search is needed to make any change to this setting take effect if the JTF window is currently open)
that's from the build #2 changelog

-daz
DrO is offline   Reply With Quote
Old 4th July 2005, 09:59   #209
TazDevil
Senior Member
 
TazDevil's Avatar
 
Join Date: Nov 2003
Location: Cyprus
Posts: 359
Comments on Extended Characters and wildcards...

searching extended chars works fine, for me...

About wildcards, JTFE already puts wildcards at the beginning and end of the search string, so if you separate them with a space part of word can be found and part of another word can be found...

The way i understand the * wildcard thing is to put wildcards inside a word..., and here is how it works for me

for every * i insert between 2 chars i get 1 wildcard so if i put ** or *** or **** between the chars i get results with words containing the first and last letter and an equal amount of chars between them as the * asterisks...

The * astyerisk thing shouldn't accomodate any number of chars between the 2 chars ??? so that only * asterisk is used ? (and for searching for an asterisk ** should be used ?

[edit]
also could i request an Unqueue menu item to remove items from the queue if the were accidentally added, (this can be done from queue management but it is a big hasle, to open dialogs and find the item and remove it...(or is it smt that i am missing)

NEW Multiple Output Plugin v1.5 | Download | outputs data to one or more audio/file output devices
Crystal Classic Skins v1.1 | Download | transparency effects for classic skins

Last edited by TazDevil; 4th July 2005 at 12:54.
TazDevil is offline   Reply With Quote
Old 4th July 2005, 11:30   #210
Tomoyo
Junior Member
 
Tomoyo's Avatar
 
Join Date: Jun 2005
Location: Nippon
Posts: 7
on Build 11
don't work to search foreign characters(i use Japanese)...

good work on Build 6.
Tomoyo is offline   Reply With Quote
Old 4th July 2005, 12:55   #211
electricmime
Major Dude
 
Join Date: Mar 2004
Posts: 991
Quote:
Originally posted by TazDevil

[edit]
also could i request an Unqueue menu item to remove items from the queue if the were accidentally added, (this can be done from queue management but it is a big hasle, to open dialogs and find the item and remove it...(or is it smt that i am missing)
you can remove from queue, from the prefs->jtfe->check remove file from queue on 'alt clik' if already in queue

it doesnt just work for alt click though, its 'q', 'middle click', and even the 'enqueue selected' from the jtfe menu

There is no reset button on life... but the graphics kick ass
electricmime is offline   Reply With Quote
Old 4th July 2005, 13:27   #212
TazDevil
Senior Member
 
TazDevil's Avatar
 
Join Date: Nov 2003
Location: Cyprus
Posts: 359
Quote:
Originally posted by electricmime
you can remove from queue, from the prefs->jtfe->check remove file from queue on 'alt clik' if already in queue

it doesnt just work for alt click though, its 'q', 'middle click', and even the 'enqueue selected' from the jtfe menu
hmm thanks electricmime, i fould the option,
missed it actually, i was looking under other tabs...
well a menu item would STILL be good also...

For me it just works for Alt+Left_Click if the file is already in que...

i didn't understand your second sentence so i guess you ment "it doesnt work with Alt+q or Alt+Middle_Click" ???
[s]
Would be good to be able to add files in the que by pressing middle_click and removing them by pressing Alt+Middle_click, since noone else uses the middle click in winamp's playlist[s] <- already such feature

NEW Multiple Output Plugin v1.5 | Download | outputs data to one or more audio/file output devices
Crystal Classic Skins v1.1 | Download | transparency effects for classic skins

Last edited by TazDevil; 4th July 2005 at 14:17.
TazDevil is offline   Reply With Quote
Old 4th July 2005, 13:57   #213
electricmime
Major Dude
 
Join Date: Mar 2004
Posts: 991
no alt middle click/alt q.. just middle click and queue(and yeah, i forgot to mention it was in the enqueue options tab )

you don't add anything to the method used to 'queue' to remove files from queue'

so if you wanted to remove something using the middle click, you would simply middle click a queued item, and if you wanted to remove something via the jtfe context menu, you would just click 'enqueue selction' over that item, and if you wanted to remove something via 'q' you would just hit 'q'

There is no reset button on life... but the graphics kick ass
electricmime is offline   Reply With Quote
Old 4th July 2005, 14:28   #214
TazDevil
Senior Member
 
TazDevil's Avatar
 
Join Date: Nov 2003
Location: Cyprus
Posts: 359
OK i understood what electricmime is telling me, BUT the "remove file from queue on 'alt clik' if already in queue" option is kind of confusing and needs to be renamed to smt like "on enqueue remove file from queue if already in queue"

Also i want to note this ... that may be a bug as well

if the option is disabled, i can enque a file as many times as i like so i can play a flie in eg 1,6,8,14,19 in my songs order... and i can only remove from the que throught prefs.

if the option is enabled i can only enqueue a file once in a queue, and if i try for a second time the file gets unqueued
so i can have it only one time.

What i suggest which is more reasonable is to remove the option and use a standard feature of...

q, Middle Click -> to always add to the queue (hwo many times the are pressed
Alt+q, Alt+Middle CLick -> to always remove from the queue

This will enable a song to be played many times in the queue.

What do the others believe/suggest ???

NEW Multiple Output Plugin v1.5 | Download | outputs data to one or more audio/file output devices
Crystal Classic Skins v1.1 | Download | transparency effects for classic skins
TazDevil is offline   Reply With Quote
Old 4th July 2005, 15:00   #215
jmatthews112
Major Dude
 
Join Date: Jun 2003
Posts: 1,661
Send a message via AIM to jmatthews112 Send a message via Yahoo to jmatthews112
Quote:
Originally posted by TazDevil
OK i understood what electricmime is telling me, BUT the "remove file from queue on 'alt clik' if already in queue" option is kind of confusing and needs to be renamed to smt like "on enqueue remove file from queue if already in queue"
Isn't too confusing here...

Quote:
Originally posted by TazDevil
if the option is disabled, i can enque a file as many times as i like so i can play a flie in eg 1,6,8,14,19 in my songs order... and i can only remove from the que throught prefs.
Are you able to dequeue it from the JTFE dialog (J) as well?

Quote:
Originally posted by TazDevil
if the option is enabled i can only enqueue a file once in a queue, and if i try for a second time the file gets unqueued so i can have it only one time.
Just noticed this, but I can get this too.

Hmm..
jmatthews112 is offline   Reply With Quote
Old 4th July 2005, 15:37   #216
TazDevil
Senior Member
 
TazDevil's Avatar
 
Join Date: Nov 2003
Location: Cyprus
Posts: 359
Nope i cannot dequeue from the JTFE dialog when the option for dequeue-ing is checked, another bug ???

NEW Multiple Output Plugin v1.5 | Download | outputs data to one or more audio/file output devices
Crystal Classic Skins v1.1 | Download | transparency effects for classic skins
TazDevil is offline   Reply With Quote
Old 4th July 2005, 15:44   #217
jmatthews112
Major Dude
 
Join Date: Jun 2003
Posts: 1,661
Send a message via AIM to jmatthews112 Send a message via Yahoo to jmatthews112
What method are you using from the JTF dialog? The 'Remove Queue' button? 'Remove from Queue' option on file right click? 'Delete' key?

I can do all three of these on a clean install of Winamp 5.093 and build 11.

And please clarify: is the option for Alt+Click checked or unchecked? You are a bit confusing as you switch from unchecked to checked between the two responses. BTW, I can do the same as above with checked and unchecked.

jmat
jmatthews112 is offline   Reply With Quote
Old 4th July 2005, 16:00   #218
TazDevil
Senior Member
 
TazDevil's Avatar
 
Join Date: Nov 2003
Location: Cyprus
Posts: 359
heh just noticed that JTFE has a menu...

In the JTF dialog the menu and delete key work fine, both ways (option checked and unchecked)
Previously i was clicking on the Enqueue button on the JTF dialog (and expected to dequeue it ).

I said that the option was confusing because the Enqueue function changes to dequeue with 'q' and Middle cLick, not just with Alt-Click

NEW Multiple Output Plugin v1.5 | Download | outputs data to one or more audio/file output devices
Crystal Classic Skins v1.1 | Download | transparency effects for classic skins
TazDevil is offline   Reply With Quote
Old 4th July 2005, 16:04   #219
jmatthews112
Major Dude
 
Join Date: Jun 2003
Posts: 1,661
Send a message via AIM to jmatthews112 Send a message via Yahoo to jmatthews112
You have to head over to Manage Mode [toggle JTF dialog with long button - Search<->Manage] and click Remove File, and then the menus are available from there.
jmatthews112 is offline   Reply With Quote
Old 5th July 2005, 04:00   #220
roytam1
Member
 
Join Date: Aug 2003
Posts: 81
Quote:
Originally posted by Tomoyo
on Build 11
don't work to search foreign characters(i use Japanese)...

good work on Build 6.
Same here. I use Chinese and Japanese to search but the result is not filtered correctly.
roytam1 is offline   Reply With Quote
Old 6th July 2005, 07:41   #221
fisher819
Senior Member
 
fisher819's Avatar
 
Join Date: Sep 2004
Location: Lebanon
Posts: 225
Send a message via Yahoo to fisher819
just a very small thing.
clicking on the about button in the enque options tab (JTFE options) either takes me to the about of playlist loader or causes winamp to crash.

help us count :Click here
fisher819 is offline   Reply With Quote
Old 6th July 2005, 19:07   #222
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
I patched the winamp-distributed gen_jumpex to resolve the DEP issue. Anyone who is curious can take a look.

version 0.96fg attached. Please note that this is a modification of DrO's old (lost source code) plugin, not his new development efforts.
Attached Files
File Type: zip gen_jumpex.zip (43.8 KB, 517 views)
Benski is offline   Reply With Quote
Old 8th July 2005, 15:17   #223
Tomoyo
Junior Member
 
Tomoyo's Avatar
 
Join Date: Jun 2005
Location: Nippon
Posts: 7
JTFE issue in Preferences,
default display font is "MS Sans Serif".
Characters cannot be displayed if change to foreign language files(ex.jtfe_japanese.ini)
Japanese font is "MS UI Gothic",so foreigner has to rewrite a display font.

Can display fonts be load from language.ini?(Winamp language file like)
Tomoyo is offline   Reply With Quote
Old 8th July 2005, 22:46   #224
niktheguru
Senior Member
 
Join Date: May 2003
Location: London, UK
Posts: 120
just another thing Darren,

Its good to see that from these builds we can now drag and move files up and down the queue (in the jtfe pop up window) but i notice that the position of the item i am moving only becomes apparent when i let go of the mouse and drop it there. Could it be more responsive, say like the playlist of winamp, where if u click and drag it u can actually see the file moving up the queue one by one, and then u can just drop it exactly where u want it. (Or at least some placeholders)

I hope that makes sense!! Keep up the excellent work.

Nikhil
niktheguru is offline   Reply With Quote
Old 9th July 2005, 02:37   #225
roytam1
Member
 
Join Date: Aug 2003
Posts: 81
Quote:
Originally posted by Tomoyo
JTFE issue in Preferences,
default display font is "MS Sans Serif".
Characters cannot be displayed if change to foreign language files(ex.jtfe_japanese.ini)
Japanese font is "MS UI Gothic",so foreigner has to rewrite a display font.

Can display fonts be load from language.ini?(Winamp language file like)
Or maybe use the default GUI Font is more suitable?
roytam1 is offline   Reply With Quote
Old 9th July 2005, 16:41   #226
Logy
Senior Member
 
Logy's Avatar
 
Join Date: Jun 2004
Location: Terengganu, Malaysia, Asia, Earth
Posts: 302
offtopic
jump to track version 1.11 ok nice, but only once bugs.... ratings display not work in songticker... when you clicks 3 star and when click again it stay on previous 5 star...
but in playlist editor is ok... functions queue it is so nice!!!

The English suffix -logy denotes a field of study or academic discipline.
Logy is offline   Reply With Quote
Old 10th July 2005, 15:57   #227
Squadman
Senior Member
 
Squadman's Avatar
 
Join Date: Nov 2004
Location: UK
Posts: 284
Send a message via AIM to Squadman
Hmm, updating to Build 11, whenever I search for something, I can type the first word in the band name, and then If I do a space, or attempt to type another word, everything dissapears, and I can't find anything.

Example: I'm searching for 'Ben Folds Five', I type 'Ben', then type 'Folds' and everything it has found is gone.

It's the same with song titles, i can only search for one word, if I enter more then one, everything dissapears.

When I go back to Build 10, it's fine. I can search for a band name and a song with a '-' seperating it.

Any ideas?
Squadman is offline   Reply With Quote
Old 13th July 2005, 16:14   #228
Squadman
Senior Member
 
Squadman's Avatar
 
Join Date: Nov 2004
Location: UK
Posts: 284
Send a message via AIM to Squadman
Sorry to double post, but that's not the problem now. Now whenever I have Build 10 or 11 installed, whenever I right click, Winamp Crashes.

It used to also be, if I went on Preferences, it also crashed, but that's not the case anymore...

Even if I re-install Winamp, to the old, original plugin bundled with Winamp, it still crashes on that! The only way to fix it is to clean install Winamp.

This error message came up a few times before, but now it doesn't.


Quote:
Unhandled exception: 07/12/2005 22:49:37
Exception code: C0000005 ACCESS_VIOLATION
Fault address: 77D5EE07 00:00000000 C:\WINDOWS\system32\USER32.dll

Registers:
EAX:00000001
EBX:0000000A
ECX:00000001
EDX:00000000
ESI:00000002
EDI:0012A8EA
CS:EIP:001B:77D5EE07
SS:ESP:0023:0012A868 EBP:0012A8B0
DS:0023 ES:0023 FS:003B GS:0000
Flags:00010202

Call stack:
Address Frame
77D5EE07 0012A8B00000:00000000 C:\WINDOWS\system32\USER32.dll
77D4A8C1 0012A8C40000:00000000 C:\WINDOWS\system32\USER32.dll
019DF0C4 0012A9EC0000:00000000 C:\Program Files\Winamp\Plugins\gen_jumpex.dll
019DE361 77D7EEC80000:00000000 C:\Program Files\Winamp\Plugins\gen_jumpex.dll
084D8BEC 8B55FF8B
I'd love if someone could help me, as this is such a great plugin. Build 10 worked fine, it was just when I updated to Build 11, the problems started, but now I can't use either.
Squadman is offline   Reply With Quote
Old 13th July 2005, 17:43   #229
jmatthews112
Major Dude
 
Join Date: Jun 2003
Posts: 1,661
Send a message via AIM to jmatthews112 Send a message via Yahoo to jmatthews112
Quote:
Originally posted by Squadman
The only way to fix it is to clean install Winamp.
Seems you may have been using some dodgy third-party plugin ... especially since the principal dll at fault was user32.dll and not gen_jumpex.dll.

What third-party plugins were you running? Other applications?

Also, re your first problem, I can't replicate it on a clean install of Winamp 5.093, WinXP Pro SP2.

jmat
jmatthews112 is offline   Reply With Quote
Old 13th July 2005, 18:42   #230
Squadman
Senior Member
 
Squadman's Avatar
 
Join Date: Nov 2004
Location: UK
Posts: 284
Send a message via AIM to Squadman
Ok, list of plugins here:
Attached Files
File Type: txt my_plugin_list.txt (1.6 KB, 573 views)
Squadman is offline   Reply With Quote
Old 13th July 2005, 19:11   #231
jmatthews112
Major Dude
 
Join Date: Jun 2003
Posts: 1,661
Send a message via AIM to jmatthews112 Send a message via Yahoo to jmatthews112
The only plugin I can see that might cause you grief is the gen_msn one. Sure, you have some of DrO's plugins, such as One Click Show & Hide, but I can safely say I don't have issues with that one and Winamp 5.093 and WinXP Pro SP2. What if you disable it? Or was it some other plugin that isn't showing up anymore after your clean install, because you haven't reinstalled it [the plugin]?
jmatthews112 is offline   Reply With Quote
Old 13th July 2005, 19:36   #232
Squadman
Senior Member
 
Squadman's Avatar
 
Join Date: Nov 2004
Location: UK
Posts: 284
Send a message via AIM to Squadman
I deleted all the plugins when I did a clean install just to be sure, but I definetly didn't forget top re-install some. And i've done a clean install twice now. Still the same problem.

Ok, now i've un-installed the MSN plugin, and it seems all fine. Except, 50% of the time all the text disappears, and only the song number in my playlist, and the length of the track remains.

I've re-installed the MSN plugin now, and the exact same thing is happening, no change, so it can't be that..

EDIT: And my first problem still remains :\

Last edited by Squadman; 13th July 2005 at 20:19.
Squadman is offline   Reply With Quote
Old 13th July 2005, 19:46   #233
jmatthews112
Major Dude
 
Join Date: Jun 2003
Posts: 1,661
Send a message via AIM to jmatthews112 Send a message via Yahoo to jmatthews112
Install the newest build of JTFE, at the top of this thread, which I see now wasn't installed. I believe that issue was fixed a few builds back, from build 11.

jmat
jmatthews112 is offline   Reply With Quote
Old 13th July 2005, 20:20   #234
Squadman
Senior Member
 
Squadman's Avatar
 
Join Date: Nov 2004
Location: UK
Posts: 284
Send a message via AIM to Squadman
I had that un-installed at the time of generating my plugins. I've been testing with Build 11. I had it un-installed at the time, as it was causing problems.
Squadman is offline   Reply With Quote
Old 13th July 2005, 20:25   #235
jmatthews112
Major Dude
 
Join Date: Jun 2003
Posts: 1,661
Send a message via AIM to jmatthews112 Send a message via Yahoo to jmatthews112
Re-install it, and then delete the [Jump to File Extra] section from winamp.ini when Winamp is closed. Also, hit the Defaults button in the Enqueue Options tab of Preferences > Jump to File to be safe. I can't reproduce this on a clean install of Winamp 5.093 and WinXP Pro SP2.

jmat
jmatthews112 is offline   Reply With Quote
Old 13th July 2005, 20:43   #236
Squadman
Senior Member
 
Squadman's Avatar
 
Join Date: Nov 2004
Location: UK
Posts: 284
Send a message via AIM to Squadman
Dammit, yeah, It didn't work...

It's no longer crashing, but I can't search for more then one word, and when I Enqueue a file, 50% of the time everything except the track number and length of the song dissapears.

Just for the hell of it.

Win XP Pro SP2
Winamp 5.093
C-Media CMI8738 (audio)
Abit Radeon 9600XT 256MB
768MB DDR Ram
Direct X 9.0c

EDIT: I've found out that if I search for an artist or song with no capital letters, I can find things. Am I missing something?
Attached Files
File Type: txt high jack this.txt (4.7 KB, 553 views)

Last edited by Squadman; 13th July 2005 at 21:08.
Squadman is offline   Reply With Quote
Old 13th July 2005, 21:29   #237
jmatthews112
Major Dude
 
Join Date: Jun 2003
Posts: 1,661
Send a message via AIM to jmatthews112 Send a message via Yahoo to jmatthews112
Check to see what your Coloriser settings are. I did experience this disappearing act at one time with a build prior to b11, but I no longer experience this. Particularly, I guess I need information on the colors set (if any, for "Use separate colour for the main text").

I spoke with DrO a while ago about this, and it was seemed to have been resolved.

Reference

Changelog *especially "Fixed the Colouriser api to correctly initialise it's default colours when using the default Classic skin and improved detection and handling with other skins"*

Since 6b, a user has been able to search for strings separated by spaces, but its only now that I see that you are right... you can't yet (if its ever been possible) search with mixed case strings. The lowercase requirement may be some extension of the extended character support, which seems broken (as far as jap and chinese support is concerned).

I am sure DrO will see this and work to resolve this issue in good time. We've sure sent him enough thread notifications about it .

jmat
jmatthews112 is offline   Reply With Quote
Old 13th July 2005, 21:47   #238
Squadman
Senior Member
 
Squadman's Avatar
 
Join Date: Nov 2004
Location: UK
Posts: 284
Send a message via AIM to Squadman
Well, In the colouriser tab, the only options I have ticked are:

- Highlight Backround Of Queued Items In Playlist
- Span the highlight across the full queued item
- Use the exisiting Colour options (as above)

And the first colour box at the top right is a light blue...
Squadman is offline   Reply With Quote
Old 13th July 2005, 22:50   #239
jmatthews112
Major Dude
 
Join Date: Jun 2003
Posts: 1,661
Send a message via AIM to jmatthews112 Send a message via Yahoo to jmatthews112
What skin are you using? Have you tried using the reset button to the right of the color box?

jmat
jmatthews112 is offline   Reply With Quote
Old 14th July 2005, 10:34   #240
Squadman
Senior Member
 
Squadman's Avatar
 
Join Date: Nov 2004
Location: UK
Posts: 284
Send a message via AIM to Squadman
I tried 'reset', no change.

I'm currently using 'Ren and Stimpy' classic skin.

I've tried normal classic skin, same problem. Although, i've yet to see the problem in Modern skin. It must be something to do with classic.

Also, when I enqueueing a lot of files in Classic skin, just trying it out, Winamp crashed. This messege came up:

Quote:
Unhandled exception: 07/14/2005 10:26:17
Exception code: C0000005 ACCESS_VIOLATION
Fault address: 019E692B 00:00000000 C:\Program Files\Winamp\Plugins\gen_jumpex.dll

Registers:
EAX:00000200
EBX:00000000
ECX:00000180
EDX:0018DE80
ESI:0018DD68
EDI:0018DE80
CS:EIP:001B:019E692B
SS:ESP:0023:0012CE20 EBP:0012CE24
DS:0023 ES:0023 FS:003B GS:0000
Flags:00010287

Call stack:
Address Frame
019E692B 0012CE240000:00000000 C:\Program Files\Winamp\Plugins\gen_jumpex.dll
019E8747 0012CE440000:00000000 C:\Program Files\Winamp\Plugins\gen_jumpex.dll
019DF877 000000010000:00000000 C:\Program Files\Winamp\Plugins\gen_jumpex.dll

Loaded Modules:
winamp.exe Load Address: 0x400000 - 0x52C000 (1200k)
( C:\Program Files\Winamp\winamp.exe )
ntdll.dll Load Address: 0x7C900000 - 0x7C9B0000 (704k)
( C:\WINDOWS\system32\ntdll.dll )
kernel32.dll Load Address: 0x7C800000 - 0x7C8F4000 (976k)
( C:\WINDOWS\system32\kernel32.dll )
COMCTL32.dll Load Address: 0x773D0000 - 0x774D2000 (1032k)
( C:\WINDOWS\WinSxS\X86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.2180_x-ww_a84f1ff9\COMCTL32.dll )
msvcrt.dll Load Address: 0x77C10000 - 0x77C68000 (352k)
( C:\WINDOWS\system32\msvcrt.dll )
ADVAPI32.dll Load Address: 0x77DD0000 - 0x77E6B000 (620k)
( C:\WINDOWS\system32\ADVAPI32.dll )
RPCRT4.dll Load Address: 0x77E70000 - 0x77F01000 (580k)
( C:\WINDOWS\system32\RPCRT4.dll )
GDI32.dll Load Address: 0x77F10000 - 0x77F56000 (280k)
( C:\WINDOWS\system32\GDI32.dll )
USER32.dll Load Address: 0x77D40000 - 0x77DD0000 (576k)
( C:\WINDOWS\system32\USER32.dll )
SHLWAPI.dll Load Address: 0x77F60000 - 0x77FD6000 (472k)
( C:\WINDOWS\system32\SHLWAPI.dll )
MSACM32.dll Load Address: 0x77BE0000 - 0x77BF5000 (84k)
( C:\WINDOWS\system32\MSACM32.dll )
WINMM.dll Load Address: 0x76B40000 - 0x76B6D000 (180k)
( C:\WINDOWS\system32\WINMM.dll )
comdlg32.dll Load Address: 0x763B0000 - 0x763F9000 (292k)
( C:\WINDOWS\system32\comdlg32.dll )
SHELL32.dll Load Address: 0x7C9C0000 - 0x7D1D4000 (8272k)
( C:\WINDOWS\system32\SHELL32.dll )
ole32.dll Load Address: 0x774E0000 - 0x7761D000 (1268k)
( C:\WINDOWS\system32\ole32.dll )
serwvdrv.dll Load Address: 0x5CD70000 - 0x5CD77000 (28k)
( C:\WINDOWS\system32\serwvdrv.dll )
umdmxfrm.dll Load Address: 0x5B0A0000 - 0x5B0A7000 (28k)
( C:\WINDOWS\system32\umdmxfrm.dll )
uxtheme.dll Load Address: 0x5AD70000 - 0x5ADA8000 (224k)
( C:\WINDOWS\system32\uxtheme.dll )
MSCTF.dll Load Address: 0x74720000 - 0x7476B000 (300k)
( C:\WINDOWS\system32\MSCTF.dll )
CLBCATQ.DLL Load Address: 0x76FD0000 - 0x7704F000 (508k)
( C:\WINDOWS\system32\CLBCATQ.DLL )
OLEAUT32.dll Load Address: 0x77120000 - 0x771AC000 (560k)
( C:\WINDOWS\system32\OLEAUT32.dll )
COMRes.dll Load Address: 0x77050000 - 0x77115000 (788k)
( C:\WINDOWS\system32\COMRes.dll )
VERSION.dll Load Address: 0x77C00000 - 0x77C08000 (32k)
( C:\WINDOWS\system32\VERSION.dll )
shdocvw.dll Load Address: 0x77760000 - 0x778CC000 (1456k)
( C:\WINDOWS\System32\shdocvw.dll )
CRYPT32.dll Load Address: 0x77A80000 - 0x77B14000 (592k)
( C:\WINDOWS\system32\CRYPT32.dll )
MSASN1.dll Load Address: 0x77B20000 - 0x77B32000 (72k)
( C:\WINDOWS\system32\MSASN1.dll )
CRYPTUI.dll Load Address: 0x754D0000 - 0x75550000 (512k)
( C:\WINDOWS\system32\CRYPTUI.dll )
WINTRUST.dll Load Address: 0x76C30000 - 0x76C5E000 (184k)
( C:\WINDOWS\system32\WINTRUST.dll )
IMAGEHLP.dll Load Address: 0x76C90000 - 0x76CB8000 (160k)
( C:\WINDOWS\system32\IMAGEHLP.dll )
NETAPI32.dll Load Address: 0x5B860000 - 0x5B8B4000 (336k)
( C:\WINDOWS\system32\NETAPI32.dll )
WININET.dll Load Address: 0x771B0000 - 0x77256000 (664k)
( C:\WINDOWS\system32\WININET.dll )
WLDAP32.dll Load Address: 0x76F60000 - 0x76F8C000 (176k)
( C:\WINDOWS\system32\WLDAP32.dll )
Secur32.dll Load Address: 0x77FE0000 - 0x77FF1000 (68k)
( C:\WINDOWS\system32\Secur32.dll )
urlmon.dll Load Address: 0x77260000 - 0x772FE000 (632k)
( C:\WINDOWS\system32\urlmon.dll )
in_cdda.dll Load Address: 0x10000000 - 0x10032000 (200k)
( C:\Program Files\Winamp\Plugins\in_cdda.dll )
in_dshow.dll Load Address: 0xE00000 - 0xE29000 (164k)
( C:\Program Files\Winamp\Plugins\in_dshow.dll )
WSOCK32.dll Load Address: 0x71AD0000 - 0x71AD9000 (36k)
( C:\WINDOWS\system32\WSOCK32.dll )
WS2_32.dll Load Address: 0x71AB0000 - 0x71AC7000 (92k)
( C:\WINDOWS\system32\WS2_32.dll )
WS2HELP.dll Load Address: 0x71AA0000 - 0x71AA8000 (32k)
( C:\WINDOWS\system32\WS2HELP.dll )
in_midi.dll Load Address: 0xE30000 - 0xE4D000 (116k)
( C:\Program Files\Winamp\Plugins\in_midi.dll )
read_file.dll Load Address: 0xE50000 - 0xE6B000 (108k)
( C:\Program Files\Winamp\Plugins\read_file.dll )
in_mod.dll Load Address: 0xE70000 - 0xE9E000 (184k)
( C:\Program Files\Winamp\Plugins\in_mod.dll )
in_mp3.dll Load Address: 0x13700000 - 0x137E1000 (900k)
( C:\Program Files\Winamp\Plugins\in_mp3.dll )
in_mp4.dll Load Address: 0xEA0000 - 0xEB9000 (100k)
( C:\Program Files\Winamp\Plugins\in_mp4.dll )
in_mplayer.dll Load Address: 0xEC0000 - 0xED7000 (92k)
( C:\Program Files\Winamp\Plugins\in_mplayer.dll )
mplayer.dll Load Address: 0x64280000 - 0x64773000 (5068k)
( C:\Program Files\Winamp\Plugins\mplayer.dll )
OPENGL32.DLL Load Address: 0x5ED00000 - 0x5EDCC000 (816k)
( C:\WINDOWS\system32\OPENGL32.DLL )
GLU32.dll Load Address: 0x68B20000 - 0x68B40000 (128k)
( C:\WINDOWS\system32\GLU32.dll )
DDRAW.dll Load Address: 0x73760000 - 0x737A9000 (292k)
( C:\WINDOWS\system32\DDRAW.dll )
DCIMAN32.dll Load Address: 0x73BC0000 - 0x73BC6000 (24k)
( C:\WINDOWS\system32\DCIMAN32.dll )
in_nsv.dll Load Address: 0xF00000 - 0xF3F000 (252k)
( C:\Program Files\Winamp\Plugins\in_nsv.dll )
in_vorbis.dll Load Address: 0xF40000 - 0xF7C000 (240k)
( C:\Program Files\Winamp\Plugins\in_vorbis.dll )
in_wave.dll Load Address: 0xF80000 - 0xF8B000 (44k)
( C:\Program Files\Winamp\Plugins\in_wave.dll )
in_wm.dll Load Address: 0xF90000 - 0xFDE000 (312k)
( C:\Program Files\Winamp\Plugins\in_wm.dll )
wdmaud.drv Load Address: 0x72D20000 - 0x72D29000 (36k)
( C:\WINDOWS\system32\wdmaud.drv )
msacm32.drv Load Address: 0x72D10000 - 0x72D18000 (32k)
( C:\WINDOWS\system32\msacm32.drv )
midimap.dll Load Address: 0x77BD0000 - 0x77BD7000 (28k)
( C:\WINDOWS\system32\midimap.dll )
out_disk.dll Load Address: 0x1140000 - 0x1148000 (32k)
( C:\Program Files\Winamp\Plugins\out_disk.dll )
out_ds.dll Load Address: 0x1150000 - 0x115E000 (56k)
( C:\Program Files\Winamp\Plugins\out_ds.dll )
out_wave.dll Load Address: 0x1160000 - 0x1167000 (28k)
( C:\Program Files\Winamp\Plugins\out_wave.dll )
xpsp2res.dll Load Address: 0x11A0000 - 0x1465000 (2836k)
( C:\WINDOWS\system32\xpsp2res.dll )
gen_ff.dll Load Address: 0x1670000 - 0x18A7000 (2268k)
( C:\Program Files\Winamp\Plugins\gen_ff.dll )
OLEPRO32.DLL Load Address: 0x5EDD0000 - 0x5EDE7000 (92k)
( C:\WINDOWS\system32\OLEPRO32.DLL )
gen_find_on_disk.dll Load Address: 0x19B0000 - 0x19B4000 (16k)
( C:\Program Files\Winamp\Plugins\gen_find_on_disk.dll )
gen_hotkeys.dll Load Address: 0x19C0000 - 0x19C8000 (32k)
( C:\Program Files\Winamp\Plugins\gen_hotkeys.dll )
gen_jumpex.dll Load Address: 0x19D0000 - 0x19FD000 (180k)
( C:\Program Files\Winamp\Plugins\gen_jumpex.dll )
gen_ml.dll Load Address: 0x10720000 - 0x107A8000 (544k)
( C:\Program Files\Winamp\Plugins\gen_ml.dll )
gen_MSN.dll Load Address: 0x1AE0000 - 0x1AE5000 (20k)
( C:\Program Files\Winamp\Plugins\gen_MSN.dll )
ml_ipod.dll Load Address: 0x1AF0000 - 0x1B2B000 (236k)
( C:\Program Files\Winamp\Plugins\ml_ipod.dll )
gen_nunzio.dll Load Address: 0x1D40000 - 0x1D55000 (84k)
( C:\Program Files\Winamp\Plugins\gen_nunzio.dll )
gen_one_click.dll Load Address: 0x1D60000 - 0x1D65000 (20k)
( C:\Program Files\Winamp\Plugins\gen_one_click.dll )
gen_tray.dll Load Address: 0x1D70000 - 0x1D77000 (28k)
( C:\Program Files\Winamp\Plugins\gen_tray.dll )
rasapi32.dll Load Address: 0x76EE0000 - 0x76F1C000 (240k)
( C:\WINDOWS\system32\rasapi32.dll )
rasman.dll Load Address: 0x76E90000 - 0x76EA2000 (72k)
( C:\WINDOWS\system32\rasman.dll )
TAPI32.dll Load Address: 0x76EB0000 - 0x76EDF000 (188k)
( C:\WINDOWS\system32\TAPI32.dll )
rtutils.dll Load Address: 0x76E80000 - 0x76E8E000 (56k)
( C:\WINDOWS\system32\rtutils.dll )
dsound.dll Load Address: 0x73F10000 - 0x73F6C000 (368k)
( C:\WINDOWS\system32\dsound.dll )
KsUser.dll Load Address: 0x73EE0000 - 0x73EE4000 (16k)
( C:\WINDOWS\system32\KsUser.dll )
msv1_0.dll Load Address: 0x77C70000 - 0x77C93000 (140k)
( C:\WINDOWS\system32\msv1_0.dll )
iphlpapi.dll Load Address: 0x76D60000 - 0x76D79000 (100k)
( C:\WINDOWS\system32\iphlpapi.dll )
USERENV.dll Load Address: 0x769C0000 - 0x76A73000 (716k)
( C:\WINDOWS\system32\USERENV.dll )
DBGHELP.dll Load Address: 0x59A60000 - 0x59B01000 (644k)
( C:\WINDOWS\system32\DBGHELP.dll )

Generated by JTFE
JTFE version: v0.97 R (Build 11)
Winamp verison: 5.09
I've also had a few other crashes when clicking around in classic, but with no messege, or reason.
Squadman is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump