Old 5th March 2009, 19:33   #1
Stradart
Junior Member
 
Join Date: Mar 2009
Posts: 1
Install error; CD Ripping-Burning

Hi everyone,
Just downloaded winamp 5.5 free.
While installing I had the following error message;
"There was a problem intalling components. CD Ripping, Burning may not function properly '-1'" I clicked ok and installation continued to the end just fine. The software works fine all options are working but I can't burn CDs. Half way through process, it stops.
My system is VISTA home Premium.
Anyone had this problem?
thanks for a response,
Stradart
Stradart is offline   Reply With Quote
Old 5th March 2009, 20:31   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,827
Close any programs which might manage cd drives or use the Sonic Engine
(e.g. Windows Media Player, Roxio, Sonic RecordNow, Sonic MyDVD, Nero, etc),
including any which place icons in the systray,
then try to reinstall Winamp 5.55 again.
DJ Egg is offline   Reply With Quote
Old 25th August 2009, 06:03   #3
statikk1
Junior Member
 
Join Date: Aug 2009
Posts: 1
I hope this is of help to you as I searched and searched the forums and the internet and in the end based on what I was seeing I solved my problem myself by simply doing this..

First, you should know I am running Windows 7 Ultimate x64(Not RC)
I am not sure if I had this problem on Vista x64 as I did not listen to or try ripping Audio CD's up until now.

I uninstalled and reinstalled to be greeted by your same error again. As I said, after much reading I did this. Installed Winamp 5.56 within my Vista 32bit Virtual PC and located the px.dll library that the winamp installer dropped into c:\windows\system32 folder. From this WORKING install I copied this file to my Windows 7 installation in the c:\windows\system32 folder and wholla .. Even though winamp was whinging on install about CD ripping/burning may not work.. it did... I haven't tried burning but CD playback and ripping works fine.
NOTe: do not try using the dll from older/diff versions of winamp. I tried... It seems to lock it up less severely but it still causes it to hang. COME ON WINAMP PROGRAMMERS.. I know you love your comeback "Win 7 is still in Beta/RC" so you are not fussed.. Well how about the file assosciation problems that are there on Vista 64 bit.. especially if you've allowed another program to assosicate itself before winamp did (such as windows media player). This problem is carried over in Win 7 64bit. elevator.exe is useless to me. I have Winamp working perfectly now without that.

Windows 7 x64 (and possibly Vista x64) users should note.. I had COMPLETE system lockups trying to use the CD playback and ripping functionality..before this workaround. So be careful if you have not saved your work as you try this. I would suggest that you do nothing while sorting this issue out

I now have a note to myself on every Windows 7 install as to what needs to be done. I might script a winamp installer that will do the dll copy automatically. Will see how bored I am first LOL
statikk1 is offline   Reply With Quote
Old 30th October 2009, 12:09   #4
Gyrovagus
Junior Member
 
Join Date: Oct 2009
Posts: 1
Similar error

I received the same error on install, but the end result is a little different. I can burn CD/DVDs, but the burn rate tops out at 8x, whereas the previous version (I was using 5.54 before I got 5.56) topped out at the expected 24x. I'll double check the systray to make sure there aren't any other programs running, but I generally shut everything down when I install. Just in case you need it, I've included my system information below.

PC: Toshiba Satellite x205-sli6
Processor: • Intel Core 2 Duo T9300 / 2.5 GHz
RAM: 3GB
Video Card: 2 NVIDIA GeForce 8600M GT TurboCache - PCI Express x16
Windows OS: Windows Vista Ultimate 32-bit (Service Pack 2)
DirectX: 10
Winamp Version: Pro
Gyrovagus is offline   Reply With Quote
Old 11th March 2011, 23:39   #5
harveylarva
Junior Member
 
Join Date: Mar 2011
Posts: 2
I have this problem with Pro 5.601. I can play, but there is no burn/rip button anywhere. I installed on a fresh boot with all virus and other stuff disabled.

What do I do? Can I get my money back. I have to download something else, right now, so I can burn.

I'm on Win 7, by the way. Win version 6.1.7600
harveylarva is offline   Reply With Quote
Old 13th March 2011, 19:13   #6
Batter Pudding
Major Dude
 
Batter Pudding's Avatar
 
Join Date: Jun 2008
Posts: 1,665
@harveylarva: There is a patch available at Roxio that works for many. Search the forum and it should show up. (If I get some spare time, I'll have a look myself as I know I posted the link a few times before)

Edit: Read this thread about CD Burning updates: http://forums.winamp.com/showthread.php?t=324557

Or this one about Ripping changes: http://forums.winamp.com/showthread.php?t=325238
Batter Pudding is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump