Old 15th June 2014, 21:43   #1
ObviouslyJesus
Junior Member
 
Join Date: Dec 2011
Posts: 5
Syncing to Android

I recently got an Android phone and I'm trying to sync some mp3s to my phone in a playlist.

However, I've found that special characters, even innocuous ones like a hyphen, are causing havoc with my sync process.

While the files with special characters sync just fine, when I go to re-sync an updated playlists, the tracks with special characters attempt to sync again, because the name of the folder created on the Android device is being taken not from its counterpart in the Windows file system with the same restrictions on special characters, but from the album name in the ID3 tags of the files being synced.

This has left me with a situation like this:



Colons especially are problematic: in the image above you can see various songs from albums entitled "Daytrotter Session: MM/DD/YYYY", Johnny Cash's
American Recordings:", Josh Ritter's "Live at the 9:30 Club", and LCD Soundsystem's "The Long Goodbye:". The slashes in two-track singles like The National's "Exile Vilify/Think You Can Wait" and Radiohead's "Supercollider/The Butcher" are also causing problems. Weirdly, Angels of Light's "Not Here/Not Now" is not causing problems, possibly because the slash is in the filename, not the folder. Not sure on that one. Finally, Android seems to be truncating the final period in "R.E.M.", making it into "R.E.M"

The folders on the Android device are, in turn, "Live at the 9_30 Club", "The Long Goodbye_", "Exile Vilify_Think You Can Wait", etc.

My question is this: is there any way to get Winamp to sync to Android and mirror the folder structure in Windows, rather than having it read from the ID tags of the files?

Please help me figure this out, or point me to other threads where this issue has been discussed/resolved.

The device does not seem to be even getting recognized as an android device, probably because Verizon is awful and has disabled Mass Storage mode on the phone, and even when I use my root access to try to re-enable it, the drive it shows up as is a 12mb drive full of Verizon bloatware to install on my PC.

Last edited by ObviouslyJesus; 15th June 2014 at 23:21.
ObviouslyJesus is offline   Reply With Quote
Old 24th June 2014, 09:27   #2
ObviouslyJesus
Junior Member
 
Join Date: Dec 2011
Posts: 5
Bump
ObviouslyJesus is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Tags
android, sync, troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump