Old 8th July 2013, 11:04   #1
MasterViVi
Senior Member
 
MasterViVi's Avatar
 
Join Date: Nov 2003
Posts: 290
[5.64] Play Count Is Not Always Increased (?)

Winamp 5.64

Since the update, the play count is not always increased.
Seems to be when I have paused the song. Quite annoying since I use it to track unplayed songs...

Settings are "count when 50%"
MasterViVi is offline   Reply With Quote
Old 8th July 2013, 14:41   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
that's by design now, pausing a song halts the tracking as it was otherwise causing complaints of things being tracked when they shouldn't be (knew it'd be too good to alter that and it not cause the reverse like with your post).

though is this against history or the local library tracking option ? as they follow the same behaviour, just would be helpful to know which one you're specifically using.

either way, i'll have to have a think about it as the changes (which were made internally just under a year ago) resolve a number of other issues and i'd prefer not to revert things, though am also not keen on adding in extra options for this as there's not really any space for such config options on the preference pages anymore.
DrO is offline   Reply With Quote
Old 9th July 2013, 09:51   #3
MasterViVi
Senior Member
 
MasterViVi's Avatar
 
Join Date: Nov 2003
Posts: 290
I use the play count in the Local Library (I have a view "unplayed") which I've now noticed contains several tracks which I've actually played.

I've lowered it now to 10%, since I'd rather have more tracked than less. It's better now.
MasterViVi is offline   Reply With Quote
Old 11th July 2013, 13:15   #4
MasterViVi
Senior Member
 
MasterViVi's Avatar
 
Join Date: Nov 2003
Posts: 290
Actually, the tracking doesn't seem to work anymore...

I've noticed when pausing, it's never tracked (even though it was paused in the first second, and then it's played until the end, it's not tracked).
Second, I've set it to "wait 120 seconds or wait 10%" and it only got tracked towards the end of the song.
I've also seen one or two songs not tracking at all whilst not pausing and played completely.

Is it possible to include an option in winamp.ini to enable the old behaviour? Seems to be a bit unreliable now (of course, I didn't have bugs with the previous implementation, so I couldn't complain about it not working then ).
MasterViVi is offline   Reply With Quote
Old 11th July 2013, 13:39   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
the old way is not coming back, sorry but that involves more hassle to have differing code paths for things (as well as trying to find out and add back in the old way when other aspects in the plug-in handling has since changed so would need more work to re-implement against those changes). and in all honesty, i just don't want to have to support that sort of a mess. i'll have to re-check the handling of things (so that's going to push back updated builds being released *joy* ).
DrO is offline   Reply With Quote
Old 16th July 2013, 03:09   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
i've resolved the paused/unpaused handling (which under the old code was a bug) for the ml_local and ml_history instances. with the other things mentioned, if it's still present in the coming v5.65 release then will need to have more specific steps to consistently replicate the issue to be able to debug it further.
DrO is offline   Reply With Quote
Old 18th July 2013, 09:21   #7
MasterViVi
Senior Member
 
MasterViVi's Avatar
 
Join Date: Nov 2003
Posts: 290
Of course.

When I still have problems in the next release, I'll let you know with more detailed steps.
Thanks for looking into it!
MasterViVi is offline   Reply With Quote
Old 23rd July 2013, 12:48   #8
DrO
 
Join Date: Sep 2003
Posts: 27,873
the current beta (v5.7.3435 at the time of reply) should resolve the issue you reported (though it's broken something else so i may have to roll this change back).
DrO is offline   Reply With Quote
Old 22nd August 2013, 15:32   #9
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,658
Hi DrO,

I need to understand how tracking and play counting is handled in the current beta (v5.7.3443).

I have both the 'History' and 'Recently Played' options set to track at 90% of playback.

History seems to track when a song is completely played, even if the song was paused or restarted during playback. Recently Played does not seem to track if a song was paused or restarted before it completely played.

Is this the intended behavior until you have more time to look at the pause/restart issue with tracking and play count?

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 22nd August 2013, 15:47   #10
DrO
 
Join Date: Sep 2003
Posts: 27,873
ergh, i thought i'd sorted this out so i could forget about it once and for all (and we're on 3444 now, 3443 is so yesterday ).

they're both meant to be able to track in basically the same way unless i've forgotten to update ml_local's handling to match how ml_history does things.

ml_history can cope with pausing since it re-starts the internal timer whilst factoring in what has been played and now i'm typing this, i've really don't think i ported that change to ml_local *meh*


so the ml_history implementation is the desired option (at least from what i had noted about it all) and ml_local's is basically the runt of the litter at the moment due to the disparity.
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump