Old 29th June 2010, 22:53   #1
glenncarr
Junior Member
 
Join Date: Feb 2002
Location: Tulsa, OK, US
Posts: 26
Send a message via AIM to glenncarr Send a message via Yahoo to glenncarr
problems building NSIS

We're using a slightly customized version of NSIS which we built a couple of years ago. I'm attempting to rebuild, and I'm missing something.

I have
Python 2.6.5
scons 1.3.0
Visual Studio 2008 and 2010

Here are the errors I'm currently getting:
Quote:
c:\dev\NSIS\v237>scons
scons: Reading SConscript files ...

scons: warning: The Options class is deprecated; use the Variables class instead.
File "c:\dev\NSIS\v237\SConstruct", line 90, in <module>

scons: warning: The BoolOption() function is deprecated; use the BoolVariable() function instead.
File "c:\dev\NSIS\v237\SConstruct", line 95, in <module>

scons: warning: The ListOption() function is deprecated; use the ListVariable() function instead.
File "c:\dev\NSIS\v237\SConstruct", line 154, in <module>

scons: warning: The PathOption() function is deprecated; use the PathVariable() function instead.
File "c:\dev\NSIS\v237\SConstruct", line 166, in <module>
Delete("nsis-29-Jun-2010.cvs")
Delete(".instdist")
Delete(".test")
Using Microsoft tools configuration
KeyError: 'LIB':
File "c:\dev\NSIS\v237\SConstruct", line 365:
envs = SConscript('SCons/Config/ms')
File "c:\Python26\Scripts\..\Lib\site-packages\scons-1.3.0\SCons\Script\SConscript.py", line 616:
return apply(method, args, kw)
File "c:\Python26\Scripts\..\Lib\site-packages\scons-1.3.0\SCons\Script\SConscript.py", line 553:
return apply(_SConscript, [self.fs,] + files, subst_kw)
File "c:\Python26\Scripts\..\Lib\site-packages\scons-1.3.0\SCons\Script\SConscript.py", line 262:
exec _file_ in call_stack[-1].globals
File "c:\dev\NSIS\v237\SCons\Config\ms", line 54:
libdirs = defenv['ENV']['LIB'].split(os.pathsep)
Any tips?
glenncarr is offline   Reply With Quote
Old 30th June 2010, 04:01   #2
glenncarr
Junior Member
 
Join Date: Feb 2002
Location: Tulsa, OK, US
Posts: 26
Send a message via AIM to glenncarr Send a message via Yahoo to glenncarr
...and I wondered why I was having trouble building the latest package. Sheesh.
glenncarr is offline   Reply With Quote
Old 30th June 2010, 04:56   #3
jiake
Senior Member
 
jiake's Avatar
 
Join Date: Oct 2007
Location: Shanghai, China
Posts: 207
Scons doesn't support VS2008 yet, only 2005 now.
I see this on a website, also I have installed VC6.0 and VS2005.
jiake is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Developer Center > NSIS Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump