Old 19th November 2012, 16:18   #1
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
Android Media Library Borked

Hi,
For some albums, I have two copies of the track in the database. I'm pretty sure that I only have one copy of the file.

If I zip, delete in winamp then unzip the album, then this fixes it. However, I don't want to have to do this for every album.

I've tried stopping and clearing data for every music related app (gallery, google play music, winamp) and I can't force a database rebuild.

Any ideas? (Other than deleting and re-transferring my music)
Or just point me to the correct sqlite db and I'll write some fixer-upper queries.

I've got a rooted galaxy nexus running stock 4.1.2, latest Winamp for Android.

Thanks,
Will

(P.S. Hello world!)

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline   Reply With Quote
Old 19th November 2012, 16:38   #2
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
Right, so I cleared the "Media Storage" app. Then winamp and google play music both reported no music on device.

So I rebooted the phone renamed the "Music" folder on my sdcard to "Music1" and then back to "Music" and this fixed it.

This is stupid. Can we have a "rebuild database" feature please?

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp for Android

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump