Prev Previous Post   Next Post Next
Old 1st August 2016, 14:49   #1
abbadon
Junior Member
 
Join Date: Aug 2016
Posts: 2
Can't connect to SHOUTcast 2 server with mixxx

Hello!

I just installed the SHOUTcast on my local server and I'm trying to connect with MIXXX.
But I get only this log:

Debug [EngineShoutcast 16]: EngineShoutcast::run: starting thread
Debug [EngineShoutcast 16]: EngineShoutcast: updating from preferences
Debug [EngineShoutcast 16]: Couldn't find shoutcast metadata codec for codec: "" defaulting to ISO-8859-1.
Debug [EngineShoutcast 16]: Successfully loaded encoder library "mp3lame"
Debug [EngineShoutcast 16]: Loaded libmp3lame version 3.99.5
Debug [EngineShoutcast 16]: Connection pending. Waiting...
Debug [EngineShoutcast 16]: Connection pending. Waiting...
Debug [EngineShoutcast 16]: Connection pending. Waiting...
Debug [EngineShoutcast 16]: Connection pending. Waiting...
Debug [EngineShoutcast 16]: Connection pending. Waiting...
Debug [EngineShoutcast 16]: Connection pending. Waiting...
Debug [EngineShoutcast 16]: Connection pending. Waiting...
Debug [EngineShoutcast 16]: Connection pending. Waiting...
Debug [EngineShoutcast 16]: Connection pending. Waiting...
Debug [EngineShoutcast 16]: Connection pending. Waiting...
Debug [EngineShoutcast 16]: EngineShoutcast:rocessConnect() error: -10 Socket is busy
Debug [EngineShoutcast 16]: Unloaded libmp3lame
Warning [EngineShoutcast 16]: Streaming error: "Please check your connection to the Internet and verify that your username and password are correct."
Debug [Main]: DlgPrefShoutcast::shoutcastEnabledChanged() 0

I use this configuration:
Server: Shoutcast 1
mount : _blank
host: 192.168.1.24
port: 8000
user: admin
password: i tried all the 4 password generated using the build.sh script and connecting with browser

Stream Settings
as default


I started the server with this command

#./sc_serv daemon ./sc_serv.conf

netstat -plnt | grep sc_serv
tcp 0 0 0.0.0.0:8000 0.0.0.0:* LISTEN 27877/sc_serv
tcp 0 0 0.0.0.0:8001 0.0.0.0:* LISTEN 27877/sc_serv

Stream ID: 1
Server Address: 192.168.1.24 (*)
Source Port: 8000
Legacy Source Port: 8000
Password: password3
Max Bitrate Allowed: Unlimited
Protocol Mode: v1 or v2
I can access the server through web browser (firefox)

I'm running mixxx on
Linux 2.6.27.19-5-default x86_64 GNU/Linux (lubuntu)
abbadon is offline   Reply With Quote
 
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Tags
connection, mixxx, problems, server

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump