Old 6th October 2006, 02:29   #1
dang0001
Junior Member
 
Join Date: Sep 2005
Posts: 23
can't resize Winamp windows

My brother was using Winamp to watch video, and when it was over, all the windows within Winamp (the playlist editor, the media library and the panel) were all resized. Normally, this is merely an annoyance, since he's able to resize the windows the way he had them before he started watching the video.

But this time is totally different. The media library is pushed way up so that the words "Media Library" aren't showing at all. The first part of the media library window that's visible is about half-way down (about level with where "online services" appears).

There doesn't appear to be any way to grab the window and pull it down. This is so exasperating. Has anyone ever experienced this? More importatntly, does anybody know how to fix this?

Thanks so much.
dang0001 is offline   Reply With Quote
Old 6th October 2006, 03:56   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,767
Hi. Try this from the FAQ :-)

Windows (main, ml, pl, etc) disappearing off screen:
http://forums.winamp.com/showthread.php?threadid=164598
DJ Egg is offline   Reply With Quote
Old 6th October 2006, 05:05   #3
dang0001
Junior Member
 
Join Date: Sep 2005
Posts: 23
Hey thanks very much.

A question about that link: Are some of the suggestions under the "prevention workarounds" section outdated? It suggests enabling easy move by going to Main menu > Options: Checkmark "Easy Move" - Ctrl+E). And yet, I have no such option.

Similarly, it suggests Disabling auto resizing of video window by going to Prefs > Video. I have no video option under Preferences.

I'm using version 5.24, btw.

I would be so happy if I could find a way to keep my Winamp setup the same all the time. Winamp is an awesome program (the best for media, hands down), but it's a major drag that the whole setup changes each and every time I view a video. What's that all about?
dang0001 is offline   Reply With Quote
Old 6th October 2006, 12:33   #4
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,767
The latest version is 5.3

However, the video options are still the same (see screenshot)

Prefs > Video > Resize video window to fit video (uncheck)


For the Easy Move option, left click the little icon in the top left corner of the main window (or right click anywhere on some gray space) to access Winamp's main menu, then Options > Easy Move.

Note that this only works for classic skins. Easy Move is always on in Modern skins. However, Easy Move for the video window only works with Classic skins, not Modern (ie. for Classic video window you can move it by dragging from inside the actual video window).

If you want your settings to always be the same, although I don't recommend it, but you could make winamp.ini, studio.xnf (Winamp root dir), and gen_ml.ini (Winamp\Plugins dir) all read-only (right-click the file in Windows Explorer, select Properties, checkmark 'read-only', Apply).
Attached Images
File Type: png video_options.png (21.7 KB, 316 views)
DJ Egg is offline   Reply With Quote
Old 6th October 2006, 18:14   #5
dang0001
Junior Member
 
Join Date: Sep 2005
Posts: 23
Oh, you're right. My bad.

It still seems silly that if you're using the modern skin and the media library gets pushed up there doesn't seem to be any way to fix it other than deleting studio.xnf. (As far as I can tell, the easygrab fix works only with the classic skin.)

Also, I've figured out how to reproduce this problem with the media library: While in the modern skin, click on the "window shade mode" on the upper right-hand side of the playlist editor. This pushes the media library way the heck up. (See images)
Attached Images
File Type: jpg before.jpg (34.8 KB, 300 views)
dang0001 is offline   Reply With Quote
Old 6th October 2006, 18:17   #6
dang0001
Junior Member
 
Join Date: Sep 2005
Posts: 23
Below is what Winamp looks like after I click the windowshade mode button. Curiously, I'm able to drag the media library down simply by dragging down the main window, which is attached to the media library. (I thought I tried this approach last night and it failed, but maybe I was just tired.)

At any rate, now that we can reproduce this behavior, maybe somebody at Nullsoft can fix this bug?
Attached Images
File Type: jpg after1.jpg (28.9 KB, 447 views)
dang0001 is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump