Old 17th December 2013, 08:57   #1
Headshaker
Junior Member
 
Join Date: Dec 2013
Posts: 6
XML metadata changes in DNAS 2.2 and 2.2.1 ?

Hi,

I've got question especially to DrO.
I've noticed change in DNAS (LINUX) behaviour when sending XML metadata to server.

I was sending XML formated metada using this:
code:
"GET /admin.cgi?sid=$id&mode=updinfo&type=xml&song=$xml&pass=$pass HTTP/1.0\r\nUser-Agent:Mozilla/4.0\r\n\r\n"


With previous versions of sc_serv XML was properly parsed and all properties were properly set.

From DNAS version 2.2 whole xml code is displayed as track title.

Is the way of sending xml metadata to DNAS has been changed ?
Headshaker is offline   Reply With Quote
Old 17th December 2013, 09:06   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
it shouldn't have changed other than not needing the type=xml param as it checks what's received to determine how to handle it. so I'd need to see an example of the actual request being sent and seen as being received by the DNAS.
DrO is offline   Reply With Quote
Old 23rd December 2013, 11:05   #3
Headshaker
Junior Member
 
Join Date: Dec 2013
Posts: 6
I have worked out what was wrong. I have removed type=xml param and formated properly xml so it's recognised by sc_serv 2.2.1

But I found something different:

When I'm broadcasting from DSP (2.3.3 [build 201]) through djport2 I have set 'Name' field in 'Directory' tab so station name is changing on this one. After disconnecting station name remains the same instead of displaying streamtitle set in sc_trans
Headshaker is offline   Reply With Quote
Old 23rd December 2013, 11:09   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
sc_trans is buggy beta software and doesn't support those parts correctly so that would explain the title weirdness. other than forcing manual updates, i don't have any solution.
DrO is offline   Reply With Quote
Old 23rd December 2013, 11:41   #5
neralex
Major Dude
 
Join Date: Mar 2011
Posts: 546
DrO ist right, in this case you must set the streamtitle manually again.

This issue comes only if you are sending the streamtitles manually and not through the id3 tags of your files. If you have set the id3 tags for artist and trackname in your mp3-files, then the sc_trans is loading the right id3 tags after the disconnecting of your streaming-client.
neralex is offline   Reply With Quote
Old 26th December 2013, 16:33   #6
Headshaker
Junior Member
 
Join Date: Dec 2013
Posts: 6
But this was working properly in previous version of sc_serv (it was 2.0 I think) or it was unwanted behaviour there ?
I left sc_trans untouched
Headshaker is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > SHOUTcast > SHOUTcast Technical Support

Tags
dnas, metadata, xml

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump