Old 8th June 2001, 02:43   #1
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,773
*** Official Winamp 2x bug list ***

For the attention of Winamp 2x dev team:

*** Compiled by PP and DJ-Egg: June 2001+ ***
All original entries applied to Winamp versions 2.76 and earlier.

*** Updated: Oct. 2001+ ***
Includes afternotes denoting whether fixed in v2.77+.
__________________________________________________________________

Regular known bugs:

#1. Limited/Missing extensions on 'All supported formats' list in OpenFile dialog.
No more explanations needed - just install a big bunch of input plug-ins and see what happens - formats from the bottom of the list aren't recognized when 'All supported types' is selected. This is NOT an input plug-in bug.
Further info here (towards end of thread)

* fixed in v2.77 ???
Apparently this is a Windows bug (256 character limitation in Open Files Dialog), and has nothing to do with Winamp ?!?!

#2. Safety of multi-instance detection.
See these threads for info: 1 | 2 | 3
FindWindow() call is NOT good here. Suggested fix:use CreateMutex() to ensure max safety.

* fixed in v2.77 (I think! gulp . . . mixed reports so far)
* definitely fixed in v2.79

#3. DirectSound output eats some very small files.
Yes, I do know about DirectSound circular buffer notification freakiness.
Suggested fix: padwith silence when you get end-of-song null block (and add this damn thing to official plug-in specs). Some people also complain about DirectSound output cutting off end of song; this is probably the same problem.
Further info here
Replacement plugin available here

* fixed in v2.79

#4. The playlist window sometimes grows too large and it isn't possible to shrink it down without messing with Winamp.ini. Especially annoying when copying Winamp from one computer to another one with lower screen resolution.
Example #1
Forum Search: keywords = pe_height | pe_width

* fixed in v2.77

#5. There are tons of 'modern' VOC files that don't work at all (chunktype 9) - see specs from wotsit.org.
For a big bunch of sample files, run some ripper on Duke Nukem 3Dmain GRP file.

* fixed in v2.77

#6. association with extensionless files (occurs randomly)
Just happened on my second comp and it seriously pissed me off.

Egg's comments:
Yes, this one's cropped up a few times in the past, but was supposed to be fixed.
It's something to do with "Register Files on Winamp start". The only way to get rid of it is to uncheck that option, then edit the registry under: HKEY_CLASSES_ROOT\.
(ie. the "full-stop" (period) key for extensionless files, near top of list)
Remove: "Winamp.File" under default string, etc.
From: TSGH -> Useful Links -> File Associations section : Further info = here

* fixed in v2.77 (apparently)


#7. Main window tooltips for play/stop/pause/etc buttons are hidden behind the EQ when EQ window is placed directly underneath main window. Needs a tooltips "always on top" hack.

__________________________________________________________________


Misc glitches:

#1. (wishlist) "New playlist" command needs extra "save" confirmation - you can accidentially delete whole playlist without any warning. An undo option would also be pretty neat.

#2. (wishlist) Pre-v2.10 output plug-in selection menu was better...
(see all newbie posts complaining about Winamp converting things instead of playing them).

#3. Just tested new URL drag&drop shiz. It wouldn't be a bad idea if it called in_Module::Play() _after_ returning from WM_DROPFILES (or whatever you use to get notification). Try to play some MIDI file and you will find why. (use PostMessage or something to do delayed start)

* fixed in v2.77

#4. Couldn't find destination format error, caused by WAV files containing MP3data on a system without MP3 ACM driver installed. This could be worked-around by a simple cross-dll hack or by making in_mp3 steal these files from in_wave - (they do work after renaming to .mp3)

#5. VIS doesn't work correctly with 24 & 32-bit samples

#6. EQ could at least ignore 24 & 32-bit samples instead of messing them up

#7. (wishlist) automatically remove trailing space in "open url" box.
__________________________________________________________________

DJ-Egg's addendum:

#1. Double frame-count display in File Info box:

The frame-count for all CBR MP3's is displayed at double the actual amount.
Alt+3 for any MP3. Make a note of the frames #
Now open the same MP3 with any other ID3 tag editor.
Note that the actual frame-count is half of whatever Winamp says it is.

* fixed in v2.77

#2. Win2k Dir context menus bug:
http://forums.winamp.com/showthread.php?threadid=46361 (includes manual regfix)
http://forums.winamp.com/showthread.php?threadid=49733

#3. CD Autoplay bug: (system specific)
http://forums.winamp.com/showthread.php?threadid=48777

#4. Memory leak with WMA file on pause:
http://forums.winamp.com/showthread.php?threadid=49470
http://forums.winamp.com/showthread.php?threadid=52339

* fixed in v2.78


Misc Reports from Bugs Forum:

#1. DirectSound Output bug � Fast forward does not advance to the next song but, instead, keeps counting time on the same track even after it is finished.

Egg's comments:
Yes, to reproduce, drag the seekbar right to the end of the currently playing song.
Timer stops, analyzer oscillates, no playlist advance.

* Seekbar drag with mouse = fixed in v2.77
* bug now only occurs when using right kyb cursor

* fixed in v2.79

#2. "Stop after Current" bug � select option, hit next track, option still checked but no longer in effect.

Egg's comments:
Confirmed & Reproduced!
__________________________________________________________________

Latest update : 20/07/01

to bugs:

DirectSound output pausing is kinda messed up. It seems to flush the buffer
(playback is usually restarted one or two seconds ahead).

to glitches:

DirectSound output could use some more smart prebuffering logic
(beginning of song is sometimes crippled when CPU usage is high).

-PP

Egg's comments:
Hmm, not sure if I can reproduce these two.
Seems alright to me ?!?!

* both fixed in v2.79
__________________________________________________________________

Latest update : 29/07/01

Error reading bitrate of MPEG 2.5 files in File Info box:
http://forums.winamp.com/showthread.php?threadid=55723

* fixed in v2.77
__________________________________________________________________

Latest update : 18/08/01

Misc Reports from Bug Reports Forum

Revised: 31/08/01

1) Problem reading time/bitrate of FhG VBRI MP3 headers, reported here

Egg's comments: [revised: 01/09/01]
Problem caused by in_mp3.dll's inability to correctly read VBRI frame headers in MP3's encoded with rippers using the FhG encoder (MMJB, FastEnc, etc)
Files play ok, but time display & bitrate readings are messed up.

Full code specifications outlined here:
http://66.96.216.160/cgi-bin/YaBB.pl...&num=999131627

* proposed fixed for v2.8
__________________________________________________________________

18/08/01 continued [unrevised]

2) Some people are complaining that Winamp isn't sorting the playlist properly when using drag+drop dir, or "dir context menus", regardless of the settings in Prefs -> Options (Sort files on load/read titles on load).
Apparently it only works properly when using the Add Files/Dir button.
This way the files are automatically ordered by filename (as intended), whereas with the other methods they seem to be ordered by FAT32 allocation or date created instead.

Probably a Windows 9x / FAT32 related bug.
Doesn't happen when using Win2k/XP with ntfs file system.

More info here, here and here
__________________________________________________________________

Latest Update : 22/08/01

Not a bug as such, more of a missing feature...
Winamp doesn't support CDDB for proxy connections/port 80 url's, even with CDReader plugin.
RE: Problems with CDDB & proxy / firewalls
http://forums.winamp.com/showthread.php?threadid=57000
http://forums.winamp.com/showthread.php?threadid=31630
http://forums.winamp.com/showthread.php?threadid=32224
http://forums.winamp.com/showthread.php?threadid=36677
__________________________________________________________________

Latest Update : 02/09/01

Alt+Delete kybd shortcut does NOT work for "remove all dead files"

"Rem button -> Misc -> Remove all dead files" works ok when clicking through with mouse, but hotkey doesn't do anything. Doh!

As reported here

* fixed in v2.77
__________________________________________________________________

Latest Update : 09/09/01

Weird minimize to systray bug (reproducable & not 3rd-party plugin related)
http://forums.winamp.com/showthread.php?threadid=59142
__________________________________________________________________

Latest Update : 28/09/01

A plethora of KNOWN skin-related bugs can be found here:
http://forums.winamp.com/showthread.php?threadid=60750
http://forums.winamp.com/showthread.php?threadid=60951
__________________________________________________________________

Latest updates : 07/10/01 +

Win2k/XP random shutdown problems
(with drag+drop/enqueue files from Open Files Dialog)

http://forums.winamp.com/showthread.php?threadid=82474
http://forums.winamp.com/showthread.php?threadid=62127
http://forums.winamp.com/showthread.php?threadid=73596
http://forums.winamp.com/showthread.php?threadid=61560
http://forums.winamp.com/showthread.php?threadid=61748
http://forums.winamp.com/showthread.php?threadid=61833
http://forums.winamp.com/showthread.php?threadid=61863
http://forums.winamp.com/showthread.php?threadid=61955
http://forums.winamp.com/showthread.php?threadid=67283

Here's the official 2.7x fix (c/o Justin - 19th April 2002)
http://www.firehose.net/~deadbeef/wafix.zip

* fixed in v2.80

From whatsnew.txt:
* fixed drag&drop from open file dialog related bugs
__________________________________________________________________

PLS Autorun problem in IE5.5+ (audio/x-scpls)
http://forums.winamp.com/showthread.php?threadid=37053
This one's been around for ages!
Fix: Winamp needs to register audio/x-scpls on installation (extension = .pls)
Though this is probably more related to some stupid IE Security Update patch,
or another player b0rking things up (eg. RealPlayer)
__________________________________________________________________

Weird windows snapping glitch:
http://forums.winamp.com/showthread.php?threadid=61775
On maximizing from windowshade mode, main window vanishes behind EQ & Playlist when playlist window is set to a wider size and the other 2 windows are snapped to the right-hand side of the screen.

Similar related problem:
http://forums.winamp.com/showthread.php?threadid=66855
__________________________________________________________________

Support for Unicode characters in filenames/ID3 tags:

As reported many times here and here

Peter's suggested fix:
http://forums.winamp.com/showthread....765#post395765

* partially fixed in v2.79 (Support for unicode characters in ID3v2 tags)

* further fix in v2.80

From WA 2.80 whatsnew.txt
* included PP's hacks for slightly better unicode filename support
__________________________________________________________________

Latest updates : 7th April 2002

Some (minor?) glitches are reported here (some confirmed, others not):
http://forums.winamp.com/showthread.php?threadid=64077

DevTeam please look into this!

Confirmed bugs/glitches:
http://forums.winamp.com/showthread.php?threadid=84028 (active window focus switch)
http://forums.winamp.com/showthread.php?threadid=64540 (read titles on display)

__________________________________________________________________
__________________________________________________________________

For playback related issues, v2.81 users should install this patch
Winamp 2 Update
(Includes latest versions of out_wave & out_ds plugins, and latest wave, mod, midi, vorbis inputs)
__________________________________________________________________

Original document compiled by Peter Pawlowski

Edited, recompiled & appended for TSGH by DJ-Egg.

This doc will be updated accordingly on a regular basis.

nb. date format above uses European standard (Day/Month/Year), not US
__________________________________________________________________

Last Updated : 9th March 2003
DJ Egg is offline   Reply With Quote
Old 6th October 2001, 18:04   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,773
^ ^
DJ Egg is offline   Reply With Quote
Old 9th March 2003, 22:04   #3
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,773
Latest Update
March 2003

Known Winamp 2.81 bugs
______________________________________________________________________

New bugs previously not listed above

1. Winamp ignores ID3v2 tags when streaming standard mp3's
http://forums.winamp.com/showthread.php?threadid=66866

(Okay, ^this^ is more of an unimplemented feature than a bug)

2. First item selected isn't added to playlist when selecting large number of files via 'Play/Enqueue in Winamp' context menu. Probably occurred as a result of the 2.78
"multiple instances" bug fix, and if so, is certainly the lesser of the two evils.
Reported on numerous occasions, reconfirmed here:
http://forums.winamp.com/showthread....399#post892399

Cannot reproduce with Winamp 5.0x under WinXP
Though bug still being reported under Win2k, eg. here

______________________________________________________________________

Bugs still not fixed from original list above

1. "Stop after Current" bug – select option, hit next track, option still checked but no longer in effect. (fixed in 2.90)

2. Main window tooltips for play/stop/pause/etc buttons are hidden behind the EQ when EQ window is placed directly underneath main window. Needs a tooltips "always on top" hack.

3. Weird minimize to systray bug (reproducable & not 3rd-party plugin related)
http://forums.winamp.com/showthread.php?threadid=59142
______________________________________________________________________

Unconfirmed whether fixed or not from original list

1. Weird windows snapping glitch:
http://forums.winamp.com/showthread.php?threadid=61775
On maximizing from windowshade mode, main window vanishes behind EQ & Playlist when playlist window is set to a wider size and the other 2 windows are snapped to the right-hand side of the screen.

Similar related problem:
http://forums.winamp.com/showthread.php?threadid=66855

2. Latest updates : 7th April 2002

Some (minor?) glitches are reported here (some confirmed, others not):
http://forums.winamp.com/showthread.php?threadid=64077

Confirmed bugs/glitches:
http://forums.winamp.com/showthread.php?threadid=84028 (active window focus switch)
http://forums.winamp.com/showthread.php?threadid=64540 (read titles on display)

Note: Cannot reproduce any with Winamp 5.01

3. PLS Autorun problem in IE5.5+ (audio/x-scpls)
http://forums.winamp.com/showthread.php?threadid=37053
This one's been around for ages!
Fix: Winamp needs to register audio/x-scpls on installation (extension = .pls)
Though this is probably more related to some stupid IE Security Update patch,
or some other player b0rking things up (eg. RealPlayer / MusicMatch)

Fixed for 2.9x and later, problem has not been reported since
______________________________________________________________________

Still not implemented (as listed above)

1. (wishlist) "New playlist" command needs extra "save" confirmation - you can accidentially delete whole playlist without any warning. An "undo" option would also be pretty neat.

2. (wishlist) automatically remove trailing spaces in "open url" box.

3. Not a bug as such, more of a missing feature...
Winamp doesn't support CDDB for proxy connections/port 80 url's, even with CDReader plugin.

RE: Problems with CDDB & proxy / firewalls
http://forums.winamp.com/showthread.php?threadid=57000
http://forums.winamp.com/showthread.php?threadid=31630
http://forums.winamp.com/showthread.php?threadid=32224
http://forums.winamp.com/showthread.php?threadid=36677

4. Couldn't find destination format error, caused by WAV files containing MP3data on a system without MP3 ACM driver installed. This could be worked-around by a simple cross-dll hack or by making in_mp3 steal these files from in_wave - (they do work after renaming to .mp3)
______________________________________________________________________

Misc

1. Full Unicode support in filenames & tags etc

2. Original skin bugs that were never fixed (and probably never will be)
http://www.winamp.com/nsdn/winamp2x/dev/skins/faq.jhtml -> 4)
______________________________________________________________________

winamp.com MIME config

From the WA2 Skins & Plugins Tech Support Forum:
Sticky: downloaded skins won't load

now fixed
______________________________________________________________________

Not Bugs

http://forums.winamp.com/showthread.php?threadid=65975
______________________________________________________________________

Did I miss anything?
______________________________________________________________________
DJ Egg is offline   Reply With Quote
Old 15th April 2003, 13:04   #4
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,773
WA2.90 Beta/Final - Known Bugs

Key:
* = 2.90 Beta bugs, fixed in 2.90 Final
** = 2.90 Final bugs, fixed in 2.91
*** = 2.9x bugs fixed in Winamp 5.0
**** = 2.9x bugs fixed in Winamp 5.01
***** = 2.9x bugs fixed in Winamp 5.03 or later

Previously Known Issues
- The Vorbis tag updating through the media library may be buggy. ***

- Running a full screen visualization plugin when playing video (or vice versa) can be bad (i.e. cause Winamp to quit). This appears to be a Direct Draw issue, we'll figure out why. ***

- some AVI/MPEG/ASF/etc videos may be flipped, due to Direct Show weirdness. We will work to correct this as much as possible. **

- Some MPEG2 video decompressors (latest PowerDVD one apparently) may have issues with playback. ***

- Some DSP/FX plugins may cause sound quality problems when used with NSV. ****


Reported Issues
- Other format metadata may not be read properly (MPC and others)
(3rd-party plugins will need updating to correctly parse library metadata)

- Some titles get truncated if they have a '-' in them. Name parsing errors for hyphenated names.

- Adding Ogg files seems to be OK now, however, selecting files and sending them to a playlist, doesn't take into account the display options. The Import option does, though. ****

- Old skins don't skin AVS without gen.bmp (avs.bmp is no longer used).

- Screensaver activates when playing a fullscreen video. ****

- When moving divider bars repeatedly in the Library window, the screen becomes messy (not redrawn correctly) and becomes unreadable. ***

- The scrollbars in the media library will not work when Winamp is moved to a secondary monitor. They work fine on the primary monitor, but can't even be clicked on the second. Upon further investigation, I discovered that this only happens if the second monitor is to the left of the primary (negative pixel space). If the second is on the right of the primary, everything works fine. **

- support for mms:// streams with no extension is broken *****


Note: Does not include any unfixed bugs from previous update post above (2.81)


WA2.91 - Known Bugs

Note: These are in addition to any unfixed bugs from 2.81 and 2.90 above.

- Winamp crashes when you view file info for any MIDI file.
Workaround fix: Checkmark "Display RMI info dialog by default" in in_midi config
Fixed in Winamp 5.0

- First track in playlist always plays first now if opening Winamp
by double clicking any m3u/pls playlist - with shuffle mode on.
(as a result of latest "shuffle" fix - see whatsnew.txt for details)
Fixed in Winamp 5.0

- Classic Main, EQ and Playlist windows positions not remembered
when coming out of game/vis fullscreen mode in different resolution.
Doesn't happen with 2.81 and earlier, only 2.9x to 5.01
Reported and reproduced here | Discussed & fix being worked on here
Fixed in Winamp 5.04
DJ Egg is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Tech Support Greatest Hits

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump