Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp for Android

Reply
Thread Tools Search this Thread Display Modes
Old 4th March 2013, 09:43   #121
midsole
Junior Member
 
Join Date: Feb 2013
Posts: 6
I've got an S3 i9300 (European UMTS/GSM), and I get stuttering both with stock and custom ROM.

I actually moved from stock ROM to Cyanogenmod 10.1 because I thought it was stock causing the stuttering.

Basic notification definitely helps but does not completely remove stuttering. I tried bumping up the minimum CPU speed from 200 to 400MHZ but that didn't do anything noticeable for me.

Just to help us understand why this stuttering has come about, what changed between 1.4.7 and 1.4.8 (I think that was the update that started all this)?

Process list attached.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2013-03-04-10-31-42.png
Views:	535
Size:	380.9 KB
ID:	50276  
midsole is offline   Reply With Quote
Old 4th March 2013, 16:31   #122
stranded
Junior Member
 
Join Date: Jan 2005
Location: Poland
Posts: 41
Send a message via ICQ to stranded Send a message via AIM to stranded Send a message via Yahoo to stranded
Also I've noticede that when you just stop playing a song, Winamp disappears from the notification area after you move back from the app. That's normal. BUT after few minutes the freaking notification bar is always displayed as an advanced thing (with progress bar below) even though I am using the basic one (just controls for skiping tracks).

Those icons still drive me crazy.
stranded is offline   Reply With Quote
Old 5th March 2013, 08:39   #123
midsole
Junior Member
 
Join Date: Feb 2013
Posts: 6
I've also noticed spontaneous/phantom presses of the pause button, and jumping inside a track, or even jumping to random points in the next track.
midsole is offline   Reply With Quote
Old 5th March 2013, 15:28   #124
stranded
Junior Member
 
Join Date: Jan 2005
Location: Poland
Posts: 41
Send a message via ICQ to stranded Send a message via AIM to stranded Send a message via Yahoo to stranded
If I could just throw money at the screen for this to be fixed asap I would do it now ;D
stranded is offline   Reply With Quote
Old 5th March 2013, 17:23   #125
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 731
Send a message via AIM to Juanus
I will PM you an address to send the money to.
Juanus is offline   Reply With Quote
Old 6th March 2013, 12:52   #126
blipsqueak
Junior Member
 
Join Date: Nov 2012
Posts: 9
Getting tons of stutter this morning. The process list was from my Samsung Galaxy Note 2 running Android 4.1.1 trying all different notification types.

Heres my process list:
Attached Files
File Type: txt log.txt (20.0 KB, 692 views)
blipsqueak is offline   Reply With Quote
Old 17th June 2013, 08:14   #127
robdog2004
Major Dude
 
robdog2004's Avatar
 
Join Date: Jan 2005
Location: South Carolina
Posts: 843
Send a message via AIM to robdog2004 Send a message via Yahoo to robdog2004
they only stutter i have ever seen is at initial playback
starts playing for about 2 seconds then goes back and starts playing back before those 2 seconds
after that i have not had issues with playback other than what egg has confirmed where playback stops in player control mode on any galaxy s type phone
mine will stop playback and when can get playback to start up again it goes back to the about the 5th previous song and plays that again
since going to basic notification bar issue stops
other way is making sure that the app is in the foreground
at first i thought it was the autokill from task manager to free ram
wish i knew that before :P

thanks rob
(c)rob 2013 (picture & SN)

(please note) As users we can't give others help unless we get full details of the problem that you are having
robdog2004 is offline   Reply With Quote
Old 18th July 2013, 00:05   #128
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,742
1.4.11 now released on Google Play

Should hopefully fix 99% cases of:
- stuttering/choppy playback
- random stops/crashing in background and returning to previous song/position, etc.
DJ Egg is offline   Reply With Quote
Old 18th July 2013, 00:33   #129
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 731
Send a message via AIM to Juanus
Hooray to Winamp Devs everywhere.
I wish that I actually had a problem so it could be solved and I could be even more excited than I already am.
I cannot wait to see what 2.0 brings!
Juanus is offline   Reply With Quote
Old 18th July 2013, 04:23   #130
robdog2004
Major Dude
 
robdog2004's Avatar
 
Join Date: Jan 2005
Location: South Carolina
Posts: 843
Send a message via AIM to robdog2004 Send a message via Yahoo to robdog2004
strange though the temporary beta fixed the issue and now released version brings issue back
dont know what changed between the 2
if using advanced notifier song stops after a few seconds of second song then goes back to first song
use basic notifier no issue
sounds like galaxy phones just give winamp a hard time

samsung galaxy stratosphere 2
android 4.2

thanks rob
(c)rob 2013 (picture & SN)

(please note) As users we can't give others help unless we get full details of the problem that you are having
robdog2004 is offline   Reply With Quote
Old 18th July 2013, 10:27   #131
robdog2004
Major Dude
 
robdog2004's Avatar
 
Join Date: Jan 2005
Location: South Carolina
Posts: 843
Send a message via AIM to robdog2004 Send a message via Yahoo to robdog2004
ok seems clean install helped fix the earlier issue

thanks rob
(c)rob 2013 (picture & SN)

(please note) As users we can't give others help unless we get full details of the problem that you are having
robdog2004 is offline   Reply With Quote
Old 18th July 2013, 13:11   #132
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,742
Hmm, interesting.
A clean install shouldn't be required.... but it fixed your stuttering issue when using the Notification Player Controls?
DJ Egg is offline   Reply With Quote
Old 18th July 2013, 13:57   #133
robdog2004
Major Dude
 
robdog2004's Avatar
 
Join Date: Jan 2005
Location: South Carolina
Posts: 843
Send a message via AIM to robdog2004 Send a message via Yahoo to robdog2004
so far yes that is true

edit
nm it returned
on advanced controls
basic notifier still works

thanks rob
(c)rob 2013 (picture & SN)

(please note) As users we can't give others help unless we get full details of the problem that you are having
robdog2004 is offline   Reply With Quote
Old 18th July 2013, 14:32   #134
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,742
Hmm, ok. Damn.... :-(

There's plenty of reports on google play of it being fixed, but still some cases (like yours) that say it isn't.
So maybe it's not 99% cases, but closer to 75%

Other than a slight glitch with the widget (which is a longer-standing issue that we'll hopefully fix for the next release)
we typically can't reproduce it on any of our test devices....
DJ Egg is offline   Reply With Quote
Old 18th July 2013, 14:38   #135
robdog2004
Major Dude
 
robdog2004's Avatar
 
Join Date: Jan 2005
Location: South Carolina
Posts: 843
Send a message via AIM to robdog2004 Send a message via Yahoo to robdog2004
it's like its limited to samsung
next version works ok just wants to be updated to release version now (it has its own issues)
and changes in google wants to force all phones to auto update

thanks rob
(c)rob 2013 (picture & SN)

(please note) As users we can't give others help unless we get full details of the problem that you are having
robdog2004 is offline   Reply With Quote
Old 23rd July 2013, 14:25   #136
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 731
Send a message via AIM to Juanus
I have found some things with the wifi syncing and I hope that this helps.

Windows 7
Winamp version 5.7 Beta Build 3435
Winamp for Android version 1.4.11
Samsung Galaxy S3 on sprint

My company uses the Cisco Systems VPN Client Version 5.0.07.0440
I noticed that that version installs vpngui.exe in the startup folder. From my research, this is not necessary. So I removed it and rebooted and my phone showed up in winamp and the Android WiFi sync works great. However, once I connect to my VPN, my phone disappears from Winamp. I have noticed that even after I disconnect from my VPN and close the program I still cannot get my phone to connect.
However, if I reboot, then my phone will show up and everything seems to work good again.
Juanus is offline   Reply With Quote
Old 23rd July 2013, 23:18   #137
robdog2004
Major Dude
 
robdog2004's Avatar
 
Join Date: Jan 2005
Location: South Carolina
Posts: 843
Send a message via AIM to robdog2004 Send a message via Yahoo to robdog2004
vpn's change your ip address of the computer
which maybe what causes the issue when its running untill next restart
as your android is looking for a 192.168.1.* or 10.0.0.* address
this is my best guess on that
til winamp redesigns to do like other wifi syncing programs (where you physically have to login to the phone) and i know thats a lot of coding
there will be slight issues with some network setups
yes some programs out there allow access from any network availalbe
just matter of time before winamp gets it right
mean time devs are busy trying to get the kinks out of what is already available

thanks rob
(c)rob 2013 (picture & SN)

(please note) As users we can't give others help unless we get full details of the problem that you are having
robdog2004 is offline   Reply With Quote
Old 23rd July 2013, 23:30   #138
DrO
 
Join Date: Sep 2003
Posts: 27,880
rob: it's not to do with that. i cannot go into the specific details but the way that some vpn software interacts with the rest of the networking stack can cause our wifi sync traffic to not make it through. hence why in the case of wifi sync + vpn software it can act weird / not at all.
DrO is offline   Reply With Quote
Old 24th July 2013, 00:33   #139
robdog2004
Major Dude
 
robdog2004's Avatar
 
Join Date: Jan 2005
Location: South Carolina
Posts: 843
Send a message via AIM to robdog2004 Send a message via Yahoo to robdog2004
from my experience with some vpns is that it disabled all local network actions
just depends on manufacturer

one of the reasons i gave up on it

thanks rob
(c)rob 2013 (picture & SN)

(please note) As users we can't give others help unless we get full details of the problem that you are having
robdog2004 is offline   Reply With Quote
Old 24th July 2013, 11:30   #140
serrin
Junior Member
 
Join Date: Jul 2013
Posts: 2
I'm also having issues with stuttering. It's worst with flac files but also happens to a lesser degree with mp3's. With flac files it's stuttering every ~1sec (or less) or so and every ~5sec or so with mp3's. Also when I launch an app (or do anything in winamp like change a setting, add a song to the play queue) it stutters.
I'm running winamp 1.4.11 (pro) on a samsung i9505 with CM10.1 nightlies (13th of July)
And if anybody else is wondering yes I've tried closing all other apps and freeing up the ram, this still happens with ~1000MB of RAM free.
The sad thing is, the free Apollo player with CM doesn't have this issue (even when deprived of RAM).
serrin is offline   Reply With Quote
Old 24th July 2013, 13:48   #141
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,742
Hi serrin

Which 'Notification Bar Type' setting are you using?

If you've changed it, does the problem persist if you change the Notification Controls back to the default "Basic" setting?

Go to the Winamp homescreen, then to "Settings" via the hardware Menu button.
Scroll down and press: "Notification Bar Type".
Change the setting from e.g. "Player Controls (Advanced)" to "Basic".
DJ Egg is offline   Reply With Quote
Old 25th July 2013, 10:10   #142
serrin
Junior Member
 
Join Date: Jul 2013
Posts: 2
Ok, thanks for that. I was using advanced with player options seems to have made things better, but it's still stuttering 1-2 times per flac track and it's stopped on mp3's. However, using another app (surfing the web etc) keeps causing stutters (when playing flac files, which is most of them).
Well as long as it's a known bug, I will wait eagerly for a fix!
serrin is offline   Reply With Quote
Old 22nd August 2013, 17:58   #143
robdog2004
Major Dude
 
robdog2004's Avatar
 
Join Date: Jan 2005
Location: South Carolina
Posts: 843
Send a message via AIM to robdog2004 Send a message via Yahoo to robdog2004
serrin that could be a ram issue
android itself is limited on ram by most phones (most only 1gb)
if stutters seems worse as more programs run
you maybe running low on the onboard ram
only way to confirm it is either in settings under app management
or use a third party app like advanced task killer

thanks rob
(c)rob 2013 (picture & SN)

(please note) As users we can't give others help unless we get full details of the problem that you are having
robdog2004 is offline   Reply With Quote
Old 11th September 2013, 15:28   #144
tnblank77
Junior Member
 
Join Date: Feb 2006
Posts: 10
I have a Samsung Galaxy S4 and have experiencing stuttering while the screen is off with the Notification Bar Type settings "Player Controls" or "Player Controls Advanced". Oddly enough when I use either of these settings stutter appears to cease when I turn off the screen while any Winamp screen is open (even the lock screen).

Restarting the phone also makes the stuttering go away for a while, but then it eventually rears it's ugly head. I do not experience stuttering when I use the default media player.

Some specs:
Phone: Samsung Galaxy S4 (SGH-M919)
Android Version: 4.2.2 (Jelly Bean)
Winamp Version: 1.4.11 (Free, will buy Pro if free works well )

The 6410 songs loaded on my phone are 128kbps MP3 files (converted from FLAC using Winamp Pro on my PC).

Using the following with Winamp (all other settings OFF):
* 4x1 Widget
* Lock-screen Player
* Notification Bar Type: "Player Controls Advanced"

Another issue I am having is that I use a PIN unlock and when playing music and turning the screen on the PIN unlock screen will be displayed for as second or two before the Winamp lock screen appears. This is fairly frustrating as sometimes I start entering my PIN out of habit and then the Winamp lock screen appears, and then I have to re-enter the PIN again. Or if I wanted to pause my song I have to sit there and stare at the screen until the lock screen opens. This only happens when the Winamp lock screen wasn't previously visible.

And please allow us to sync to the SD card via Wi-Fi in the future! This will make me a very happy panda!
tnblank77 is offline   Reply With Quote
Old 4th October 2013, 00:10   #145
robdog2004
Major Dude
 
robdog2004's Avatar
 
Join Date: Jan 2005
Location: South Carolina
Posts: 843
Send a message via AIM to robdog2004 Send a message via Yahoo to robdog2004
so far the 1.4.12 version has fixed a few more issues being brought up
cant give full review for a little while longer

thanks rob
(c)rob 2013 (picture & SN)

(please note) As users we can't give others help unless we get full details of the problem that you are having
robdog2004 is offline   Reply With Quote
Old 4th October 2013, 13:22   #146
tnblank77
Junior Member
 
Join Date: Feb 2006
Posts: 10
Quote:
Originally Posted by robdog2004 View Post
so far the 1.4.12 version has fixed a few more issues being brought up
cant give full review for a little while longer
Agreed. v1.4.12 fixed all stuttering for me on my Galaxy S4.
tnblank77 is offline   Reply With Quote
Old 9th October 2013, 15:41   #147
tnblank77
Junior Member
 
Join Date: Feb 2006
Posts: 10
Quote:
Originally Posted by tnblank77 View Post
Agreed. v1.4.12 fixed all stuttering for me on my Galaxy S4.
But with v1.4.13 I am getting stuttering issues again. Boy it must be fun to support so many different kinds of phones.
tnblank77 is offline   Reply With Quote
Old 9th October 2013, 16:10   #148
DrO
 
Join Date: Sep 2003
Posts: 27,880
"extracting teeth with a hot poker" sort of fun i believe
DrO is offline   Reply With Quote
Old 18th October 2013, 03:54   #149
robdog2004
Major Dude
 
robdog2004's Avatar
 
Join Date: Jan 2005
Location: South Carolina
Posts: 843
Send a message via AIM to robdog2004 Send a message via Yahoo to robdog2004
stuttering issue is a tricky issue and probably very hard to figure where it is
on all 3 phones i have winamp installed on it gives the stutter only at startup of playback
wonder if it has something to do with way files are encoded

thanks rob
(c)rob 2013 (picture & SN)

(please note) As users we can't give others help unless we get full details of the problem that you are having
robdog2004 is offline   Reply With Quote
Old 18th October 2013, 04:04   #150
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,149
Send a message via AIM to MrSinatra
I think its important to always run mp3s thru mp3val and mp3tag to check for bad headers and tags, b/c they can cause audio artifacts or worse. while its likely not the cause here, its important to rule it out.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 18th October 2013, 04:33   #151
robdog2004
Major Dude
 
robdog2004's Avatar
 
Join Date: Jan 2005
Location: South Carolina
Posts: 843
Send a message via AIM to robdog2004 Send a message via Yahoo to robdog2004
yeah i run all files through mp3tag to make sure tags are correct and to put the album art in

thanks rob
(c)rob 2013 (picture & SN)

(please note) As users we can't give others help unless we get full details of the problem that you are having
robdog2004 is offline   Reply With Quote
Old 18th October 2013, 16:49   #152
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,149
Send a message via AIM to MrSinatra
and mp3val?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 19th October 2013, 00:04   #153
robdog2004
Major Dude
 
robdog2004's Avatar
 
Join Date: Jan 2005
Location: South Carolina
Posts: 843
Send a message via AIM to robdog2004 Send a message via Yahoo to robdog2004
being that i encode the files through winamp it should cause validation problems
but yes i run the checksums to make sure they are correct and validate the mp3 files

thanks rob
(c)rob 2013 (picture & SN)

(please note) As users we can't give others help unless we get full details of the problem that you are having
robdog2004 is offline   Reply With Quote
Old 19th October 2013, 01:54   #154
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,149
Send a message via AIM to MrSinatra
mp3val checks lame headers, not checksums.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 26th November 2013, 17:01   #155
Hanschke
Senior Member
 
Join Date: Mar 2003
Location: germany
Posts: 125
will we get an android update too like the desktop today?
Hanschke is offline   Reply With Quote
Old 12th December 2013, 03:36   #156
Sabine Klare
Forum Queen
 
Sabine Klare's Avatar
 
Join Date: Nov 2010
Location: Berlin, Germany
Posts: 2,373
@ Hanschke , I am afraid, that no Winamp 1.4.16 will come out anymore...

I have already asked another very important question in Post #24...
http://forums.winamp.com/showthread.php?t=373779

The "Jelly Bean Issues" have been resolved, but I am really afraid of the upcoming reports about the "Kit Kat Issues"...

Sabine Klare Aka Sternenmaschinebine
Music, Art, Lyrics, Videos
AMBIENT... AMBIENT music forever...
Sabine Klare is offline   Reply With Quote
Old 28th September 2015, 08:56   #157
chapiz
Junior Member
 
chapiz's Avatar
 
Join Date: Sep 2015
Posts: 25
How installed on android?

thx.
chapiz is offline   Reply With Quote
Old 29th September 2015, 23:34   #158
robdog2004
Major Dude
 
robdog2004's Avatar
 
Join Date: Jan 2005
Location: South Carolina
Posts: 843
Send a message via AIM to robdog2004 Send a message via Yahoo to robdog2004
have to install through google play store

thanks rob
(c)rob 2013 (picture & SN)

(please note) As users we can't give others help unless we get full details of the problem that you are having
robdog2004 is offline   Reply With Quote
Old 21st October 2015, 16:21   #159
Marcos
Member
 
Marcos's Avatar
 
Join Date: May 2001
Posts: 70
Quote:
Originally Posted by robdog2004 View Post
have to install through google play store
cannot find - please provide link, thx.
Marcos is offline   Reply With Quote
Old 21st October 2015, 19:05   #160
robdog2004
Major Dude
 
robdog2004's Avatar
 
Join Date: Jan 2005
Location: South Carolina
Posts: 843
Send a message via AIM to robdog2004 Send a message via Yahoo to robdog2004
https://play.google.com/store/apps/d...ullsoft.winamp
based of my app history (can not guarantee it will work for all)
the only warning is that the buy features no longer work and software was as of oct 2013
hopefully will get an update from developers and that the project isnt completely dead

thanks rob
(c)rob 2013 (picture & SN)

(please note) As users we can't give others help unless we get full details of the problem that you are having
robdog2004 is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp for Android

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump