Old 23rd August 2008, 03:54   #1
3thereal
Junior Member
 
Join Date: Aug 2008
Posts: 9
Memory leak issue with winamp / simplify media?

Hello, I recently stumbled upon this amazing application called Simplify Media. It allows users to share either their itunes or winamp library computer to computer (or iphone) over an internet connection, and I'm guessing it acts as a plugin for both applications because it creates a "shared" section underneath the dashboard etc where you can play your computer's shared music. I have not had this same problem on my work computer, only my home computer, and I've spent several days going through this with Simplify Media already and they say it is a problem with winamp, not on their end (even though winamp runs fine when I uninstall the program) so I'm hoping someone can help me.

This is what happens when simplify media is installed and winamp is running: winamp begins to increase in memory usage at a constant rate - usually reaching about 2GB of memory usage until it crashes with this error in the event log "Faulting application winamp.exe, version 5.5.4.2165, faulting module unknown, version 0.0.0.0, fault address 0x0000000c." I don't even have to be playing music or really do anything with winamp, it just starts hogging more and more memory until it explodes. If I can provide any other information let me know - I also have a dr watson log of the crashes as well.
3thereal is offline   Reply With Quote
Old 23rd August 2008, 04:33   #2
Rocker
Hiding in plain sight (mod)
 
Join Date: Jun 2000
Location: Melbourne, Australia
Posts: 9,907
winamp by itself doesn't do that so i'm guessing its the third party plugin causing that.

we can't provide support for third party plugins here. as we don't know the product.

I suggest you contact the developer of simplify media.
Rocker is offline   Reply With Quote
Old 23rd August 2008, 05:03   #3
3thereal
Junior Member
 
Join Date: Aug 2008
Posts: 9
Thanks for your response, but like I wrote in that post they already claimed there was nothing they could do after reviewing my error logs - that it was something I'd have to take up with winamp. Trust me, I already tried going through all the routes I could before making a post, including doing the full uninstall/reinstall and visiting the FAQs. I don't want to waste anyone's time.
3thereal is offline   Reply With Quote
Old 24th August 2008, 16:02   #4
3thereal
Junior Member
 
Join Date: Aug 2008
Posts: 9
Anyone have any other ideas of where I can go with this?
3thereal is offline   Reply With Quote
Old 24th August 2008, 17:15   #5
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
If you have a large music collection then my guess is it is some sort of indexing problem, but without knowing anything about what the plugin is ....

UJ
ujay is offline   Reply With Quote
Old 24th August 2008, 18:10   #6
Greg_E
Major Dude
 
Join Date: Nov 2006
Location: USA
Posts: 1,687
Update to the non-beta release of Winamp 5.541?

Your mileage may vary!
Greg_E is offline   Reply With Quote
Old 24th August 2008, 22:03   #7
3thereal
Junior Member
 
Join Date: Aug 2008
Posts: 9
Nope, sorry, I'm using the latest non-beta download off the winamp site. I could try an older version maybe, and see if that helps at all. . .
3thereal is offline   Reply With Quote
Old 3rd September 2008, 08:31   #8
Trickstar
Junior Member
 
Join Date: Oct 2003
Posts: 49
i have exactly the same problem, people at simplifymedia are looking into it, but i don't think it will help. this problem must be related to winamps media library, i guess. i'm using 5.541 in windows XP Professional.
Trickstar is offline   Reply With Quote
Old 3rd September 2008, 18:49   #9
3thereal
Junior Member
 
Join Date: Aug 2008
Posts: 9
I'm glad I'm not alone on this one. I'm being forced to use itunes if I want to use simplify media (bleh)
3thereal is offline   Reply With Quote
Old 3rd September 2008, 19:02   #10
Trickstar
Junior Member
 
Join Date: Oct 2003
Posts: 49
i'm in contact with some bill from simplifymedia on this one, i hope we can narrow it down a bit.
Trickstar is offline   Reply With Quote
Old 22nd September 2008, 19:20   #11
thebasa
Junior Member
 
Join Date: Sep 2008
Posts: 1
is this still in the process of being rememdied?
thebasa is offline   Reply With Quote
Old 22nd September 2008, 19:23   #12
3thereal
Junior Member
 
Join Date: Aug 2008
Posts: 9
Unfortunately I personally have not heard from either side, and the latest updates to winamp and simplify media haven't changed anything.
3thereal is offline   Reply With Quote
Old 22nd September 2008, 19:44   #13
Trickstar
Junior Member
 
Join Date: Oct 2003
Posts: 49
well, the guys at SM promised me to look into it, but i never heard from them again. also informed them, that this is being discussed in this forum.
Trickstar is offline   Reply With Quote
Old 2nd October 2008, 16:42   #14
Trickstar
Junior Member
 
Join Date: Oct 2003
Posts: 49
we found, that Simplify Media will run fine, when uninstalling just the Simplify Media Library 1.0 plugin, but not the other. Apparently there's something wrong with this plugin, because the memory grows exactly that many KB, as the number of files in your media library. Having a large library (mine is almost 7000) i always got surges of 7000KB RAM every minute.
Trickstar is offline   Reply With Quote
Old 2nd October 2008, 16:53   #15
3thereal
Junior Member
 
Join Date: Aug 2008
Posts: 9
Well mine i s alittle more extremem than that - I have a library of over 28k songs and winamp will get to the point where it is taking of 2 GB of memory resources before it crashes. Simplify just sent me a beta install of their app that is supposed to address a lot of memory issues with winamp, so I will give it a shot in the next few days and if it works then I will update this post.
3thereal is offline   Reply With Quote
Old 2nd October 2008, 17:12   #16
Trickstar
Junior Member
 
Join Date: Oct 2003
Posts: 49
well, with 28k songs, it will surge 28MB RAM every minute, so summing up a whole hour, it will already have aggregated 1,680GB RAM. I've been to swapping country with SM like you
Trickstar is offline   Reply With Quote
Old 2nd October 2008, 18:03   #17
3thereal
Junior Member
 
Join Date: Aug 2008
Posts: 9
Ahhh haha ok I see, yeah that explains it.
3thereal is offline   Reply With Quote
Old 8th October 2008, 04:57   #18
3thereal
Junior Member
 
Join Date: Aug 2008
Posts: 9
Hey everyone, I just got an e-mail from simplify media with a new version that seems to have fixed the problem! Winamp has run for several hours and not gone above 100mb of usage, download it here http://tpnupdate.simplifymedia.net/u...MediaSetup.exe
3thereal is offline   Reply With Quote
Old 8th October 2008, 08:14   #19
Trickstar
Junior Member
 
Join Date: Oct 2003
Posts: 49
yeah, i got it too, seems to run just fine
Trickstar is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump