Old 8th February 2014, 10:04   #1
mukke
Junior Member
 
Join Date: Feb 2014
Posts: 8
links to radio stations don't work anymore

Hello. I'm using the latest Winamp Version 566 build 3516 and found out that under

Media Library > Online Services > SHOUTcast Radio

suddenly all links to radio stations are not working anymore!

No matter if I try to click on a link under the view "Most Popular", "Featured" or "Recently Played". All orange links can't be clicked. Nothing happens. The same phenomena when I make a search for a station, artist or genre. Links are just not clickable. Even the links (at the bottom of the page)

Winamp Terms, FAQ, SHOUTcast Radio Terms, Disclamer, Contact Us

do not work anymore. What is suddenly wrong with my Winamp? Please help.
mukke is offline   Reply With Quote
Old 8th February 2014, 10:07   #2
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,659
Look at the following thread.

http://forums.winamp.com/showthread.php?t=375081

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 8th February 2014, 10:59   #3
mukke
Junior Member
 
Join Date: Feb 2014
Posts: 8
Thanks for your quick response. There's a whole lot of information in that thread, but it believe that it really doesn't apply to me.

I do not get any error messages opening Media Library > Online Services > SHOUTcast Radio.

The wierd thing now is, when i add manually SHOUTcast Radio to the Online Services with the mentioned url http://www.shoutcast.com/scradioinwinamp/ (which corresponds exactly to the url in my original SHOUTcast Radio directory) I get in fact a copy of the original directory, right, and the same view. And here now the links are surprisingly working !?!

What makes sense do me is that are apparently many ongoing changes due to sell of winamp/shoutcast.

But why my links only work when i dublicate this directory or in other words manually add the same url doesn't make any sense to me. I just don't get it.
Attached Thumbnails
Click image for larger version

Name:	01-SHOUTcast Radio_orginal.jpg
Views:	376
Size:	77.7 KB
ID:	50998   Click image for larger version

Name:	02-SHOUTcast Radio_manual.jpg
Views:	240
Size:	74.1 KB
ID:	50999  
mukke is offline   Reply With Quote
Old 8th February 2014, 12:12   #4
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,659
Quote:
Originally Posted by mukke View Post
But why my links only work when i dublicate this directory or in other words manually add the same url doesn't make any sense to me. I just don't get it.
In your case, all I can suggest is that somehow the associated configuration file associated with the original entry was corrupted. Adding a new entry (with the same url) allowed the configuration file associated with it to work.

Are you using Winamp within the US?

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 9th February 2014, 14:21   #5
mukke
Junior Member
 
Join Date: Feb 2014
Posts: 8
Well, I'm not an IT-specialist, just a normal user. But I strongly believe that this certain "corruption" wasn't my fault. Very strange all this!

I'm using Winamp at the moment within Bali, Indonesia and normaly within Germany. Before I travelled thru other south east asian countries like Thailand, Cambodia, Laos.. This described behaviour happened here in Bali for the first time.

But; ... why could this question be relevant?
mukke is offline   Reply With Quote
Old 9th February 2014, 14:49   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
it's all stemming from the sale of Winamp and SHOUTcast and things are going to get more broken in the coming weeks (as things are still being transitioned over from AOL to Radionomy) before it'll all be back to working as expected.

and the reason for asking if you were on a US based IP address is that the view was setup to show certain ads to users deemed to be in the US and that is causing some of the access issues (and could be possibly responsible for the issue you are / were having). again that is a side-effect of the sale as things which were providing valid responses aren't and that's causing some access issues on the page and will likely need things to be re-worked (when other things with SHOUTcast have been transitioned) before it'll be working as expected again.
DrO is offline   Reply With Quote
Old 9th February 2014, 15:29   #7
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,659
Hi mukke,

I'm not saying you did anything wrong. Since a new entry with the same site address works, I'm guessing that something happened to the configuration data for the original entry. In normal use, random read/write errors can and do occur with the way computers store data. Usually these errors are handled by the build-in error detection and correction technology and sometimes they are not. This is one of the reasons why you should make regular backups of stuff you can't easily replace.

As for why I asked your location, re-read the thread I linked to. Users in the US had AOL servers supplying ads associated with the SHOUTcast radio search page (and SHOUTcast site). Since AOL is no longer providing these servers, the page does not work within Winamp for users in the US. These ads were not being pushed to users outside the US and the page continues to work within Winamp for them.

I'm glad it's working for you and expect Winamp's new owners will get things sorted out for us in the US soon.

Edit:
I kept being interrupted while writing my response and DrO got his reply in first.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 9th February 2014, 23:21   #8
Bytemann
Junior Member
 
Join Date: Jul 2010
Posts: 33
Why not leave the original Winamp/Shoutcast system in place until the new system is ready?
Otherwise we will be waiting for months for the new system

Bytemann is offline   Reply With Quote
Old 9th February 2014, 23:23   #9
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
Quote:
Originally Posted by Bytemann View Post
Why not leave the original Winamp/Shoutcast system in place until the new system is ready?
Otherwise we will be waiting for months for the new system

That's something you would need to ask AOL.
Alas, there's nothing much else that we (Radionomy/Nullsoft/Winamp/SHOUTcast) can really do about it :-(

Hopefully, it won't be too long before we have services etc back up & running smoothly again...

*gulp*


[EDIT]

Plus what Koopa says below is pretty much spot on.
DJ Egg is offline   Reply With Quote
Old 9th February 2014, 23:52   #10
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,341
Quote:
Originally Posted by Bytemann View Post
Why not leave the original Winamp/Shoutcast system in place until the new system is ready?
Otherwise we will be waiting for months for the new system

Honestly, if I would sell a product, why should I still provide online contents, which produces a lot of cost?

It's up to the new owner to make things working again, so here I fail to see that AOL did anything wrong.
Koopa is offline   Reply With Quote
Old 10th February 2014, 12:17   #11
Bytemann
Junior Member
 
Join Date: Jul 2010
Posts: 33
Thanks for posting that information!
Bytemann is offline   Reply With Quote
Old 10th February 2014, 12:24   #12
DrO
 
Join Date: Sep 2003
Posts: 27,873
koopa's post sums it up very well and when you look at other products that get sold / bought, you see things being either shutdown or limited when that happens as things are transitioned / re-appraised as to what should / should not be maintained.

and when it comes to the 'online' based services, if Winamp hadn't been sold then they'd have gone dead (as some aspects already have) and would not come back (hence all of the work i did for the 5.66x releases to allow for local customisation of them if needed).

however as it has been sold, there's still going to be things going down (and potentially not coming back) whilst people have to re-implement things or decide that it just needs to be killed and would then require client updates (which in itself is going to be an issue due to the reasonable assumption that things are going to need to be re-licensed or dropped / re-implemented).

so it's not just a simple 'transfer of ownership' from AOL to Radionomy (and those believing that would be the case are very naive) and i'd expect to see a lot more things breaking or needing to be changed in the coming months when it comes to anything which was online based or needed to be licensed.

but in the main, it's not going to prevent playing of files locally or most other aspects of Winamp as-was.
DrO is offline   Reply With Quote
Old 11th February 2014, 11:46   #13
mukke
Junior Member
 
Join Date: Feb 2014
Posts: 8
Thanks to all for your explanations!

I understood now that's all related to the sell of Winamp & Shoutcast and will try to be just patient and observe how things develop in the future.

By the way: The instant email notifications for the last new answers didn't work. I received nothing.
mukke is offline   Reply With Quote
Old 11th February 2014, 22:56   #14
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,659
Quote:
Originally Posted by mukke View Post
By the way: The instant email notifications for the last new answers didn't work. I received nothing.
That has long been a problem with this site. Sometimes it works and sometimes not.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump