Old 13th November 2010, 03:04   #1
hobbes487
Junior Member
 
Join Date: Nov 2010
Posts: 8
APP_ASSOCIATE not changing the icon of the file types

I am trying to use APP_ASSOCIATE and the problem I am having is that it doesn't give the file types the icon I want. I have tried the following scripts and neither of them give the file types the right icon.

code:
!insertmacro APP_ASSOCIATE "osapp" "OSA.osapp" "Plugin Package" "$INSTDIR\PluginInstaller.exe" "Open" "$INSTDIR\PluginInstaller.exe $\"%1$\""

code:
!insertmacro APP_ASSOCIATE "osapp" "OSA.osapp" "Plugin Package" "$INSTDIR\PluginIcon.ico" "Open" "$INSTDIR\PluginInstaller.exe $\"%1$\""

code:
!insertmacro APP_ASSOCIATE "osapp" "OSA.osapp" "Plugin Package" "$INSTDIR\PluginInstaller.exe,0" "Open" "$INSTDIR\PluginInstaller.exe $\"%1$\""

Any ideas?
hobbes487 is offline   Reply With Quote
Old 14th November 2010, 16:45   #2
{_trueparuex^}
Senior Member
 
{_trueparuex^}'s Avatar
 
Join Date: Dec 2005
Location: Glow
Posts: 285
I quess you need to refreshes the shell associations.

With FileAssoc.nsh call this macro after creating the associations:
code:
!insertmacro UPDATEFILEASSOC


PaR

The guy with the ridiculous username. Thou shall call him PaR instead.
Visit My Website

Last edited by {_trueparuex^}; 14th November 2010 at 18:38.
{_trueparuex^} is offline   Reply With Quote
Old 14th November 2010, 17:39   #3
hobbes487
Junior Member
 
Join Date: Nov 2010
Posts: 8
That worked! Thanks
hobbes487 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Developer Center > NSIS Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump