Old 3rd December 2010, 01:16   #1
Stupifier
Major Dude
 
Join Date: Nov 2005
Posts: 596
New Ratings ----> ID3 Tag feature - QUESTION

This feature is exactly what I was looking for........

How do I get the songs I have ALREADY rated to write their ratings to their ID3 Tags?

UPDATE:
I understand that when I play an ALREADY rated song.....after about a minute of playback, winamp writes that rating to the ID3 tag. Fine......but I want ALL my currently rated songs to put their ratings into the ID3 tag. How do I do this for my entire library.
Stupifier is offline   Reply With Quote
Old 3rd December 2010, 07:47   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,822
Media Library -> Local Media or Audio view

Search:

?rating=5

Select all results
Right-click first item -> Rate Items -> 5 stars

Repeat for 4,3,2,1


Obviously make sure "Save ratings to file" is checkmarked in Prefs -> Media Library -> Library Options tab first.
DJ Egg is offline   Reply With Quote
Old 3rd December 2010, 10:41   #3
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by Stupifier View Post
I understand that when I play an ALREADY rated song.....after about a minute of playback, winamp writes that rating to the ID3 tag. Fine......but I want ALL my currently rated songs to put their ratings into the ID3 tag. How do I do this for my entire library.
that isnt' standard behaviour as far as i'm aware (or can see in the code). sure it's not from an extra plug-in you've got installed?

-daz
DrO is offline   Reply With Quote
Old 3rd December 2010, 16:22   #4
Stupifier
Major Dude
 
Join Date: Nov 2005
Posts: 596
I'll spit a plug-in list when I get more time. Gotta go to lab right now. I get to use Laser Nano Tweezers to trap particles today, YAY!!!

Anyway, I'll get back to you DrO
Stupifier is offline   Reply With Quote
Old 3rd December 2010, 18:06   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
well are you definitely sure that the rating is being written after a specific delay or did you mean maybe the playcount into the history? is just strange to hear someone say it's writing things out to the file when i'm not aware of anything in the code to do that

"Laser Nano Tweezers" - now that sounds more fun than the stuff i'm having to do at the moment.

-daz
DrO is offline   Reply With Quote
Old 4th December 2010, 00:04   #6
Stupifier
Major Dude
 
Join Date: Nov 2005
Posts: 596
Quote:
Originally Posted by DrO View Post
well are you definitely sure that the rating is being written after a specific delay or did you mean maybe the playcount into the history? is just strange to hear someone say it's writing things out to the file when i'm not aware of anything in the code to do that

-daz
Here is a test I did to confirm things:

1. Find a song that is ALREADY rated in my library...but does NOT have that rating applied to the ID3 tag.
2. Play that file.
3. During playback, again check the ID3 tag. Rating still not written to ID3 Tag.
4. After exactly 20% (I checked) of the song has played, the song stutters for like a half second....My thought...Winamp wrote something to the file.
5. Check the ID3 tag of the file. The Rating is now written to the ID3 tag.

My Plug-in List is attached below.

Quote:
Originally Posted by DrO View Post
"Laser Nano Tweezers" - now that sounds more fun than the stuff i'm having to do at the moment.
-daz
It was pretty cool. We got to trap these 2.1um diameter microsphere beads in space using a high power laser and some focusing optics. It felt like I was using a Tractor Beam from Star Trek! The microbeads would just follow wherever we focused the laser. We were literally pushing these beads around a glass slide using just light....which has no mass....kinda interesting.
Attached Files
File Type: txt my_plugin_list.txt (13.7 KB, 241 views)
Stupifier is offline   Reply With Quote
Old 20th December 2010, 07:06   #7
beatsandmelody
Junior Member
 
Join Date: Jan 2010
Posts: 44
Quote:
Originally Posted by DJ Egg View Post
Obviously make sure "Save ratings to file" is checkmarked in Prefs -> Media Library -> Library Options tab first.
Nevermind, found it. Wanted to delete this post, but don't see the option.
beatsandmelody is offline   Reply With Quote
Old 20th December 2010, 08:04   #8
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by Stupifier View Post
Here is a test I did to confirm things:
1. Find a song that is ALREADY rated in my library...but does NOT have that rating applied to the ID3 tag.
2. Play that file.
3. During playback, again check the ID3 tag. Rating still not written to ID3 Tag.
4. After exactly 20% (I checked) of the song has played, the song stutters for like a half second....My thought...Winamp wrote something to the file.
5. Check the ID3 tag of the file. The Rating is now written to the ID3 tag.
from looking at the list, i'm not too sure what would be causing it as i really cannot see anything in the main Winamp code to do it. maybe it's an ActiveWinamp script you've got running as the 20% thing doesn't match with anything else i can think off. though there's a few shaneh plug-ins in there i've not used so maybe they are doing it (i.e. the playcount one) but that's just from them being unknown to me.

-daz
DrO is offline   Reply With Quote
Old 8th January 2011, 07:39   #9
Stupifier
Major Dude
 
Join Date: Nov 2005
Posts: 596
Thanks, I'll look into it.
Stupifier is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump