Old 18th December 2007, 13:48   #161
urlwolf
Junior Member
 
Join Date: Nov 2007
Posts: 39
yet another problem. Using autotagging, after I press "apply" I get A runtime erro 6025 (visual C++).
Often.
urlwolf is offline  
Old 18th December 2007, 14:01   #162
heavydawson
Junior Member
 
Join Date: Dec 2005
Location: Ireland
Posts: 25
@urlwolf
OK, I did a clean install, following the clean install instructions from the forums here. I didn't install the emusic option, nor the winamp remote option. Also disabled winamp agent, and the reporting of anonymous usage statistics.
Added my 15 tracks to the media library.
Real memory usage is down to 50MB from 60MB. Virtual Memory usage is down only 4MB to 189MB from 193MB.
I'll repeat with my 20k song collection this evening.
heavydawson is offline  
Old 18th December 2007, 16:50   #163
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Quote:
Originally posted by urlwolf
Other plugins used:
TAK
out_sqr175
Active winamp
Ozone plugin

Will proceed to uninstall them...
Yup, you'll need to remove ALL 3rd-party/extra plugins (including Predixis AND any from the Essential Pack) for any report to be valid.

Virtual Memory usage reported by Windows Task Manager isn't necessarily accurate or a true representation anyway:
http://tweakhound.com/xp/virtualmemory.htm

I'm currently running 5.51 beta (a slightly newer build than the public beta).

Big Bento skin, playing an mp3, spectrum vis & beat detector vis on, no vis plugin running, 30,000+ files in mldb, 24bit playback enabled, using DirectSound Output...

With Winamp minimized to taskbar, Task Mgr says:
CPU: 00 to 05
Mem Usage: 18,164K
VM Size: 126,756K

With Winamp restored/maximized
CPU: 00 to 06
Mem Usage: 25,716K
VM Size: 126,928K

After switching to the Winamp Classic skin:

With Winamp minimized to taskbar, Task Mgr says:
CPU: 00 to 05
Mem Usage: 10,284K
VM Size: 105,116K

With Winamp restored/maximized
CPU: 00 to 06
Mem Usage: 15,432K
VM Size: 105,116K


As I said, I can't reproduce your problem.
DJ Egg is offline  
Old 18th December 2007, 17:49   #164
heavydawson
Junior Member
 
Join Date: Dec 2005
Location: Ireland
Posts: 25
Quote:
Originally posted by DJ Egg
Yup, you'll need to remove ALL 3rd-party/extra plugins (including Predixis AND any from the Essential Pack) for any report to be valid.

Virtual Memory usage reported by Windows Task Manager isn't necessarily accurate or a true representation anyway:
http://tweakhound.com/xp/virtualmemory.htm

I'm currently running 5.51 beta (a slightly newer build than the public beta).

Big Bento skin, playing an mp3, spectrum vis & beat detector vis on, no vis plugin running, 30,000+ files in mldb, 24bit playback enabled, using DirectSound Output...

With Winamp minimized to taskbar, Task Mgr says:
CPU: 00 to 05
Mem Usage: 18,164K
VM Size: 126,756K

With Winamp restored/maximized
CPU: 00 to 06
Mem Usage: 25,716K
VM Size: 126,928K

After switching to the Winamp Classic skin:

With Winamp minimized to taskbar, Task Mgr says:
CPU: 00 to 05
Mem Usage: 10,284K
VM Size: 105,116K

With Winamp restored/maximized
CPU: 00 to 06
Mem Usage: 15,432K
VM Size: 105,116K


As I said, I can't reproduce your problem.
Looking at DJ Eggs figures, I thought something was off with my own setup, especially considering I had far fewer songs in the library. I re-opened Process Explorer, and the following are my figures:
Physical Memory - Working Set : 17,268k
Virtual Memory - Private Bytes : 70,476k
Virtual Memory - Virtual Size : 249,132k
This was with Winamp in windowshade mode.

Therefore I was incorrect to say my real memory usage was ~60MB as I stated earlier. I can see now its around the 17MB mark.
However, I'm not sure which of the virtual memory figures is representative of the space Winamp has allocated on my drive to use as memory.
I checked over here:
http://blogs.msdn.com/frankarr/archi...24/676412.aspx
and see that private bytes is the actual space used, whereas virtual size is the virtual address space being used by the process and is not necessarily an indicator of virtual space usage.
@wolfurl,
1. download and install process explorer from microsoft
2. open it, and right-click the winamp.exe process
3. click "properties"
4. click the "performance" tab
5. Under the virtual memory section, check "private bytes"
6. Under the physical memory section, check "working set"
7. Post the two figures back here, and lets see if you're memory consumption is really all that bad?

Last edited by heavydawson; 18th December 2007 at 18:09.
heavydawson is offline  
Old 18th December 2007, 18:08   #165
XenonMB
Junior Member
 
Join Date: Dec 2001
Posts: 2
Send a message via ICQ to XenonMB
Auto-Tag Error

This error with the auto-tag is easily reproduceable if you happen to have a file, that seems to be not in the database. (or the information just isn't shown)

1. send some files to autotag. (for example i sent the last two tracks of an album to autotag.)

2. click on the file that doesn't seem to be in the DB, or scroll down using the cursor keys.

now i don't know if the files really aren't in the database or if it's the error that causes the info to not show up, but i can reproduce it as often as i want using the same files.

Attached is a screenshot of what it looks like. notice that no new info for the file is shown, the new info shows ok for all files with which it works.

Obviously I'm using WIndows Vista, not so obviously 32bit Ultimate Edition.

Hope that helps.

Edit: I forgot to say: if need be, i can provide an mp3 file to test this out, if this is allowed.
Attached Images
File Type: jpg wa551_autotag_error.jpg (54.1 KB, 487 views)
XenonMB is offline  
Old 18th December 2007, 19:01   #166
snoopdarr
Junior Member
 
Join Date: Dec 2007
Posts: 4
There's no way to make winamp "forget" the ipod you have to make it prompt for "What kind of ipod is connected?".

But does this make a difference? In my case, Third Gen ipod nano (with coverflow), I chose "ipod nano" as the type of ipod. Cover art is in the file's tags, in the album's folder, displays in winamp, and cover art is not transferred to the device. This did not work in Winamp 5.5 either.
snoopdarr is offline  
Old 18th December 2007, 19:46   #167
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
@XenonMB

Hi :-)

I think that issue might already be known & fixed.

From the whatsnew.txt in a newer internal 5.51 beta build:

* Fixed: [ml_autotag] Crash when track isn't part of a disc, eg. internet-only releases
DJ Egg is offline  
Old 18th December 2007, 21:29   #168
Kn0tte
Major Dude
 
Join Date: Feb 2007
Posts: 585
And one question from me again (after a few days):
Any interesting news/information for me (about my bugs)? Heh
Kn0tte is offline  
Old 18th December 2007, 21:35   #169
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
No. Due to your persistent bugging, we've decided to punish you by leaving those two bugs untouched....


j/k

To be perfectly honest with you, I haven't got a clue.
I still can't reproduce the Winamp Modern ML issue, and I never double click playlist files in Explorer to open Winamp.
But maybe Benski's already fixed one or both of them, maybe he hasn't...
DJ Egg is offline  
Old 18th December 2007, 22:46   #170
Kn0tte
Major Dude
 
Join Date: Feb 2007
Posts: 585
Quote:
Originally posted by DJ Egg
No. Due to your persistent bugging, we've decided to punish you by leaving those two bugs untouched....


j/k

To be perfectly honest with you, I haven't got a clue.
I still can't reproduce the Winamp Modern ML issue, and I never double click playlist files in Explorer to open Winamp.
But maybe Benski's already fixed one or both of them, maybe he hasn't...
Ok, that was all I wanted to hear.. I know I have been talking about it for a long time, but that is only because the bugs are annoying.. Maybe you dont do the "double click"-thing (on desktop), but I do. I am an Winamp user. I want Winamp as bug-free as we can get it.
Yes, lets hope Benski has fixed them. The best thing would be that he could answer the questions himself.. But, I will just have to wait and see..
And yes, I know that you have other things to do since it is christmas soon Heh..
Im sorry, but maybe you can talk with Benski (just a question) ?

Atleast, can you put those two bugs under "Known issues" so you can atleast remember them?

Keep up the good work.
Kn0tte is offline  
Old 18th December 2007, 23:03   #171
urlwolf
Junior Member
 
Join Date: Nov 2007
Posts: 39
fresh restart.

5. Under the virtual memory section, check "private bytes"
6. Under the physical memory section, check "working set"

private bytes:271348
working set: 260248

It's fat as hell...
I'm not sure I want to remove all plugins... predixis takes half a month to scan the library And ozone is a DSP effect, I don't think it causes much memory usage. All others are removed.

UPDATE: Ok, I removed every plugin... even predixis. Now private bytes is only 168mb, in agreement with DJ egg's numbers (I'm 36000 songs so a bit more memory).

So it's a trade-up... predixis and fat, or a leaner winamp.
Is the playlist generator plugin as good as predixis? It sure is slower...

Thanks
urlwolf is offline  
Old 18th December 2007, 23:15   #172
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 740
Send a message via AIM to Juanus
Quote:
Originally posted by urlwolf
.predixis takes half a month to scan the library

Is the playlist generator plugin as good as predixis? It sure is slower...

Thanks
\

Obviously you have not tried the playlist generator, buecause it is NOT slower. In fact, its a million times faster.

go into the preferences and under Media Library highlight the playlist generator plugin and choose configure. Not only can you change some settings there, but you can do a scan. it will not take half a month I guarentee you.
Juanus is offline  
Old 18th December 2007, 23:41   #173
urlwolf
Junior Member
 
Join Date: Nov 2007
Posts: 39
Also, my searches (core 2 duo 2 Ghz) take seconds. I'm not sure this is right, since other programs (MusicIP, Jriver) do it in miliseconds.

Is this correct (i.e., searches are not very fast in winamp)?

Thanks
urlwolf is offline  
Old 18th December 2007, 23:50   #174
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
Quote:
Originally posted by Kn0tte
Ok, that was all I wanted to hear.. I know I have been talking about it for a long time, but that is only because the bugs are annoying.. Maybe you dont do the "double click"-thing (on desktop), but I do. I am an Winamp user. I want Winamp as bug-free as we can get it.
Yes, lets hope Benski has fixed them. The best thing would be that he could answer the questions himself.. But, I will just have to wait and see..
And yes, I know that you have other things to do since it is christmas soon Heh..
Im sorry, but maybe you can talk with Benski (just a question) ?

Atleast, can you put those two bugs under "Known issues" so you can atleast remember them?

Keep up the good work.
I think the playlist issue is fixed, although I'm not 100% sure.
Benski is offline  
Old 18th December 2007, 23:51   #175
urlwolf
Junior Member
 
Join Date: Nov 2007
Posts: 39
Quote:
Originally posted by Juanus
\

Obviously you have not tried the playlist generator, buecause it is NOT slower. In fact, its a million times faster.

go into the preferences and under Media Library highlight the playlist generator plugin and choose configure. Not only can you change some settings there, but you can do a scan. it will not take half a month I guarentee you.
It's faster creating the fingerprinting yes, but when you ask for similar songs it takes a while, whereas musicIP is immediate.
urlwolf is offline  
Old 18th December 2007, 23:56   #176
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 740
Send a message via AIM to Juanus
Quote:
Originally posted by urlwolf
It's faster creating the fingerprinting yes, but when you ask for similar songs it takes a while, whereas musicIP is immediate.
what do you consider "a while"?
For me it is immediate. Granted, I only have some 6000 songs, but still...

maybe someone else could weigh in?
Juanus is offline  
Old 20th December 2007, 17:32   #177
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Thread ends here :-)

Winamp 5.51 Released
DJ Egg is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump