Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Discussion

Reply
Thread Tools Search this Thread Display Modes
Old 22nd April 2017, 12:11   #801
MarkRH
Senior Member
 
Join Date: Nov 2002
Location: Oklahoma City, OK
Posts: 405
Quote:
Originally Posted by Koopa View Post
What is wrong with the miscellanous statistic table columns on your site? I don't see that on my outputs.
Ooops, I missed some of the CSS changes. Looks better now.
MarkRH is offline   Reply With Quote
Old 22nd April 2017, 13:05   #802
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,338
Could you tell me what the the:

[ml_pmp]
extractpath=

value in your winamp.ini file is? Or does it not exists?

same for:

[transcoder]
fileroot=

in your ml_transcode.ini?

The value is empty in your report, seems to be a bug in info tool
Koopa is offline   Reply With Quote
Old 22nd April 2017, 21:23   #803
MarkRH
Senior Member
 
Join Date: Nov 2002
Location: Oklahoma City, OK
Posts: 405
Quote:
[ml_pmp]
extractpath=
That section does not exist in winamp.ini.
Quote:
[transcoder]
fileroot=
I don't have a ml_transcode.ini file in either the Winamp program directory or in %appdata% area.
MarkRH is offline   Reply With Quote
Old 22nd April 2017, 22:57   #804
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,606
I also do not have a "ml_pmp" section in my Winamp.ini file, but I do have the "ml_pmp.dll" plug-in installed. I do have a "pmp_usb" section in my Winamp.ini file because the "pmp_usb.dll" is the only portables plug-in installed in my configuration and I have used it to copy song files to 1 of my portable devices.

I do have a "ml_transcode.ini" file. It was created when I used Winamp to transcode 1 digital music format to another. It is in my %appdata% area in the Winamp\Plugins\ml folder.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 23rd April 2017, 10:49   #805
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,338
Not having this section means that a.) using the cd ripping settings is enabled or b.) it is using the default path.

MarkRH:

Could you show me a report created by this build:

http://koopa.meggamusic.co.uk/downlo..._Info_Tool.zip

I guess i fixed the issues with the portable/transcoder paths.

You can also set ReportHTMLHeader=0 to disable html body.
Koopa is offline   Reply With Quote
Old 23rd April 2017, 11:16   #806
MarkRH
Senior Member
 
Join Date: Nov 2002
Location: Oklahoma City, OK
Posts: 405
Tried that one out. Report is here: http://www.markheadrick.com/winamp-info.php

Putting ReportHTMLHeader=0 in did not change the behavior, however.
MarkRH is offline   Reply With Quote
Old 23rd April 2017, 11:31   #807
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,338
Have you put it under [options]?
Koopa is offline   Reply With Quote
Old 23rd April 2017, 12:19   #808
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,338
Try with the newer build 6140, forgot to enable the noheader stuff, sorry.
Koopa is offline   Reply With Quote
Old 23rd April 2017, 20:02   #809
MarkRH
Senior Member
 
Join Date: Nov 2002
Location: Oklahoma City, OK
Posts: 405
Quote:
Originally Posted by Koopa View Post
Try with the newer build 6140, forgot to enable the noheader stuff, sorry.
That worked. New report: http://www.markheadrick.com/winamp-info.php

Thanks for your work. Get well soon.
MarkRH is offline   Reply With Quote
Old 29th April 2017, 13:18   #810
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,338
Just released 6.0.1 which should resolve the issues with the big 6.0 update.

Note I have moved all to css now, so there were a lot of css changes for all styles.
Koopa is offline   Reply With Quote
Old 1st May 2017, 18:31   #811
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,338
MarkRH

your website is UTF-8 why did you request ANSI reports?

You missed some css updates btw, especially for the statistics tables and back to top links.
Koopa is offline   Reply With Quote
Old 2nd May 2017, 14:31   #812
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,338
Just released 6.0.2 a minor update with smaller fixes and improvements to the new default html stylesheet mainly.
Koopa is offline   Reply With Quote
Old 2nd May 2017, 19:42   #813
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,338
Released 6.0.3 mainly to indicate more WACUP specific components.
Koopa is offline   Reply With Quote
Old 2nd May 2017, 21:09   #814
MarkRH
Senior Member
 
Join Date: Nov 2002
Location: Oklahoma City, OK
Posts: 405
Quote:
Originally Posted by Koopa View Post
MarkRH

your website is UTF-8 why did you request ANSI reports?

You missed some css updates btw, especially for the statistics tables and back to top links.
At the time the page wasn't encoded UTF-8 and I think back then you were doing UTF-16 or something. When I created the Wacup Info page, I converted both to UTF-8 charset so I use the UTF-8 report option now. If you want to get rid of the ANSI option, that's fine with me.

Going to install the latest version now and double-check the CSS.
MarkRH is offline   Reply With Quote
Old 2nd May 2017, 21:15   #815
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,338
Yeah, when I did UTF-16 I agree that ANSI was the better choice, but if I had known that you use UTF-8 I never had re-implemented ANSI in 6.0.

Nevertheless I ripped it out.

Maybe it is more easy for you if you directly take a look at my css:

http://koopa.meggamusic.co.uk/css/infotool.css

But I'm using the new default, modern css, you are using the classic theme, hehe
Koopa is offline   Reply With Quote
Old 2nd May 2017, 21:54   #816
MarkRH
Senior Member
 
Join Date: Nov 2002
Location: Oklahoma City, OK
Posts: 405
OK, check my reports: http://www.markheadrick.com/winamp-info.php and http://www.markheadrick.com/wacup-info.php

Thanks for all your work!
MarkRH is offline   Reply With Quote
Old 3rd May 2017, 00:14   #817
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,338
Looking good, already fixed the missing 0 for WLZ file statistics for next version.
Koopa is offline   Reply With Quote
Old 3rd May 2017, 00:30   #818
MarkRH
Senior Member
 
Join Date: Nov 2002
Location: Oklahoma City, OK
Posts: 405
Oh, I did notice an error here: http://www.markheadrick.com/wacup-info.php#summary where it thinks there a 0 skins in a folder when there are 4 skins, which are listed above. The Winamp info one is correct. It's just the Wacup one that's wrong for some reason.
MarkRH is offline   Reply With Quote
Old 6th May 2017, 19:25   #819
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,606
Hi Koopa,

I'm using v6.0.2.6152. I think ml_bkmk.dll, ml_enqplay.dll, and ml_exporter in the media library section are added by WACUP. Likewise for image.w5s in the system components section and libsoxr.dll in the DLL files sections.

You should check with DrO to be sure.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 6th May 2017, 22:39   #820
MarkRH
Senior Member
 
Join Date: Nov 2002
Location: Oklahoma City, OK
Posts: 405
Quote:
Originally Posted by MarkRH View Post
Oh, I did notice an error here: http://www.markheadrick.com/wacup-info.php#summary where it thinks there a 0 skins in a folder when there are 4 skins, which are listed above. The Winamp info one is correct. It's just the Wacup one that's wrong for some reason.
Well, I added a skin and ran the Info Tool again and now it's counting all the skins properly. So maybe it's a special case where the only skins are the ones in the folder.
MarkRH is offline   Reply With Quote
Old 7th May 2017, 03:50   #821
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,338
Aminifu:

ml_bkmk.dll, ml_enqplay.dll, and ml_exporter are already marked as WACUP components in 6.0.3. Need to research about libsoxr.dll.

MarkRH:

I cannot reproduce your issue, independent of the total amount of skins also I haven't found anything wrong in the code.

I have fixed the missing 0 if no language files are present in statistics though.

Sill trying to resolve a Unicode garbage issue when parsing strings from winamp.ini, but this can take a while so another minor release has to wait a bit.
Koopa is offline   Reply With Quote
Old 8th May 2017, 06:50   #822
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,338
A short info, beginning with Winamp Info Tool 6.0.4, Windows XP/Vista isn't supported anymore. I cannot test against XP/Vista and add workarounds for not working Unicode chars etc.

The tool is meant as a report tool used on current operation systems. Next Version will require Windows 7+.
Koopa is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Discussion

Tags
html report, installed winamp version, plugin list, txt report, winamp build number, winamp info report

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump