Old 14th December 2013, 21:28   #321
Victhor
Late skinner & Moderator
 
Victhor's Avatar
 
Join Date: May 2003
Location: Argentina
Posts: 1,375
Quote:
Originally Posted by DigiBC View Post
I'm sorry, but that one's not working. Unfortunately only some "crap" is shown...
Sorry, NOW it´s working fine (re-download please). (stupid xml why can´t I comment inside a comment?)


It could be that previously it wasn´t working as expected on some installs (in fact, worked in mine before posting it, but I had video enabled.. so I went to an old Win XP PC and tested just to find it doesn´t work..so I fix it)

· · TMCT · KOMODO X
Victhor is offline   Reply With Quote
Old 14th December 2013, 22:45   #322
Irbidan
Junior Member
 
Join Date: Jan 2011
Posts: 6
WINAMP crashing!!!!!!!!

Version 5.666 3516:



Isn't resolved!
Irbidan is offline   Reply With Quote
Old 14th December 2013, 23:08   #323
Victhor
Late skinner & Moderator
 
Victhor's Avatar
 
Join Date: May 2003
Location: Argentina
Posts: 1,375
@irbidan ; You talk about the skin I modified or about Winamp itself?

· · TMCT · KOMODO X
Victhor is offline   Reply With Quote
Old 14th December 2013, 23:36   #324
DigiBC
Junior Member
 
Join Date: Dec 2007
Location: Europe
Posts: 28
@Victhor:

Unfortunately the "normal" Bento version is still not working.

I wonder that the file size is quite small (134 KB) compared to the Big Bento version (405 KB). Actually the content of the WAL (ZIP) file appears to be incomplete somehow...

Maybe I've tried the wrong download link, but it's the only one I can find on your site.
DigiBC is offline   Reply With Quote
Old 14th December 2013, 23:42   #325
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,336
If I can remember, Bento and Big Bento share some files. Most of the files for Bento are present in 'Big Bento' folder only.

This would explain, why it doesn't work and why the normal 'Bento' version is smaller.

I've only tested Big Bento mod, which works perfectly.
Koopa is offline   Reply With Quote
Old 15th December 2013, 00:02   #326
Victhor
Late skinner & Moderator
 
Victhor's Avatar
 
Join Date: May 2003
Location: Argentina
Posts: 1,375
@DigiBC: Is like Koopa says, so that explains 2 things;

1- Why Bento is smaller
2- Why it doesn´t work for you, have you erased or renamed Bento or Big Bento´s original FOLDERS? You need both, specially Big bento for my mods to work properly..

· · TMCT · KOMODO X
Victhor is offline   Reply With Quote
Old 15th December 2013, 08:29   #327
harimenon89
Member
 
Join Date: Apr 2008
Posts: 81
Hi All,

I uninstalled my older version of Winamp and tried installing the Winamp latest Build as a clean install...However after installation when every time i am trying to add media library to my Winamp its crashes. I have attached the crash report and winamp info report please help. its always crashing
Attached Files
File Type: txt Winamp Info Report.txt (25.4 KB, 261 views)
File Type: txt Winamp Crash Report.txt (804 Bytes, 303 views)

Hari
harimenon89 is offline   Reply With Quote
Old 15th December 2013, 08:45   #328
DigiBC
Junior Member
 
Join Date: Dec 2007
Location: Europe
Posts: 28
Quote:
Originally Posted by Victhor View Post
@DigiBC: Is like Koopa says, so that explains 2 things;

1- Why Bento is smaller
2- Why it doesn´t work for you, have you erased or renamed Bento or Big Bento´s original FOLDERS? You need both, specially Big bento for my mods to work properly..
I've made it finally!

Installing those two WAL files is still not working, but after unzipping both files to Winamp's (original) "Skins" folder it's working now.
DigiBC is offline   Reply With Quote
Old 15th December 2013, 15:31   #329
Irbidan
Junior Member
 
Join Date: Jan 2011
Posts: 6
Quote:
Originally Posted by Victhor View Post
@irbidan ; You talk about the skin I modified or about Winamp itself?
Talking about Winamp, not skins, i only installed Winamp by default in Windows 8.1 and when i play some Audio Winamp crashs.
Irbidan is offline   Reply With Quote
Old 15th December 2013, 20:05   #330
Hanschke
Senior Member
 
Join Date: Mar 2003
Location: germany
Posts: 125
no browser will be nice or how to get rid off?
Hanschke is offline   Reply With Quote
Old 15th December 2013, 21:12   #331
DrO
 
Join Date: Sep 2003
Posts: 27,880
Quote:
Originally Posted by schulze View Post
after setting no_video=1 the video tab under preferences is still present but this is just a cosmetic thing. I don't really mind because I didn't install / deleted everything video related (plugins etc).
that's weird as the setting blocks the prefs item as well. oh well *shrugs*

Quote:
Originally Posted by schulze View Post
went back to JTFE b1212 and everything's working flawlessly so take your time.
just about to have a look now, so can start on the non-Winamp release updates again.


Quote:
Originally Posted by Koopa View Post
But I'm even not sure, if all needed source code for Bento is available to do such things.
there'll be a new skin SDK soon, just a bit behind on sorting out such things at the moment.

Quote:
Originally Posted by Irbidan View Post
WINAMP crashing!!!!!!!!

Version 5.666 3516:...
of course it won't have been fixed as i've no idea what the crash is (the screenshot gives _no_ information. without a crash report or something from procdump (http://forums.winamp.com/showpost.ph...86&postcount=6) there's little else to do / suggest.

Quote:
Originally Posted by harimenon89 View Post
I uninstalled my older version of Winamp and tried installing the Winamp latest Build as a clean install...However after installation when every time i am trying to add media library to my Winamp its crashes. I have attached the crash report and winamp info report please help. its always crashing
really need a Winamp crash report of a procdump output (http://forums.winamp.com/showpost.ph...86&postcount=6) though the most i can probably do is determine the cause, not fix it.
DrO is offline   Reply With Quote
Old 15th December 2013, 23:53   #332
Victhor
Late skinner & Moderator
 
Victhor's Avatar
 
Join Date: May 2003
Location: Argentina
Posts: 1,375
Quote:
Originally Posted by DrO View Post
there'll be a new skin SDK soon, just a bit behind on sorting out such things at the moment.

Can you please upload there the wasabi sources (or whatever that can be share) of the COLOR EDITOR?
It really needs an update, there are people willing to fix it (if allowed) and just today I´ve found out that it is AOL / Nullsoft property.. :/

· · TMCT · KOMODO X
Victhor is offline   Reply With Quote
Old 15th December 2013, 23:56   #333
DrO
 
Join Date: Sep 2003
Posts: 27,880
probably not especially as it doesn't seem to be buildable against anything current in the main repository. i can ask, but i wouldn't expect a response you'll like.
DrO is offline   Reply With Quote
Old 16th December 2013, 00:16   #334
Victhor
Late skinner & Moderator
 
Victhor's Avatar
 
Join Date: May 2003
Location: Argentina
Posts: 1,375
Please do, as the old men used to say.. "If it was a ´yes´ all the time you´ll never know if you don´t ask"..

· · TMCT · KOMODO X
Victhor is offline   Reply With Quote
Old 16th December 2013, 03:31   #335
Victhor
Late skinner & Moderator
 
Victhor's Avatar
 
Join Date: May 2003
Location: Argentina
Posts: 1,375
Sorry for double post..

Quote:
Originally Posted by Hanschke View Post
no browser will be nice or how to get rid off?
I can work on something like that, but it has to be a more carefully done job so it wont be soon, check winampforum.com so I´ll probably be posting there.

@DrO; Sorry, forgot to say ("to think of" actually).. if you were going to ask to Martin Pöhlmann, don´t do it, I´ve already spoke with him.

· · TMCT · KOMODO X
Victhor is offline   Reply With Quote
Old 16th December 2013, 03:42   #336
Sabine Klare
Forum Queen
 
Sabine Klare's Avatar
 
Join Date: Nov 2010
Location: Berlin, Germany
Posts: 2,390
There are two fronts: people, who love the Winamp Browser (Bento / Big Bento), and people, who hate it. I am one of the people, who love it, and I want to keep it. Maybe something can be done for both fronts. It's just an idea...

I will read on winampforum.com, of course...

Sabine Klare Aka Sternenmaschinebine
Music, Art, Lyrics, Videos
AMBIENT... AMBIENT music forever...
Sabine Klare is offline   Reply With Quote
Old 16th December 2013, 07:46   #337
OlexijL
Senior Member
 
Join Date: Jan 2004
Location: Germany
Posts: 101
Send a message via AIM to OlexijL Send a message via Yahoo to OlexijL
It would be best to have at least the Winamp JTFE bug fixed either via hotfix or new installer compilation. See #303 posting... It is confirmed not working.

best regards
OlexijL is offline   Reply With Quote
Old 16th December 2013, 12:11   #338
DrO
 
Join Date: Sep 2003
Posts: 27,880
OlexijL: it will now only be updated from downloads on my site as i've already stated. we've re-patched and re-run installers more that was ever intended (though it was needed) and things are now at the point where it's no longer viable to make new 'official' installers. as such, out of band patching of my plug-in is all that is going to happen now (like it used to be).
DrO is offline   Reply With Quote
Old 16th December 2013, 12:59   #339
AustinGuy
Junior Member
 
Join Date: Dec 2013
Posts: 1
I just this morning learned about Winamp's imminent semi-demise, hence this first and possibly only visit to the forum. After reading this thread and some others, I can't find firm answers to my concerns. With apologies if these have already been well answered, can someone tell me, definitively, whether these statements are true:

1. There is now only one Winamp installer. It is stripped of the "extras" and installs only the Regular and Pro versions.

2. The only active link for downloading the installer is the text "Already own Winamp and need to upgrade?" on http://www.winamp.com/media-player/en.

3. Pro features can only be enabled by entering a registration key.

4. It's no longer possible to buy Pro registration keys, so if we don't already have one, we can't get the Pro features.

5. This site, winamp.com, including this forum, will disappear on or soon after Dec. 20. After that, Winamp discussion will only be available at winampforum.com.

Thanks in advance.
-- AG
AustinGuy is offline   Reply With Quote
Old 16th December 2013, 15:59   #340
Sinergie
Junior Member
 
Join Date: Sep 2005
Location: The Netherlands
Posts: 18
Winamp 5.666 latest build crashes with some songs, doesn't crash with 5.64 or 5.65.

I uploaded an example here:

http://www.sendspace.com/file/dzppxx
Sinergie is offline   Reply With Quote
Old 16th December 2013, 16:40   #341
OlexijL
Senior Member
 
Join Date: Jan 2004
Location: Germany
Posts: 101
Send a message via AIM to OlexijL Send a message via Yahoo to OlexijL
Quote:
Originally Posted by Sinergie View Post
Winamp 5.666 latest build crashes with some songs, doesn't crash with 5.64 or 5.65.

I uploaded an example here:

http://www.sendspace.com/file/dzppxx
Please upload ALL not working songs. I fix it for you if i am capable. PM me for that please.
OlexijL is offline   Reply With Quote
Old 16th December 2013, 18:07   #342
DrO
 
Join Date: Sep 2003
Posts: 27,880
or i do one better and patch in_mp3.dll...
DrO is offline   Reply With Quote
Old 16th December 2013, 18:10   #343
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,153
Send a message via AIM to MrSinatra
DrO,

did u confirm an issue with in_mp3.dll?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 16th December 2013, 18:12   #344
DrO
 
Join Date: Sep 2003
Posts: 27,880
yes, a few days ago though haven't determined the actual cause, other than a crude way to fix it which i'm not happy about.
DrO is offline   Reply With Quote
Old 16th December 2013, 18:41   #345
ryerman
Major Dude
 
ryerman's Avatar
 
Join Date: Mar 2010
Location: Canada
Posts: 581
Quote:
Originally Posted by Sinergie View Post
Winamp 5.666 latest build crashes with some songs, doesn't crash with 5.64 or 5.65.

I uploaded an example here:

http://www.sendspace.com/file/dzppxx
Hopefully, DrO will have time to provide a fix for in_mp3.dll.

Meanwhile, that file has ID3v2.1 and ID3v2.4 tags.
According to Mp3tag, the ID3v2.4 tags are "bad".
If the tag is removed or rewritten, the file plays in Winamp (even with 2 picture fields).

Windows 10 Home, 64 bit, Winamp 5.666, Bento Skin
ryerman is offline   Reply With Quote
Old 16th December 2013, 18:41   #346
OlexijL
Senior Member
 
Join Date: Jan 2004
Location: Germany
Posts: 101
Send a message via AIM to OlexijL Send a message via Yahoo to OlexijL
Quote:
Originally Posted by DrO View Post
or i do one better and patch in_mp3.dll...

@DrO: actually if MP3 has 2 cover files inside (see via MP3Tag or similar tools) it won't work. I removed one cover. That's all.
OlexijL is offline   Reply With Quote
Old 16th December 2013, 18:53   #347
DrO
 
Join Date: Sep 2003
Posts: 27,880
i've not closely looked at the file so i don't know what's in it, though thanks for the hint. as i've tried it with the in_mp3.dll from build 3516 and against what i'd made as a patch and the patch one doesn't crash, though i'd much prefer to know what is causing the crash to better handle such an issue compared to just blindly adding a parameter check as my current attempt does.
DrO is offline   Reply With Quote
Old 16th December 2013, 18:54   #348
ryerman
Major Dude
 
ryerman's Avatar
 
Join Date: Mar 2010
Location: Canada
Posts: 581
The ID3v2.4 tags are written incorrectly.

Windows 10 Home, 64 bit, Winamp 5.666, Bento Skin
ryerman is offline   Reply With Quote
Old 16th December 2013, 18:56   #349
DrO
 
Join Date: Sep 2003
Posts: 27,880
give me a chance to look into it properly, geez. and if those are incorrect, the changes made with memory allocation shouldn't be causing a crash to happen, which makes me wonder if it was able to crash previously but the other adjustments are now exposing the issue in a more consistent manner.
DrO is offline   Reply With Quote
Old 16th December 2013, 19:05   #350
ryerman
Major Dude
 
ryerman's Avatar
 
Join Date: Mar 2010
Location: Canada
Posts: 581
You're welcome.

Windows 10 Home, 64 bit, Winamp 5.666, Bento Skin
ryerman is offline   Reply With Quote
Old 16th December 2013, 19:06   #351
DrO
 
Join Date: Sep 2003
Posts: 27,880
we had an example file which causes the same crash which has no ID3v2.4 tag in it, that is what i mean in that it needs time to look into it properly.
DrO is offline   Reply With Quote
Old 16th December 2013, 22:03   #352
lordsilver
Junior Member
 
Join Date: Dec 2013
Posts: 43
Sorry for asking such a stupid question, but I can't find anymore this option :|. How can I disable the playlist number of the song from the notification bar?
Hmm, I just found the option at General Preferences... But there is a bug in there... if you deselect taskbar you can't deselect "Show the playlist number in the Windows taskbar".. So if you want to deselect it, you need to select Taskbar again, deselect the option and there deselect Taskbar again. Now the playlist number will not be on the notification of Winamp Agent.
lordsilver is offline   Reply With Quote
Old 16th December 2013, 22:22   #353
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,153
Send a message via AIM to MrSinatra
so DrO, sounds like you found a workaround, but do you know the actual cause yet? I only ask b/c its got me very curious.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 16th December 2013, 22:26   #354
DrO
 
Join Date: Sep 2003
Posts: 27,880
Quote:
Originally Posted by lordsilver View Post
Hmm, I just found the option at General Preferences... But there is a bug in there... if you deselect taskbar you can't deselect "Show the playlist number in the Windows taskbar".. So if you want to deselect it, you need to select Taskbar again, deselect the option and there deselect Taskbar again. Now the playlist number will not be on the notification of Winamp Agent.
that is by design, the option relates primarily to the presence of the taskbar item, so it being non-editable when that is disabled is desired. so it is not a bug.

Quote:
Originally Posted by MrSinatra View Post
so DrO, sounds like you found a workaround, but do you know the actual cause yet? I only ask b/c its got me very curious.
i do and it's best i don't go into detail.
DrO is offline   Reply With Quote
Old 16th December 2013, 23:12   #355
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,751
JTFE update now available
http://forums.winamp.com/showthread....373755#updates
DJ Egg is offline   Reply With Quote
Old 17th December 2013, 02:14   #356
djgencdafunk
Junior Member
 
Join Date: Sep 2007
Posts: 1
Hey. The latest version features active in the pro version?
djgencdafunk is offline   Reply With Quote
Old 17th December 2013, 09:41   #357
Sabine Klare
Forum Queen
 
Sabine Klare's Avatar
 
Join Date: Nov 2010
Location: Berlin, Germany
Posts: 2,390
If the ID3v2.4 tags are written incorrectly, then I have to take care, that some of my MP3s from SoundCloud, Bandcamp, Internet Archive & Co don't have incorrectly written ID3v2.4 tags. But mostly the tags were incomplete, and I had to use Mp3tag (I want to have also the album art from these websites in my files). It will be many work to check all my files again with Mp3tag. I have picked some folders to take a quick look, and I see ID3v2.3. When did the ID3v2.4 tags come out?

I have also a few files from Jamendo, which have more than 1 embedded image.

Sure, a fix for in_mp3.dll would be very good, and I have also downloaded the JTFE update. I will still keep my eyes open here...

Sabine Klare Aka Sternenmaschinebine
Music, Art, Lyrics, Videos
AMBIENT... AMBIENT music forever...
Sabine Klare is offline   Reply With Quote
Old 17th December 2013, 09:50   #358
DrO
 
Join Date: Sep 2003
Posts: 27,880
the in_mp3.dll issues in build 3516 are not ID3v2.4 specific and is just specific to changes made in that build. though badly tagged files from random sources are more likely to cause the issue to appear (which the prior builds were effectively hiding).
DrO is offline   Reply With Quote
Old 17th December 2013, 09:51   #359
Sabine Klare
Forum Queen
 
Sabine Klare's Avatar
 
Join Date: Nov 2010
Location: Berlin, Germany
Posts: 2,390
Good to know that. Thank You...

Sabine Klare Aka Sternenmaschinebine
Music, Art, Lyrics, Videos
AMBIENT... AMBIENT music forever...
Sabine Klare is offline   Reply With Quote
Old 17th December 2013, 14:37   #360
schulze
Junior Member
 
Join Date: Nov 2005
Posts: 27
Quote:
Originally Posted by DJ Egg View Post
it's working now. thanks for fixing this one
schulze is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump