Old 21st August 2007, 15:36   #1
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
Winamp 5.36 Beta Preview 2 (Build 1504)

Winamp 5.36 Beta, Build 1504

Winamp 5.36 Beta Full
Winamp 5.36 Beta Pro (asks for key during install)
Winamp 5.36 Beta Lite (basic 2.x-style mp3/cd player)

Winamp 5.36
* New: [in_mp3] Multi-channel mp3surround support
* New: [ml_local] 3 pane view options in 'Add/Edit View' dialog
* New: [ml_local] Smart View Presets
* New: [ml_local] Album Art support/pane
* New: [ml_local] Toolbar buttons to control view options
* New: [ml_plg] Winamp Playlist Generator (powered by Gracenote MusicID)
* New: [ml_pmp] New fields, configurable filter panes & columns, 3 pane view
* New: [ml_pmp] Album Art view & support for iPod and P4S Devices
* New: [ml_pmp] Separate view for video files
* New: Album Art window for Winamp Modern skin
* New: Global 'playback thread priority' setting for decoders
* New: Version History drop-down selector and Search (in About dialog)
* Improved: General misc dialog/ui tweaks & improvements
* Improved: Re-tuned and optimized classic Spectrum Analyzer
* Improved: Surround indicator in Winamp Modern skin for multi-channel files
* Improved: [in_cdda] Conductor metadata support
* Improved: [in_cdda] Handling of multiple discs
* Improved: [in_flac/in_vorbis] ALBUM ARTIST & ENSEMBLE read support
* Improved: [in_flac] Advanced Editor mode
* Improved: [in_mod] Added support for more than 256 samples
* Improved: [gen_ff] General freeform skinning engine optimizations
* Improved: [gen_ml] Collapsed/expanded state of treeview items now remembered
* Improved: [gen_ml] Skinned scrollbars for Media Library with Modern skins
* Improved: [gen_ml] Reordering of treeview items (via drag+drop)
* Improved: [ml_disc] Better Unicode support
* Improved: [ml_history] Unicode support
* Improved: [ml_local] Customize Columns menu for top filter panes
* Improved: [ml_local] Option to show horizontal scrollbar for top panes
* Improved: [ml_local] New 'Podcasts' view (appears after downloading a podcast)
* Improved: [ml_local] Added ISPODCAST and PODCASTCHANNEL field names
* Improved: [ml_local] Added BEGINSLIKE comparison operator
* Improved: [ml_local] Dragging of headers to sort column order
* Improved: [ml_local] Redesigned Smart View Editor
* Improved: [ml_local] Star Rating display and selection
* Improved: [ml_pmp] 'Copy to Local Media' config separated from CD Ripping settings
* Improved: [ml_pmp] Portables "Sync" can now keep podcasts updated
* Improved: [ml_rg] ReplayGain calculation support for 64, 88.2 & 96 KHz samplerates
* Improved: [ml_wire] Optional automatic downloading of new podcast episodes
* Improved: [ml_wire] Multi-select, 'Send To' menu and other general enhancements
* Improved: [ml_wire] Podcast downloads now saved in channel subfolders
* Improved: [pmp_ipod] Now uses the iPod's podcast menu for podcasts
* Fixed: Long filepaths corrupted when opening Winamp via Explorer context menu
* Fixed: Oversized preference pages with large DPI setting
* Fixed: Recurrence of multiple instances bug (previously fixed in 5.3)
* Fixed: Selecting 'No' for 'Physically Remove' prompt removes playlist/mldb item
* Fixed: TV button in video window not working
* Fixed: Windows showing if switching from modern to classic skin in minimized state
* Fixed: [ASX Loader] Recursive playlist loading & case-insensitive element matching
* Fixed: [ASX Loader] Handling of entries embedded within a REPEAT tag
* Fixed: [gen_ff] "Can't unload script while in script" error when switching skins
* Fixed: [gen_ff] Transparent docked toolbars for skins using alpha-blending
* Fixed: [gen_ml] %playcount% returning Comment on drag+drop from ML to pledit
* Fixed: [in_cdda] CDDB crash when trying to rip CDs in a 2nd instance of Winamp
* Fixed: [in_flac] General FLAC Editor quirks (Comments field, Enter key, etc)
* Fixed: [in_flac] 24bit files don't play when 'Allow 24bit' setting is disabled
* Fixed: [in_mod] Fadeout value goes below 0.0 sec in in_mod config
* Fixed: [in_mod] Interpolator 'division by zero' crash bug
* Fixed: [in_mp3] Crash on some mp3's with corrupt ID3v2 extended headers (rare)
* Fixed: [in_mp3] Crash on loading corrupt id3v2.3 tags of a later revision
* Fixed: [in_mp3] Negative bitrate in File Info for long mp3's
* Fixed: [in_wave/libsndfile] Crash on invalid .au files
* Fixed: [in_wm] Garbage characters when editing filetypes in config
* Fixed: [in_mp4/libmp4v2] Memory leaks
* Fixed: [ml_disc] 0 byte temp files not deleted after ripping
* Fixed: [ml_disc] Double-click drive icon in Rip & Burn not selecting tree item
* Fixed: [ml_disc] Crash when using <trackartist> in playlist filename generation
* Fixed: [ml_disc] Drag+drop from Audio CD view to Playlist Editor
* Fixed: [ml_local] (no album) items adding to Album count in Artist pane
* Fixed: [ml_local] isempty and =0 queries now return same results
* Fixed: [ml_local] Add dir to 'Watch Folders' path truncated to 64 characters
* Fixed: [ml_pmp] Inserting extra period in filename when transcoding to mp4/aac
* Fixed: [ml_wire] Subscription Updates setting always resets to 'Never'
* Fixed: [pmp_ipod] Potential incompatability issue with latest version of iTunes
* Fixed: [pmp_p4s] 'Error In Insert' when transferring to some P4S devices
* Fixed: [vis_milk] Milkdrop DEP incompatibility
* Misc: Removed db.w5s (replaced by new Gracenote database system)
* Misc: Moved drawing engine out of gen_ff to tataki.dll
* Misc: Moved freetype font renderer out of gen_ff to freetype.wac
* Updated: Gracenote MusicID CDDB v2.5
* Updated: libpng 1.2.19
* Updated: [in_flac] FLAC 1.2.0
* Updated: [in_mp3] FhG Decoder v4.10
* Updated: [in_vorbis] libvorbis 1.2.0


More to follow in subsequent betas...

__________________________________________________________________________


Notes:

Please report any issues with the beta in this thread only.
Make sure your report is complete, according to the stickys in Bug Reports
(clean install, no 3rd-party plugins, full step-by-step method of reproduction, relevant system specs, links to sample files, etc).

Particular areas which need testing are:
  • Album Art support (view/pane in ml)
  • Media Library navigation tree (drag+drop items, collapse/expand, etc)
  • New ML Local Media filters/panes/config
  • New PMP filters/panes/config
  • Check for any gen_ff/skinning bugs
  • New Podcast views/features
  • CDDB2.5 features/editor
  • Playlist Generator (play tracks similar to)
-Album Art support is still incomplete (more to come: download, refresh, etc) ;-)
-Currently looks for folder/cover/%album%.jpg/gif/etc then embedded (in tags).
-(this order will be reversed in the next public beta).
-Note: At the moment, the only way to clear the cache is:
-to close Winamp and delete the art*.* cache files in the "Plugins\ml" folder
-(art.dat, art.idx, art60.dat/idx, art90.dat/idx, etc).

-mp3surround is playback only for now (no encoding).
-You can find tracks at www.all4mp3.com/music/

-Playlist Generator is still in early beta (rt. click ml/pledit items > Play tracks similar to).
-Notes:
-1) Manual config via: Prefs > Plugins > Media Library > ml_plg.dll > config
-2) Initial Scan may take some time. The more files in your mldb, the longer...
-3) Limited to 20 results only (with option to change coming later)
-4) Obeys the Play/Enqueue as default action in ML Prefs
-5) Database stored in Winamp\Plugins\Gracenote (along with all other GN/CDDB files).
-6) Selected item is not in the generated list (but will be in a later beta).

-Re: Skinned ml scrollbars
-For support, Wasabi version needs to be specified as 1.3 in skin.xml, eg.
-<WasabiXML version="1.3">


Hidden settings:

plugins\gen_ml.ini
Navigation_ItemHeight=18 (default)
Navigation_ShowIcons=1/0 (show/hide tree icons)
Navigation_FullRowSel=1/0 (hi-lite full row in tree, or just the text)
Navigation_MouseDownSel=1/0 (rt-click selects item, or not)

plugins\ml\cdrom.vmd
showeject=0/1 (show/hide 'Eject CD' icons in tree)
showparent=0/1 (group CD Drives under 'Rip & Burn' parent, or not)

These settings will hopefully be accessible via the UI eventually....

__________________________________________________________________________


Known Bugs/Issues:

-Updated JTFE (gen_jumpex.dll) to come later
Includes fixes for a couple of known 5.35 bugs
Also known: Enter & dbl-click aren't working when the JTFE dialog is skinned.

-New CDDB features may still be a bit buggy (eg. see ujay's post below)

-Mouse cursor disappearing over ml column headers (1504-specific) *

-Winamp Modern skin Album Art window still checked in menu when closing it via the 'x', and not changing with colorthemes (fixed version here) *

-"Send To > Format Converter" is broken for multiple selections *

-Alas, Winamp 5.36 Full/Pro is probably no longer compatible with Win9x (Win 98/ME)
(Lite should still be ok, as it is mainly the ML which is incompatible).

* = Fixed internally

__________________________________________________________________________


Updates:

Color Editor 2.1.1
Check this thread for the latest installer - some feedback on vista is required!.

Winamp Essentials Pack v5.36 Beta

A couple of updates available for Winamp Modern skin Album Art window here & here

5.36 Beta 2, Build 1500-1504 changelog


______________________________________________
Old Winamp 5.35 Released thread
DJ Egg is offline  
Old 22nd August 2007, 19:27   #2
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
yay!
Benski is offline  
Old 22nd August 2007, 19:55   #3
martin.deimos
Android/UI Development
 
martin.deimos's Avatar
 
Join Date: Sep 2004
Location: Bavaria
Posts: 1,242
Send a message via ICQ to martin.deimos Send a message via AIM to martin.deimos Send a message via Yahoo to martin.deimos
hehe, we've got internal album art support

For skinners:
in your skins you can show an album art image via a new object
PHP Code:
<AlbumArt notfoundImage="someImgID"/> 
To access this Object via script just use GuiObject - it is NOT a layer!!
the Media Library image for album art not found can be changed via player-elements.xml
PHP Code:
<bitmap id="winamp.cover.notfound" file="window/notfound.png" /> 
i think that's all...

WebSite: www.skinconsortium.com - Community for Userinterface Design & Coding
Skins: Click Here
martin.deimos is offline  
Old 22nd August 2007, 20:30   #4
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
feel free to worship/mail me burritos if you enjoy the album art view as much as i (and ben and maksim) enjoyed coding it.
turn it on here:



If you don't have any album art, i (personally, not AOL) recommend this tool: http://team.thenexusnet.com/nexus/AAA/

Oh and don't forget to try out all the fun modes:

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline  
Old 22nd August 2007, 20:56   #5
STanger
Senior Member
 
STanger's Avatar
 
Join Date: Jul 2004
Location: Memphis TN
Posts: 399
Send a message via AIM to STanger Send a message via Yahoo to STanger
at least I don't have to worry about random crashes in milkdrop anymore thanks to having DEP fully applied. x.x
STanger is offline  
Old 22nd August 2007, 21:56   #6
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
CDDB plugin config - any use when 'Use MusicID' is switched off on entry causes C++ Runtime error 'application has requested the Runtime to terminate in an unusual way'

Looks like there are some problems with not writing anything to DB if Gracenote matches/submissions are declined.
CD Text works OK but doesn't write to DB. Editing looks problematical in these cases, is it dependent on submitting to Gracenote, or should you be able to edit anything, whether it's on GN's database or not .

What provision is there for moving info from cdinfo.db3 -> cddb.db or is that lost.

[edit] There was a very useful 'feature' in the old Modern skin where you could raise the Playlist window by clicking on dead space in the Main window. This can still be set up but doesn't hold from session to session.

Is this lost now?

UJ

Last edited by ujay; 22nd August 2007 at 22:26.
ujay is offline  
Old 22nd August 2007, 22:26   #7
rx-182
Junior Member
 
Join Date: Jun 2003
Posts: 4
* Fixed: [pmp_ipod] Potential incompatability issue with latest version of iTunes

What was fixed?

Let me quote a bug report I just filled:
<i>
I'm experiencing issues with Winamp 5.35 and my iPod nano (w/ latest firmware from Apple). When I use Winamp to add songs to my iPod, it crashes Winamp when I switch from my iPod to Local Media in the Winamp Media Library.

Worst, when I stay in Local Media to drag and drop songs to my iPod, it will remove these songs from the Media Library and it will corrupt some song titles until I restart Winamp. I tried on 3-4 boxes and the same thing happens. Someone is having the same problem?
</i>

Full post: http://forums.winamp.com/showthread....hreadid=270947
rx-182 is offline  
Old 22nd August 2007, 23:11   #8
Chrissyx
Member
 
Chrissyx's Avatar
 
Join Date: Jul 2006
Location: Germany
Posts: 63
Send a message via ICQ to Chrissyx
Re: Winamp 5.36 Beta Preview 1 (Build 1500)

Quote:
Originally posted by DJ Egg
-Alas, Winamp 5.36 Full/Pro is probably no longer compatible with Win9x (Win 98/ME)
(Lite should still be ok, as it is mainly the ML which is incompatible).
"probably"?

I like "silly devs"!

At the going down of the sun and in the morning ...
we will remember Winamp ♥
Chrissyx is offline  
Old 22nd August 2007, 23:25   #9
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
As far as I know, we don't test under Win9x any more, hence the 'probably'.
DJ Egg is offline  
Old 22nd August 2007, 23:28   #10
Cianca
Senior Member
 
Join Date: Mar 2002
Posts: 336
This 5.36 is historian version of winamp


Finally comes out a "several" winamp... a winamp copyrighted by the new team of winamp... the old winamp is only a reminiscence



GO!!!

The universal god of light, love, wisdom and rok n rol
Cianca is offline  
Old 22nd August 2007, 23:34   #11
Omega X
Forum King
 
Omega X's Avatar
 
Join Date: Feb 2003
Location: A Parallel Dimension
Posts: 2,252
Send a message via AIM to Omega X Send a message via Yahoo to Omega X
I was wondering when the next build was coming. Just look at that changelog.
Omega X is offline  
Old 22nd August 2007, 23:39   #12
DrO
 
Join Date: Sep 2003
Posts: 27,873
Re: Re: Winamp 5.36 Beta Preview 1 (Build 1500)

Quote:
Originally posted by Chrissyx
"probably"?
with some of the other changes that will be coming into play in a few more builds, i think win9x support is dead even on the lite - it's definitely not a platform being tested on anymore now (official testing is effectively xp sp2 which screws me over as i'm a win2k stallwart). alas for the things that is needed with features in the player, crippling things for win9x support has reached the point where it's no longer feasible (as a lot of other programs have reached - just look at foobar which hasn't even worked on win9x for a few years now).

things have basically reached the stage where if it works then it's a bonus but with no dedicated testing pattern or desire to cripple things for the main user base, the win9x support will become unofficial/partial. like Egg's post mentions, things to do with the media library are the main cause of the win9x issues (along with anything to do with cd accessing) but other changes are likely to force things even on the main client (is still uncertain on a few things so i may or may not be right on that)

-daz
DrO is offline  
Old 23rd August 2007, 00:04   #13
Cianca
Senior Member
 
Join Date: Mar 2002
Posts: 336
the llamas in spectrum visualizer

The universal god of light, love, wisdom and rok n rol
Cianca is offline  
Old 23rd August 2007, 00:25   #14
Kaminari
Member
 
Kaminari's Avatar
 
Join Date: Mar 2003
Location: Paris, France
Posts: 52
The latest in_mod build makes Winamp 5.36 crash at startup if Bass Module Player is installed. Separately, each plugin works ok.

http://winamp.com/plugins/details/132367
Kaminari is offline  
Old 23rd August 2007, 01:53   #15
jmatthews112
Major Dude
 
Join Date: Jun 2003
Posts: 1,661
Send a message via AIM to jmatthews112 Send a message via Yahoo to jmatthews112
@Kaminari

Third party plug-ins are not supported. It's more on the developer to fix any bugs with those plugins.
jmatthews112 is offline  
Old 23rd August 2007, 03:39   #16
Logy
Senior Member
 
Logy's Avatar
 
Join Date: Jun 2004
Location: Terengganu, Malaysia, Asia, Earth
Posts: 302
it is any work around on scroll bar playlist editor in final version of winamp!!!

The English suffix -logy denotes a field of study or academic discipline.
Logy is offline  
Old 23rd August 2007, 04:29   #17
Kaminari
Member
 
Kaminari's Avatar
 
Join Date: Mar 2003
Location: Paris, France
Posts: 52
Quote:
Originally posted by jmatthews112
Third party plug-ins are not supported. It's more on the developer to fix any bugs with those plugins.
I'm aware of that.

I reported it because, in this case, the Bass plugin works *perfectly* with Winamp 5.36, providing that the in_mod.dll is disabled. Since the in_mod.dll (which is also an external component and not an integral part of Winamp per say) has recently changed and the Bass plugin hasn't, that designates the Nullsoft plugin as the probable culprit between the two. And it might just be useful to Nullsoft to know that the Bass issue is related to one of their plugins and not to Winamp itself. Which is the whole point of betatesting.

I could also have reported that the lastest build of the USF plugin makes Winamp crash. I didn't because, in this case, it happens not matter what other plugin is enabled or disabled, which clearly points the USF plugin as being buggy (or at least incompatible with 5.36).

Cheers.
Kaminari is offline  
Old 23rd August 2007, 04:31   #18
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
Quote:
Originally posted by Kaminari
I'm aware of that.

I reported it because, in this case, the Bass plugin works *perfectly* with Winamp 5.36, providing that the in_mod.dll is disabled. Since the in_mod.dll (which is also an external component and not an integral part of Winamp per say) has recently changed and the Bass plugin hasn't, that designates the Nullsoft plugin as the probable culprit between the two. And it might just be useful to Nullsoft to know that the Bass issue is related to one of their plugins and not to Winamp itself. Which is the whole point of betatesting.

I could also have reported that the lastest build of the USF plugin makes Winamp crash. I didn't because, in this case, it happens not matter what other plugin is enabled or disabled, which clearly points the USF plugin as being buggy (or at least incompatible with 5.36).

Cheers.
It's definitely worth knowing when third-party plugins break between versions - it might be a legitimate bug on our part. I'll check out the Bass thing, and maybe USF if I get the time.

Whether or not we can do anything about it is another story...
Benski is offline  
Old 23rd August 2007, 06:22   #19
jerimiah40
Major Dude
 
jerimiah40's Avatar
 
Join Date: Nov 2004
Posts: 955
Ooh, ooh, Album Art! Playlist Generator! Look at all the fun new toys. Except, I can't make either of them work. o_O

Album Art is one that I'm not too worried about. Sure, it would be neat, but not entirely necessary. For the record though, my music is organized by iTunes, so that's where it got all the album artwork from. However, I prefer Winamp as a player, but none of the art shows up. As I said, no biggie (at least not to me).

The playlist generator, however, is something I'd like to have working. I fired up the media library (after a clean install), picked an Artist, picked an Album, then right clicked on the track and clicked "Play tracks similar to Layla". As I rather expected, I got a window wanting to scan the library. That went along quite nicely, took a little while, but I expected that. Once it said it was completed, I clicked the close button, and then repeated the process to select a song. I selected "Play tracks similar to Layla" again, and then waited. I first got a message saying that it was analyzing new files. Fine, that didn't take too long. Once that finished, the status area of the ML changed to "Querying Gracenote Database". That finished, and then..... the status area once again read "Querying Gracenote Database". After this, it stopped doing anything. So, I restarted Winamp, located the track again, told it to play similar tracks, and the same thing happened. After another restart, Winamp doesn't even acknowledge that I've clicked, the menu disappears and then nothing happens. Am I doing something wrong?

Specs:
Intel Celeron D Processor (2.8GHz)
256MB RAM
AC97' Embedded Audio
Clean install of Winamp 5.36 Build 1500
Windows XP SP2
jerimiah40 is offline  
Old 23rd August 2007, 08:09   #20
Masta2002
Junior Member
 
Join Date: Nov 2003
Location: Germany
Posts: 8
Are there any plans to make the cover art visible/(maybe changeable) in view file info too?

And show it when playback in playlist or in winamp not only in media libery?
Masta2002 is offline  
Old 23rd August 2007, 08:13   #21
Serpher
Senior Member
 
Serpher's Avatar
 
Join Date: Jun 2006
Location: Poland
Posts: 146
YAY! Adlast new version! Keep it up guys

Sorry for my bad English
=====================
MB: Gigabyte P35C-DS3R || CPU: Intel Core 2 Duo E8400 (3.00 GHz) || RAM: 8 GB Kingston DDR3 1333MHz || Audio card: ASUS Xonar D2X || Video card: GeForce 460 GTX || OS: Windows 7 SP1 || DirectX: 9.0c (latest) || Winamp version: latest || Winamp skin: Modern
Serpher is offline  
Old 23rd August 2007, 08:16   #22
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
Quote:
Originally posted by Masta2002
Are there any plans to make the cover art visible/(maybe changeable) in view file info too?
Hopefully!

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline  
Old 23rd August 2007, 08:36   #23
Serpher
Senior Member
 
Serpher's Avatar
 
Join Date: Jun 2006
Location: Poland
Posts: 146
One question: I saw your new improvment "Play tracks similar to (...)"
How does it work? When I clicked on it, theres nothing happend.


EDIT

Ok, first BUG. In ID3 Tag Editor on tracks 96khz "MPEG Info" shows only "Payload Size: (...) bytes". In previous version it showed normal info like on other mp3 tracks (128/192/etc). Oh and it happens in normal track too (sometimes).

EDIT (2)

There is this same situation on mp3 track that was converted to mp3 surround tracks (even if they have above 96khz).

EDIT (3)

Next bug in mp3 surround track. When I was looking for a good moment in one mp3 surround track the song suddenly went fast forward o.0 It happend me first time...

EDIT (4) ech...
And why mp3 surround tracks are not so loud as in previous version?

EDIT (5) o_O
In new converted mp3 stereo to mp3 surround bitrate in main window of Winamp Modern skin is showed uncorrectly.
And time of the track is showed uncorrectly too.

EDIT (6) ...
Winamp crushing when I'm clicking in ML > Audio.


Please let somebody answer for my edits...

Sorry for my bad English
=====================
MB: Gigabyte P35C-DS3R || CPU: Intel Core 2 Duo E8400 (3.00 GHz) || RAM: 8 GB Kingston DDR3 1333MHz || Audio card: ASUS Xonar D2X || Video card: GeForce 460 GTX || OS: Windows 7 SP1 || DirectX: 9.0c (latest) || Winamp version: latest || Winamp skin: Modern

Last edited by Serpher; 23rd August 2007 at 10:06.
Serpher is offline  
Old 23rd August 2007, 09:27   #24
flocksoft
Major Dude
 
flocksoft's Avatar
 
Join Date: Aug 2006
Location: Italy
Posts: 695
Winamp 5.36 (build 1500) on Windows XP SP2, clean full installation

- Media Library -> CD Ripping -> Ripping tab doesn't support yet the DPI \ Cleartype fix

- (suggestion): sort the genres in the brand new CD info editor (see the picture)

congratulations to the Winamp Team
Attached Images
File Type: png genres.png (3.9 KB, 1051 views)
flocksoft is offline  
Old 23rd August 2007, 09:29   #25
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally posted by flocksoft
- Media Library -> CD Ripping -> Ripping tab doesn't support yet the DPI \ Cleartype fix
there's still a few things left to do with the handling of dialog resources so this will be fixed shortly

-daz
DrO is offline  
Old 23rd August 2007, 09:54   #26
flocksoft
Major Dude
 
flocksoft's Avatar
 
Join Date: Aug 2006
Location: Italy
Posts: 695
tabbability

in the Smart View Editor the first field is Choose a Preset, but it is acting like the last in the tab chain (i.e. hitting the tab key, the focus don't shift to the following fields)

- the last entry field (Name:) is the first in the tab chain

- second frame: no tab-switching at all
flocksoft is offline  
Old 23rd August 2007, 11:01   #27
DrO
 
Join Date: Sep 2003
Posts: 27,873
noted and will be done along with the previous post issue as well - due to some of the changes in the handling of that dialog, things haven't been checked out fully on that. as a note as well, some of the tabbing will be out of synch due to how windows designates the order of things based on the creation of the controls so somethings may not be able to be resolved but will let you know...

-daz
DrO is offline  
Old 23rd August 2007, 11:51   #28
Cianca
Senior Member
 
Join Date: Mar 2002
Posts: 336
a few things:


1) EDIT


2) i run playlist generator and run in background... when winamp doesn't find any result... i think that could be show some message.. maybe in media library statusbar

The universal god of light, love, wisdom and rok n rol

Last edited by Cianca; 23rd August 2007 at 12:33.
Cianca is offline  
Old 23rd August 2007, 12:46   #29
Rdoorn
Junior Member
 
Join Date: Aug 2007
Posts: 5
Crash in Playlist generator

I get a crash in the playlist generator at step 3/4. It scans all my music (20.000) and then it wants to check with gracenote and then winamp crashes and the winamp crash analyzer kicks in.
without the playlist generator all seems normal.

System win XP pro NL sp2
winamp 5,36 build 1500.
1,5 gb ram.

Greetings
Ronald van Doorn
Rdoorn@gmail.com
Rdoorn is offline  
Old 23rd August 2007, 15:00   #30
VortX
Member
 
VortX's Avatar
 
Join Date: May 2006
Location: Santurtzi, Euskadi (Spain)
Posts: 57
not really a bug, but I find it annoying that the search string disappears when switching between "normal" and "cover" view using the "cover" button

anyway, great improvement!! I has been wishing for album art support for ages

Windows 7
Winamp 5.58
VortX is offline  
Old 23rd August 2007, 15:32   #31
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,341
Winamp Essentials Pack v5.36 Beta Released

Download

Changelog:

5.36:
* New: Timerestore & Autoplay plug-in from Darren Owen
* Removed: ml_lite_n from the installer (this functionallity is now part of Winamp)
* Improved: [Installer] deletes ml_lite_n.dll, to keep your installation folder clean
* Improved: [Installer] simplified the section descriptions system again
* Improved: [Installer] improved some parts of the German and Turkish translation
* Updated: [Installer] Polish, Spanish, Turkish and German translations
* Updated: [Installer] to NSIS 2.29


Enjoy,
Koopa
Koopa is offline  
Old 23rd August 2007, 15:43   #32
jmbattle
Senior Member
 
Join Date: Apr 2004
Location: Hamamatsu, Japan
Posts: 166
Oh baby, look at that changelog!

I'm loving the new ML iCandy!



Optional thumbnail caching would be the icing on the cake! Perhaps something to consider when the DB switches to XML?

Incidentally, how can I change the font of the top 'Search:' <search field> 'Clear Search' line and botton 'Play' 'Enqueue' 'Create Playlist' etc. line? Actually, it would be lovely to be able to hide these lines also - I don't think I have ever used those three buttons.

I'm off to play around with some of the other new features.

Keep up the great work chaps!

Cheers,
James
x
jmbattle is offline  
Old 23rd August 2007, 15:51   #33
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
Quote:
Originally posted by jmbattle
Optional thumbnail caching would be the icing on the cake! Perhaps something to consider when the DB switches to XML?
Actually, we do have thumbnail caching. In winamp\plugins\ml\ you should see a few files beginning with "art". This is the cache.

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline  
Old 23rd August 2007, 16:13   #34
jmbattle
Senior Member
 
Join Date: Apr 2004
Location: Hamamatsu, Japan
Posts: 166
Ahhhh, you guys!

May I ask which image format is used for the cache? It is a little sluggish on my dated 1.6mhz P4 laptop.

Furthermore, it would be lovely to have the ML display the currently visible album art first, and then the remaining (non-visible) images in the background to prevent the delay when scrolling through a list of albums.
jmbattle is offline  
Old 23rd August 2007, 16:45   #35
jerimiah40
Major Dude
 
jerimiah40's Avatar
 
Join Date: Nov 2004
Posts: 955
Still no reply about the playlist generator? Damn, I was hoping to get that working, it sounds like a really neat new feature.
jerimiah40 is offline  
Old 23rd August 2007, 17:25   #36
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
@jerimiah40

Go to: Prefs > Plugins > Media Library > Playlist Generator > config
Is the Scan still in progress, or has it completed?
Is the Scan button showing, or does it say Pause or Idle?

If 'Idle', click 'Scan' again and wait for the scan to complete.

Note that some files might not be in the Gracenote database.
eg. I've got 30,508 files in my Local Media Audio, but the Playlist Generator only sees 29,452

The ones that aren't recognised will return no results.
For me, it's obscure 12" mixes that aren't recognized (ie. tracks which aren't on any album).

The results will be displayed in the Playlist Editor window (Enqueued at the end of the list if Enqueue is the default ML action, otherwise the Playlist will be wiped & replaced by the generated list).
If Enqueue is the default ML action (Prefs > Media Library > Library Options tab), then check the end of your Playlist for the results.

Naturally, you also need to make sure that Winamp has been granted internet access at the firewall level.


@all

All other reports are noted, whether commented on or not.
DJ Egg is offline  
Old 23rd August 2007, 17:55   #37
jerimiah40
Major Dude
 
jerimiah40's Avatar
 
Join Date: Nov 2004
Posts: 955
DJ Egg - I opened up the preferences, and despite having run it previously, it says "Idle", and the scan button is available. So, I clicked it to re-scan, and it immediately said "Status: Error Initializing", and the button now reads "Pause". I went into Windows Firewall and added an exception for Winamp and tried again, with the same result. Is there a specific port that needs to be open at the hardware level?

/edit - And I've tried it with many songs, including different artists, genres, completely different decades, nothing has returned any results.
jerimiah40 is offline  
Old 23rd August 2007, 18:33   #38
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
@jerimiah40

Hmm, that's weird.

Did you install Winamp with 'shared settings for all users', or 'separate settings per user'?

Alas, it sounds like the database has got corrupt, and I suggest that you delete it and start again.

With Winamp closed, go to the Winamp\Plugins\Gracenote folder
Delete (or move to some backup folder): cddbplm.idx, cddbplm.pdb
(If you delete cddbpcm.gcf it will just download it from the gracenote server again)

Reopen Winamp

Go to the Playlist Generator config page and start the Scan again.

Wait until it's complete before attempting to use the feature.

Note: The scan requires an internet connection for it to work.
DJ Egg is offline  
Old 23rd August 2007, 19:24   #39
Serpher
Senior Member
 
Serpher's Avatar
 
Join Date: Jun 2006
Location: Poland
Posts: 146
Eh.. nobody's listen' to me... oh well... that's pitty...

Sorry for my bad English
=====================
MB: Gigabyte P35C-DS3R || CPU: Intel Core 2 Duo E8400 (3.00 GHz) || RAM: 8 GB Kingston DDR3 1333MHz || Audio card: ASUS Xonar D2X || Video card: GeForce 460 GTX || OS: Windows 7 SP1 || DirectX: 9.0c (latest) || Winamp version: latest || Winamp skin: Modern
Serpher is offline  
Old 23rd August 2007, 19:35   #40
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally posted by DJ Egg
@all

All other reports are noted, whether commented on or not.
i think that's where you post falls into things

-daz
DrO is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump