Old 28th October 2013, 02:31   #1
Drazala
Junior Member
 
Join Date: Oct 2013
Posts: 8
Confused

Hello everyone. I have a bit of an odd problem. Winamp pro will play some mp4 video while other mp4 files only play audio.

I have tested the ones that are only playing audio with windows media player and they play fine there but not in . So I was wondering if anyone here could give me any suggestions. I will gladly provide any info you need.
Attached Files
File Type: txt Winamp_Info_Report_27.10.2013.txt (22.5 KB, 187 views)
File Type: txt DxDiag.txt (41.5 KB, 166 views)
Drazala is offline   Reply With Quote
Old 28th October 2013, 09:57   #2
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,806
Send a message via AIM to MrSinatra
u might need to share some links to some example files that don't work. also, you can try putting the files thru "mediainfo" and see what it says about them.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 28th October 2013, 10:36   #3
Drazala
Junior Member
 
Join Date: Oct 2013
Posts: 8
I am not sure how many examples you would like but here is one for now. If you need more let me know. Or if this is the wrong info, I apologizes. I am not real familiar with this program.
Attached Files
File Type: txt Example.txt (3.2 KB, 167 views)
Drazala is offline   Reply With Quote
Old 28th October 2013, 12:10   #4
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,806
Send a message via AIM to MrSinatra
have u tried the same file using normal latin characters?

and if that doesn't work, some links to actual files that don't work.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 28th October 2013, 13:43   #5
Drazala
Junior Member
 
Join Date: Oct 2013
Posts: 8
As in just replace the 漢字 with English text or switching my PC from Unicode to English? I would rather not have to resort to the latter if I can keep from it. I do have files with the same problem with English text as a title. I'll provide another example.

Here is a link to the first example.
http://www.filedropper.com/40_1

Here is a link to second example.
http://www.filedropper.com/kotoko-re-sublimity


Note: I will be taking the links down when/if we can resolve the problem I am having.
Attached Files
File Type: txt Example2.txt (3.1 KB, 158 views)
Drazala is offline   Reply With Quote
Old 28th October 2013, 14:30   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
the characters of the filename are not the issue (if they were then the files wouldn't play at all). without drilling down deeper into the code, i suspect it's purely how Winamp is handling the video format as i see it's a h264 variant but maybe it's not one we're supporting the decoding / processing off (as sadly h264 isn't clean cut on just supporting everything with one solution it seems).
DrO is offline   Reply With Quote
Old 28th October 2013, 15:04   #7
Drazala
Junior Member
 
Join Date: Oct 2013
Posts: 8
Well I guess that makes sense as to why some play and some don't. Are there any plans in the future in supporting that particular codec? Is it possible to convert it to another video codec file that is more favorable to Winamp?
Drazala is offline   Reply With Quote
Old 28th October 2013, 15:07   #8
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,858
Hi Drazala,

DrO is probably right about the official Winamp video codecs not being able to handle some variants of some formats. I'm able to run both of the samples you provided (both show a static image while the music plays), but although I am using the Winamp Pro version, I'm not using some of the official Winamp codecs.

The thread linked below explains the 3rd party codecs that I'm using and how to install them. Be sure to read post #11 for links to the latest simplified procedure.

http://forums.winamp.com/showthread.php?t=369826

Winamp v5.9.0.9999 - Quinto Black CT v3.6 skin
Windows 11 Home 64-bit v21H2 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 28th October 2013, 15:11   #9
Drazala
Junior Member
 
Join Date: Oct 2013
Posts: 8
Yes, that is exactly what you should be seeing. Thank you for the links. I'll try them out. I'll post back say if they work or not.
Drazala is offline   Reply With Quote
Old 28th October 2013, 18:43   #10
Drazala
Junior Member
 
Join Date: Oct 2013
Posts: 8
The link (skydive) to the 11th post doesn't work. Are you able to repost the codec pack that was on there?
Drazala is offline   Reply With Quote
Old 28th October 2013, 18:49   #11
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,858
The Google Drive link still works and the links within the PDF. The K-Lite pack has been updated since the PDF was made, but the instructions are still valid.

Winamp v5.9.0.9999 - Quinto Black CT v3.6 skin
Windows 11 Home 64-bit v21H2 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 28th October 2013, 20:27   #12
Drazala
Junior Member
 
Join Date: Oct 2013
Posts: 8
Video works!! but now the audio is crackling.
Drazala is offline   Reply With Quote
Old 28th October 2013, 21:02   #13
Drazala
Junior Member
 
Join Date: Oct 2013
Posts: 8
Never mind. I did something to fix the crackling. Thanks guys for all the help! I really appreciate it.
Drazala is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump