Old 18th October 2017, 22:46   #1
strannik
Junior Member
 
Join Date: Oct 2017
Posts: 5
sc_serv setup does not write file or allow completion

I have installed sc_serv - DNAS 2.5.5 Build 733
On a VPS using Ubuntu 16.04 LTE.

I can run the server using the simple example sc_serv.conf
I can begin to run setup using sc_serv setup which is what i really want to do.

When I get to the "Stage 4 - Save Settings" page, it presents "Save Settings" at the top of the page, but no button to save the settings. If I try to reload the page I get:

Successfully saved settings to the config file (sc_serv.conf).

Click 'Run Server' to run the server with the specified settings or 'Exit' to close this instance of the server (run without a configuration file to use the new settings).

The file is not saved, and if I try to click on "Run Server" nothing happens.

I need a fix or a workaround!
strannik is offline   Reply With Quote
Old 19th October 2017, 22:41   #2
MegaRock
Forum King
 
MegaRock's Avatar
 
Join Date: Jun 2003
Location: Inside my water bong
Posts: 6,864
Send a message via ICQ to MegaRock Send a message via Yahoo to MegaRock
Easiest way is to rename the example config file to sc_serv.conf and put it in the same directory as the sc_serv executable. Edit as needed but for most instances you don't need many items in it

This is all that is in mine

password=pooey
adminpassword=admin!pooey
portbase=1234
streamauthhash_1=H8&f(w&m3Ap1fd
maxuser=50

you have to add your own passwords and hash as those are examples. Save file and run server and of course edit the port to what you want or 8000 which is default.

Make sure to get the authhash from rmo.shoutcast.com

Megarock Radio - St. Louis Since 1998!
Don't click this link!
Corporate Radio Sucks! No suits, all rock!
MegaRock is offline   Reply With Quote
Old 20th October 2017, 07:07   #3
strannik
Junior Member
 
Join Date: Oct 2017
Posts: 5
The sample files don't have enough detail to tell me how to set up what I want: two MP3 streams at different nitrates, etc. It doesn't explain why the setup tool is broken in my case.
strannik is offline   Reply With Quote
Old 21st October 2017, 11:20   #4
neralex
Major Dude
 
Join Date: Mar 2011
Posts: 576
1. Forget the setup tool and build your own config, its only text-based.

2. Bitrates and encoding-formats are not a part of SHOUTcast DNAS, its a part of your source-client, which is feeding the DNAS. You can only specify the minbitrate and maxbitrate. Check the /docs/ folder!


Quote:
password=pooey
adminpassword=admin!pooey
portbase=1234

streamauthhash_1=H8&f(w&m3Ap1fd
streamauthhash_2=f566z45grt6T5u4f
streamauthhash_3=gfhre335gh4gfh45

streammaxuser_1=150
streammaxuser_2=100
streammaxuser_3=50

streamid_1=1
streampath_1=/streampath1.mp3
streamid_2=2
streampath_2=/streampath2.mp3
streamid_3=3
streampath_3=/streampath3.mp3
neralex is offline   Reply With Quote
Old 27th October 2017, 04:10   #5
strannik
Junior Member
 
Join Date: Oct 2017
Posts: 5
I have tried several combinations of things. I just attempted to use the sc_serv_basic.conf example. The server starts up with no errors. When I try to connect using BUTT, I get the following error:

2017-10-27 04:03:21 ERROR [SRC 69.109.112.111:58454 sid=1] SHOUTcast 1 source connection denied for user (PASSWORD
icy-name). Bad password: Tiki Beach Live

Tiki Beach Live is the name of the stream. I've tried every sample config I could find. Nothing is working. This used to be much easier in earlier version of DNAS.
strannik is offline   Reply With Quote
Old 27th October 2017, 11:20   #6
neralex
Major Dude
 
Join Date: Mar 2011
Posts: 576
PHP Code:
You have to type "user:password" in the password-field of BUTT
neralex is offline   Reply With Quote
Old 27th October 2017, 23:04   #7
strannik
Junior Member
 
Join Date: Oct 2017
Posts: 5
How do I configure "user" in the sc_serv.conf - is it the stream user? There is nothing about it in the sc_serv_basic.conf
strannik is offline   Reply With Quote
Old 27th October 2017, 23:38   #8
strannik
Junior Member
 
Join Date: Oct 2017
Posts: 5
OK, I was 2 versions behind on BUTT. I upgraded and everything now works - go figure.
neralex, you do NOT have to type "userassword" in the password-field of BUTT.
strannik is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump