Old 1st December 2010, 20:37   #1
EmperorOfNight
Junior Member
 
Join Date: Nov 2010
Posts: 10
iPod 6G becomes corrupt when adding media (WinAMP v5.6)

As if my frustration with Winamp the last version of WinAMP wasn't enough (My last problem) I am now faced with a new problem.

I just installed WinAMP 5.6 and I was very happy with it's updated iPod support....was.

I can add my playlists to my iPod easily with no problem. But when I eject my iPod and actually go to play the songs on it..................

where is all my music?

It doesn't show songs, artists, albums, playlists, nothing! My iPod is just blank. I plug my iPod back in and open WinAMP and WinAMP will still show my playlists on my iPod, but the iPod itself will say there's no music.

And I can still play music (that apparently doesn't exist) from my iPod using WinAMP and my iPod shows the "synchronizing" screen signaling that the iPod is being used.

So I go into iTunes to see if the music will show up there, and I get a message saying that my iPod is corrupt and needs to be restored. So I let it restore and all that, and now everything is hunky dory. So I go back into WinAMP and re-add all my music, eject my iPod, and.... there is STILL no music!!!

So I go back to iTunes and I, once more, get a "your iPod is corrupt and needs to be restored" message.

This ends up being a never ending cycle.

PLEASE HELP ME!!!

My PC specs are:

OS: Win7 Pro (64-bit)
Processor: Intel Core 2 Quad
RAM: 8GB
HD Size: 1TB (on PC)
iPod: iPod Classic 6G (160GB)
iPod firmware: 2.0.4
EmperorOfNight is offline   Reply With Quote
Old 1st December 2010, 21:35   #2
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
Yeah, this is a known issue... DJ Egg posted this in another thread about this issue.

Quote:
Originally Posted by DJ Egg View Post
Hi

Yup, it's a known bug. A fix is on its way... imminently.
Juanus is offline   Reply With Quote
Old 1st December 2010, 22:32   #3
EmperorOfNight
Junior Member
 
Join Date: Nov 2010
Posts: 10
Quote:
Originally Posted by Juanus View Post
Yeah, this is a known issue... DJ Egg posted this in another thread about this issue.
Oh thank god!

Thanks for letting me know.
EmperorOfNight is offline   Reply With Quote
Old 2nd December 2010, 06:22   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,822
There's been a slight delay....

So I'm posting the fixed pmp_ipod.dll here, for now :-)

Let us know if it fixes the problem (it does for us).


[EDIT]

Attachment removed (32 downloads)

Please use v0.8 update below

________________________________________
DJ Egg is offline   Reply With Quote
Old 2nd December 2010, 08:46   #5
jmbattle
Senior Member
 
Join Date: Apr 2004
Location: Hamamatsu, Japan
Posts: 166
Hey, Winamp supports the newer iPods?

Wow, nice work chaps!

Cheers,
James
x
jmbattle is offline   Reply With Quote
Old 2nd December 2010, 08:56   #6
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,822
Hi jmbattle

Winamp 5.6 supports:

iPod Shuffle & Mini (all models)
iPod Classic (1-4G already supported, 5+6G now supported)
iPod Nano (1-4G only)

We do not support any Touch models (iPod Touch, Nano 5-6G, iPhone, iPad, etc).
Protected proprietary formats/stipulations in place.
We might support them in the future... we shall see....

But if not, Winamp will be to Android what iTunes is to iPod ;-)

I recommend everyone should ditch their crappy iPhones and get an Android phone instead.
I did, and I've never looked back.



Sooooo... can someone please confirm the fix :-)
DJ Egg is offline   Reply With Quote
Old 2nd December 2010, 11:18   #7
EmperorOfNight
Junior Member
 
Join Date: Nov 2010
Posts: 10
Quote:
Originally Posted by DJ Egg View Post
There's been a slight delay....

So I'm posting the fixed pmp_ipod.dll here, for now :-)

Let us know if it fixes the problem (it does for us).

________________________________________
WORDS CAN NOT DESCRIBE HOW EPIC YOU HAVE JUST BECOME!

WinAMP still crashed the first time I opened it after the new add-on install, but after that it seems to be running smoothly. I can sync my playlists easily and when I eject my iPod, "0.o THE SONG ARE ACTUALLY THERE!!!"

iTunes still refuses to STFU however still saying my iPod is corrupt, but if WinAMP works, I really don't give a damn.

My iPod can handle multiple playlists, even a playlist with 200+ songs on it. It will freeze at times, but if I wait a few seconds, it will be ok. I even tried playling some music and videos off my computer while this was happening and everything seemed fine.

It still doesn't look like it can handle syncing my 3000+ song playlist, but purhaps playlists aren't made to be that long. ^^'

Anyway, thanks SO MUCH for this fix. WinAMP is still a bit glitchy and iTunes is still being a S.O.B but it's working, and that's what I wanted. Let's hope it stays that way.
EmperorOfNight is offline   Reply With Quote
Old 2nd December 2010, 11:30   #8
EmperorOfNight
Junior Member
 
Join Date: Nov 2010
Posts: 10
Quote:
Originally Posted by EmperorOfNight View Post
WORDS CAN NOT DESCRIBE HOW EPIC YOU HAVE JUST BECOME!

WinAMP still crashed the first time I opened it after the new add-on install, but after that it seems to be running smoothly. I can sync my playlists easily and when I eject my iPod, "0.o THE SONG ARE ACTUALLY THERE!!!"

iTunes still refuses to STFU however still saying my iPod is corrupt, but if WinAMP works, I really don't give a damn.

My iPod can handle multiple playlists, even a playlist with 200+ songs on it. It will freeze at times, but if I wait a few seconds, it will be ok. I even tried playling some music and videos off my computer while this was happening and everything seemed fine.

It still doesn't look like it can handle syncing my 3000+ song playlist, but purhaps playlists aren't made to be that long. ^^'

Anyway, thanks SO MUCH for this fix. WinAMP is still a bit glitchy and iTunes is still being a S.O.B but it's working, and that's what I wanted. Let's hope it stays that way.
Although syncing multiple playlists is noticeably slower than it was before. And these playlists I'm syncing now are only 8-10 songs long. :\
EmperorOfNight is offline   Reply With Quote
Old 2nd December 2010, 14:04   #9
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,822
Hmmm, we'll look into it (re: slow playlist sync)

And thanks for confirming the fix :-)

ps. You can uninstall the iTunes monster now
DJ Egg is offline   Reply With Quote
Old 2nd December 2010, 16:16   #10
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
I wish I could uninstall iTunes... but it doesn't seem to be working for me. I get the same problem where the music shows up when my ipod is connected, but when I disconnect it, my ipod says no music.
And when I start up iTunes, it says that the database is corrupt and I have to reinstall the software.
So I reinstall the software, and then I remembered that we used to have to add a song via itunes to build the database. Then we could use Winamp.
Unfortunately that doesn't work either.
I am also having problems ejecting the Ipod. The message always comes up asking if something else is using it. I start the task manager and close the ipod services... still no go.

I feel bad that I am the only one that is having problems.
I start the task manager an
Windows 7
iPod Classic 5G
do you need any other info?
Juanus is offline   Reply With Quote
Old 2nd December 2010, 16:28   #11
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,822
Hi Juanus

D'oh! :-(

Okay, thanks for the info
DJ Egg is offline   Reply With Quote
Old 2nd December 2010, 16:31   #12
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
No Sir Thank YOU! you do great work.
If I can provide any other info, let me know.


By the way, I ditched my iphone and got an android phone... then I ditched my android phone and got a webOS phone. just sayin!
Juanus is offline   Reply With Quote
Old 2nd December 2010, 17:42   #13
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
Correction!
It did work... I tried a few things and I have found the the playlists were the "problem"
If I loaded music with no playlists, then it worked much better. But something is still up.

After you load music, you have to let it sit there for a little while before you can eject it. (it took me approx 30 minutes after winamp said it was done syncing that I could eject it.)
I am guessing that when you load stuff on the device, that it holds up the ablity to eject. but if you let it sit there for a little while and the try to eject it will work and I can see all the music and playlists and such. Maybe writing the database?
Juanus is offline   Reply With Quote
Old 2nd December 2010, 19:42   #14
EmperorOfNight
Junior Member
 
Join Date: Nov 2010
Posts: 10
Quote:
Originally Posted by DJ Egg View Post
Hmmm, we'll look into it (re: slow playlist sync)

And thanks for confirming the fix :-)

ps. You can uninstall the iTunes monster now
I've also noticed that my Play/Pause controls for the Win7 taskbar has disappeared. T_T
EmperorOfNight is offline   Reply With Quote
Old 3rd December 2010, 01:25   #15
EmperorOfNight
Junior Member
 
Join Date: Nov 2010
Posts: 10
Facedesk!!!!!

Quote:
Originally Posted by EmperorOfNight View Post
WORDS CAN NOT DESCRIBE HOW EPIC YOU HAVE JUST BECOME!

WinAMP still crashed the first time I opened it after the new add-on install, but after that it seems to be running smoothly. I can sync my playlists easily and when I eject my iPod, "0.o THE SONG ARE ACTUALLY THERE!!!"

iTunes still refuses to STFU however still saying my iPod is corrupt, but if WinAMP works, I really don't give a damn.

My iPod can handle multiple playlists, even a playlist with 200+ songs on it. It will freeze at times, but if I wait a few seconds, it will be ok. I even tried playling some music and videos off my computer while this was happening and everything seemed fine.

It still doesn't look like it can handle syncing my 3000+ song playlist, but purhaps playlists aren't made to be that long. ^^'

Anyway, thanks SO MUCH for this fix. WinAMP is still a bit glitchy and iTunes is still being a S.O.B but it's working, and that's what I wanted. Let's hope it stays that way.
----------------------
After the happy results after this fix and I sync my iPod and get all my music back, I come back at the end of the day and just plug it in to charge my iPod. I unplug it and head out..... my iPod committed suicide again, everything is gone. I know one time back when this started Windows would recommend that I run a CHKDSK on my iPod to make sure everything is just dandy, and I did this and that wiped my iPod. I'm ignoring that message now, but I just noticed that when I plug my iPod in, it shows the syncing screen when the "Recommendation to run CHKDSK" window pops up. I wounder if that has something to do with this mess?

Why me?
EmperorOfNight is offline   Reply With Quote
Old 3rd December 2010, 03:41   #16
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
Please don't cry. It was happening to me also. Your ipod is fine.
But I think Benski came up with a fix that is really going to work this time. Please be patient and tomorrow you should hear some good news.
Juanus is offline   Reply With Quote
Old 3rd December 2010, 07:00   #17
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,822

Yup, hopefully this is the good news....

pmp_ipod v0.81 update

Includes:
-Eject fix
-Gapless fix (in_mp3 v4.94)
-Sync fixes from previous update (tweaked)

UPDATED: 5 DEC 2010 (downloads reset to 0, was at 46)

UPDATED: 7 DEC 2010 (downloads reset to 0, was at 28)

UPDATED: 8 DEC 2010 with Nano 4g sync fix (downloads reset to 0, was at 15)

______________________________________
Attached Files
File Type: exe pmp_ipod_update.exe (307.7 KB, 1101 views)
DJ Egg is offline   Reply With Quote
Old 5th December 2010, 21:24   #18
Stone Free
Senior Member
 
Join Date: Feb 2001
Posts: 107
Will this fix the occasional cross linking of tracks?

See http://forums.winamp.com/showpost.ph...33&postcount=1 and http://forums.winamp.com/showpost.ph...36&postcount=6
Stone Free is offline   Reply With Quote
Old 6th December 2010, 17:24   #19
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,822
@Stone Free

Possibly not

Thanks for bringing it to our attention.
We'll look into it and try to find a fix for the next major release.
DJ Egg is offline   Reply With Quote
Old 8th December 2010, 15:36   #20
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,822
Note, there's still some issues with Nano 4G sync.

Keep tuned to this thread for updates:
http://forums.winamp.com/showthread.php?t=324573

EDIT: 8 Dec 2010

Above installer now updated with Nano 4g sync fix
DJ Egg is offline   Reply With Quote
Old 9th December 2010, 01:37   #21
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,623
Send a message via AIM to MrSinatra
i got my wife one of these for xmas, (so it won't be opened til then)

http://www.apple.com/ipodnano/

the 8gb ver.

anyway, i take it that winamp won't natively work with it, is that correct?

i have seen mention of a 3rd party ipod plugin, can it do any better?

i also saw mention of some utility benski had that generates xml or something and gives you devs useful info to make support for these devices; could you use that from me for this?

she has a mac and so she can load her mostly terrible music into this thing for workouts and so on with her mac, and be happy. but i am just wondering if i'll be able to use it with winamp at all, or will i corrupt it or something?

also, i have decided to get a droid X this weekend, as i give up using LG phones and i want an android phone. i am a bit worried it won't be as good as an iphone useability wise, sizewise, or in other ways, (my family/friends istuff rocks, i have to admit) but i like the philosophy of droid over apple, and i really hate itunes.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 9th December 2010, 09:46   #22
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,822
Winamp 5.601 supports the following iPod models:

Shuffle (all models)
Mini (all models)
Classic (all models)
Nano 1-4g

No support for:

Nano 5/6g
Touch
iPhone
iPad

These newer models use an entirely different database system (proprietary & sql-based)
and the devices do not mount as a drive.

We attempted to hack in support for them a year or two ago
but Apple then released new firmware which broke it again.

The 3rd-party ml_ipod plugin *might* support Nano 5/6g models
but I can't guarantee it.

Also note that ml_ipod & iTunes are not comptaible with each other
(with regards to Nano 5/6g and Touch support)

http://mlipod.sourceforge.net/
http://forums.winamp.com/forumdisplay.php?f=69


Congratulations on your wise decision to get a Droid X
You won't have any problems using Winamp to manage it :-)
DJ Egg is offline   Reply With Quote
Old 5th January 2011, 02:07   #23
a_bomb
Junior Member
 
Join Date: Jan 2011
Posts: 1
"This ends up being a never ending cycle.
PLEASE HELP ME!!! "

I'm having the exact same problem with my nano touch - I got it in October and it's been a ridiculous cycle ever since and all I have to show for it is an ipod with absolutely nothing on it. Prior to installing winamp I did everything i could possibly think of to get the ipod to work just through itunes. I've had numerous phone calls and emails to Apple support, took my computer (which was at the time running windows vista) in to the shop, and still nothing. Then they suggested I get the boot software from the manufacturer to restore the computer to factory specs (costing me even more money) before I just gave up. A friend of mine upgraded my OS, and installed winamp and a bunch of patches and I'm now at the point where I have a program that actually recognizes my ipod, and synchs with it - but there is still nothing showing up as music on my ipod. However, when I plug into it, the library comes up in winamp. I'm starting to wonder if this is ever going to work for me. Any suggestions would be absolutely welcome (and are absolutely needed)!
a_bomb is offline   Reply With Quote
Old 13th January 2011, 13:17   #24
WhammyDroid
Junior Member
 
Join Date: Oct 2010
Posts: 20
Quote:
Originally Posted by DJ Egg View Post

Yup, hopefully this is the good news....

pmp_ipod v0.81 update

Includes:
-Eject fix
-Gapless fix (in_mp3 v4.94)
-Sync fixes from previous update (tweaked)

UPDATED: 5 DEC 2010 (downloads reset to 0, was at 46)

UPDATED: 7 DEC 2010 (downloads reset to 0, was at 28)

UPDATED: 8 DEC 2010 with Nano 4g sync fix (downloads reset to 0, was at 15)


______________________________________
DJ Egg,

I just downloaded and installed the latest ipod dll update for 5.601.The sorting issue with the Ipod is still not resolved. Winamp is putting the song selection order in some random order (rather than alphabetical).

To replicate, connect the ipod, add a few songs to the ipod, then disconnect. Off of the main menu, select the "songs" selector and notice the songs are not in order.

I have a 3rd Gen Nano and a 5th Gen Ipod Classic. Both ipods witness this issue.
WhammyDroid is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump