Old 28th April 2011, 19:49   #1
brentmj
Junior Member
 
Join Date: Feb 2011
Posts: 13
Encoding error in 1.9 XML stats

I'm trying to pull some info from the XML stats and I'm having some trouble. When I click Get XML stats, it pulls up the XML file, but my browser is telling me "This page contains the following errors:

error on line 1 at column 3158: Encoding error"

When I go to that location, there doesn't appear to be anything incorrect, in fact, it's right in the middle of a USERAGENT tag for one of the listeners. When I was checking this out last week everything was fine, today it's been doing this all day.

I'm using 1.9.8 because I'm broadcasting with SAM and it doesn't play well with 2.0, yet. Any suggestions on what's going wrong?
brentmj is offline   Reply With Quote
Old 30th April 2011, 00:42   #2
hackerdork
Forum King
 
hackerdork's Avatar
 
Join Date: Feb 2006
Location: Earth Circa sometime.
Posts: 3,297
well funny and strange as XML is, the XML generated in shoutcast is not really browser freindly since its generated using the DNAs from shoutcast and not a web browser XML.

What is the real issue? getting XML form the web page is not used by SAM broadcaster as far as I know, and shoutcast has never been a issue with SAM broadcaster as I have used it very often myself.

~ According to the ship's log we're down to our last 3000 vomit bags.It'll never be enough.
search the forums! don't PM me on how-to, or ask me to setup you system. you do it so you learn.
hackerdork is offline   Reply With Quote
Old 30th April 2011, 10:24   #3
MADxHAWK
Senior Member
 
Join Date: Jan 2010
Posts: 181
Well i wonder what browser you are using. I never had any problems viewing the xml-stats with Firefox and even the simpleXML funktion from PHP is able to parse this file without any errors (except there was a song in history with a specialchar in the tag, for example è or german umlaute äöü, what was fixed in DNAS2.x)

-MAD
MADxHAWK is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump