Old 26th April 2011, 01:36   #1
Industrial_One
Junior Member
 
Join Date: Aug 2008
Posts: 38
Subtitles not displaying (directvobsub)

Subtitles don't appear in MKV or MP4 files but when I change the extension to AVI, they do. This problem is not present on Media Player Classic. Any ideas how to fix this?
Industrial_One is offline   Reply With Quote
Old 23rd September 2011, 20:20   #2
DarkFireBlade25
Junior Member
 
Join Date: Sep 2011
Posts: 3
I would also like to know this as the subtitles worked for my .mkv before but now don't work... not too sure what happened there.
DarkFireBlade25 is offline   Reply With Quote
Old 24th September 2011, 05:01   #3
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,851
Alas, subtitles support for the in_mp4 and (the newer) in_mkv plugins still hasn't been implemented :-(

In versions of Winamp prior to v5.57, all of avi, mkv, mp4 & mpg video playback was handled by the in_dshow plugin.
To get subtitles support, you would need to revert back to making in_dshow handle mkv & mp4 instead...
which involves doing the following:

1. Close Winamp, rename Winamp\Plugins\in_mkv.dll to in_mkv.dll.off (or move it out of the Plugins folder)
2. Reopen Winamp, go to: Prefs (Ctrl+P) > Plugins > Input > in_mp4 > config, and remove MP4 from the extensions list.
3. Go to: Prefs (Ctrl+P) > Plugins > Input > in_dshow > config, and add MP4;MKV to the extensions list.

This is also assuming you've already got the external mp4/mkv DirectShow splitter(s) and filters installed (I personally use ffdshow, with Subtitles enabled)
http://forums.winamp.com/showthread.php?t=155680#mkv
DJ Egg is offline   Reply With Quote
Old 24th September 2011, 05:37   #4
DarkFireBlade25
Junior Member
 
Join Date: Sep 2011
Posts: 3
Thanks, my friend actually found a fix for it and told me about it a few hours ago. You download QQ player and it automatically gives you subtitle support. Don't know how, but it did it for me.
DarkFireBlade25 is offline   Reply With Quote
Old 16th March 2012, 12:39   #5
Industrial_One
Junior Member
 
Join Date: Aug 2008
Posts: 38
Quote:
Originally Posted by DJ Egg View Post
Alas, subtitles support for the in_mp4 and (the newer) in_mkv plugins still hasn't been implemented :-(

In versions of Winamp prior to v5.57, all of avi, mkv, mp4 & mpg video playback was handled by the in_dshow plugin.
To get subtitles support, you would need to revert back to making in_dshow handle mkv & mp4 instead...
which involves doing the following:

1. Close Winamp, rename Winamp\Plugins\in_mkv.dll to in_mkv.dll.off (or move it out of the Plugins folder)
2. Reopen Winamp, go to: Prefs (Ctrl+P) > Plugins > Input > in_mp4 > config, and remove MP4 from the extensions list.
3. Go to: Prefs (Ctrl+P) > Plugins > Input > in_dshow > config, and add MP4;MKV to the extensions list.

This is also assuming you've already got the external mp4/mkv DirectShow splitter(s) and filters installed (I personally use ffdshow, with Subtitles enabled)
http://forums.winamp.com/showthread.php?t=155680#mkv
I use 5.54 and use in_dshow by default for everything as the in_mp4 and other filters are choppy, not as smooth as in_dshow and I still got problems. Oh well, this is easily fixed by enabling Subtitles in FFDShow Video decoder.
Industrial_One is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump