Old 4th March 2012, 14:18   #1
jbmusic
Junior Member
 
Join Date: Mar 2012
Posts: 11
shoutcast 2.0 issue's

Dear Shoutcast members,

We are working already a long time with shoutcast 1.9.8 without any problem.
After some new software updates we decided to update shoutcast as well to version 2.0

We had already made a test-machine with 2.0 without any problem.
Now we have added this in the live machine, with a big issue.
We are not able to connect to the live stream.
We have built up the machine as follow:

Sam 4.9.3.
encoding by sam
shoutcast 2
MP3 Multi-stream (2 endpoints)

We can connect to the admin page, but when we starts the url by winamp, we see in the shoutcast screen the connection, but is dropped directly.
on the admin page we see, the song info, etc (corresponding with the info which sam is parsing)

We thought is was something like a firewall problem, but after downgrading to 1.9.8 it worked directly.

is there somebody with a suggestion??


Am i missing something??
jbmusic is offline   Reply With Quote
Old 4th March 2012, 17:26   #2
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,009
Send a message via Skype™ to thinktink
What does the admin page say the status is?

Do you have the DNAS logs? Please post them.
thinktink is offline   Reply With Quote
Old 4th March 2012, 17:55   #3
jbmusic
Junior Member
 
Join Date: Mar 2012
Posts: 11
Shoutcast log:

2012-03-02 18:06:02 I msg:[MAIN] Logger updating log file to use
2012-03-02 18:06:02 I msg:[MAIN] Loaded config from sc_stream_ZFM.conf
2012-03-02 18:06:02 I msg:[MAIN] Calculated CPU count is 2
2012-03-02 18:06:02 I msg:[MAIN] Starting 2 network threads
2012-03-02 18:06:02 I msg:[MICROSERVER] Listening for connection on port 8192
2012-03-02 18:06:02 I msg:[MICROSERVER] Listening for connection on port 8193
2012-03-02 18:06:03 I msg:[SRC 127.0.0.1:2278] SHOUTcast 2 source connection.

2012-03-02 18:06:43 I msg:11565156 streamData::specialFileData::loadFromFileintro file x:\ZFM192.mp3 loaded. 370592 bytes.
2012-03-02 18:06:43 E msg:[YP2] No authhash found for stream config #1. Aborting registering stream with YP.
2012-03-02 18:06:43 I msg:[SRC 127.0.0.1:2297 sid=1] stream configuration complete. [
type=SHOUTcast 2
mimeType=audio/mpeg
maxPayloadSize=16377
avgBitrate=192000
maxBitrate=192000
desiredBufferSize=60
minimumBufferSize=0
icyName=ZeewoldeFM
icyGenre=top40
icyURL=http://www.zeewoldefm.nl
icyPub=1
]
2012-03-02 18:06:45 I msg:[SRC 127.0.0.1:2297 sid=1] Got complete metadata message type=3902 [248 bytes] id=1 span=1 content=
<?xml version="1.0" encoding="UTF-8"?>
<metadata><TENC>SAM Broadcaster 4.9.3</TENC><TRSN>ZeewoldeFM</TRSN><WORS>http://www.zeewoldefm.nl</WORS><extension><title seq="1"> .:. Bezoek ook onze website .:. </title></extension></metadata>

2012-03-02 18:06:52 I msg:[SRC 127.0.0.1:2297 sid=1] Got complete metadata message type=3902 [240 bytes] id=2 span=1 content=
<?xml version="1.0" encoding="UTF-8"?>
<metadata><TENC>SAM Broadcaster 4.9.3</TENC><TRSN>ZeewoldeFM</TRSN><WORS>http://www.zeewoldefm.nl</WORS><extension><title seq="1"> .:. www.zeewoldefm.nl .:. </title></extension></metadata>

2012-03-02 18:07:01 I msg:[SRC 127.0.0.1:2297 sid=1] Got complete metadata message type=3902 [267 bytes] id=3 span=1 content=
<?xml version="1.0" encoding="UTF-8"?>
<metadata><TENC>SAM Broadcaster 4.9.3</TENC><TRSN>ZeewoldeFM</TRSN><WORS>http://www.zeewoldefm.nl</WORS><extension><title seq="1"> .:. ZeewoldeFM is het radio station van Zeewolde .:. </title></extension></metadata>

2012-03-02 18:07:08 E msg:[DST dsl-213-233-250-191.solcon.nl:58217 sid=1] SHOUTcast 2 client connection rejected. Stream not available. WinampMPEG/5.62, Ultravox/2.1
2012-03-02 18:07:08 I msg:[DST dsl-213-233-250-191.solcon.nl:58217 sid=1] SHOUTcast 2 client connection closed (0 seconds) [Bytes: 0] Agent: `WinampMPEG/5.62, Ultravox/2.1'
2012-03-02 18:07:10 I msg:[SRC 127.0.0.1:2297 sid=1] Got complete metadata message type=3902 [267 bytes] id=4 span=1 content=
<?xml version="1.0" encoding="UTF-8"?>
<metadata><TENC>SAM Broadcaster 4.9.3</TENC><TRSN>ZeewoldeFM</TRSN><WORS>http://www.zeewoldefm.nl</WORS><extension><title seq="1"> .:. ON AIR: Caro Emerald - I Know That He's Mine .:. </title></extension></metadata>
jbmusic is offline   Reply With Quote
Old 4th March 2012, 20:22   #4
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,009
Send a message via Skype™ to thinktink
Quote:
Originally Posted by jbmusic View Post
2012-03-02 18:06:43 E msg:[YP2] No authhash found for stream config #1. Aborting registering stream with YP.
Quote:
Originally Posted by jbmusic View Post
2012-03-02 18:07:08 E msg:[DST dsl-213-233-250-191.solcon.nl:58217 sid=1] SHOUTcast 2 client connection rejected. Stream not available. WinampMPEG/5.62, Ultravox/2.1


Looks like the DNAS is rejecting clients because you have it set to list on the YP directory (public) without a valid auth hash.

Please visit this documentation page:
http://wiki.winamp.com/wiki/SHOUTcas...ash_Management
thinktink is offline   Reply With Quote
Old 4th March 2012, 22:04   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
the v2 DNAS will not allow client connections when there is no / an invalid authhash and the DNAS is not able to register itself with the YP - since the DNAS uses the authhash information for the stream and if that cannot be obtained then the DNAS is in an invalid state and so should not allow client connections (though that will be altered in the next release [no eta] to allow client connections if the YP connection is unobtainable due to the YP not running BUT that does not change things if the YP connection is there and the authhash is invalid / missing).

i guess i need to make day-glow flashing error messages in the log output as the error line was pretty obvious i though (plus there's error messages noting no YP connection on the stream summary / admin pages) *shrugs*

-daz
DrO is offline   Reply With Quote
Old 5th March 2012, 14:24   #6
jbmusic
Junior Member
 
Join Date: Mar 2012
Posts: 11
-DAZ,

thanks for your support. We had added the HASHCODE before, but due to the change of a IPrange, we deleted this code, and now i have re-new the Authhash id: STREAMAUTHHASH>removed by moderation</STREAMAUTHHASH>
i can connect the admin pages, without any problem as well the lissenersurl is ok, but i cannot connect the stream.

The port 8064 is open!

2012-03-05 15:16:03 I msg:[MAIN] Logger updating log file to use
2012-03-05 15:16:03 I msg:[MAIN] Loaded config from sc_server_zfm.conf
2012-03-05 15:16:03 I msg:[MAIN] Calculated CPU count is 2
2012-03-05 15:16:03 I msg:[MAIN] Starting 2 network threads
2012-03-05 15:16:03 I msg:[MICROSERVER] Listening for connection on port 8064
2012-03-05 15:16:03 I msg:[MICROSERVER] Listening for connection on port 8065
2012-03-05 15:16:06 I msg:[SRC 127.0.0.1:2188] SHOUTcast 2 source connection.
2012-03-05 15:16:06 I msg:[SRC 127.0.0.1:2188] Password accepted. Stream id is 1
2012-03-05 15:16:06 I msg:11559620 streamData::specialFileData::loadFromFileintro file Z:\jingels\stream\ZFM64.mp3 loaded. 123840 bytes.
2012-03-05 15:16:06 I msg:[SRC 127.0.0.1:2188 sid=1] stream configuration complete. [
type=SHOUTcast 2
mimeType=audio/mpeg
maxPayloadSize=16377
avgBitrate=64000
maxBitrate=64000
desiredBufferSize=60
minimumBufferSize=0
icyName=ZeewoldeFM
icyGenre=Top40
icyURL=http://www.zeewoldefm.nl
icyPub=1
]
2012-03-05 15:16:06 I msg:[YP2] Connecting to yp.shoutcast.com
2012-03-05 15:16:06 E msg:[YP2] /yp/resp/updatefreq missing
2012-03-05 15:16:06 E msg:[YP2] Connection attempt failed. YP2 error code is 480 (Cannot see your station/computer (URL: http://95.97.28.147:8064/stream/1/) from the Internet, disable Internet Sharing/NAT/firewall/ISP cache.)
2012-03-05 15:16:08 I msg:[SRC 127.0.0.1:2188 sid=1] Got complete metadata message type=3902 [266 bytes] id=8 span=1 content=
<?xml version="1.0" encoding="UTF-8"?>
<metadata><TENC>SAM Broadcaster 4.9.3</TENC><TRSN>ZeewoldeFM</TRSN><WORS>http://www.zeewoldefm.nl</WORS><extension><title seq="1"> .:. Voor al jouw verzoekjes, vragen of reacties .:. </title></extension></metadata>

2012-03-05 15:16:15 I msg:[SRC 127.0.0.1:2188 sid=1] Got complete metadata message type=3902 [236 bytes] id=9 span=1 content=
<?xml version="1.0" encoding="UTF-8"?>
<metadata><TENC>SAM Broadcaster 4.9.3</TENC><TRSN>ZeewoldeFM</TRSN><WORS>http://www.zeewoldefm.nl</WORS><extension><title seq="1"> .:. ZEEWOLDEFM.NL .:. </title></extension></metadata>

also checked the port, and this is open. the only strange thing i notify is the IP http://95.97.28.147:8064/stream/1/ this is not correct because the url should be: http://stream192.zeewoldefm.nl:8064/listen.pls?sid=1
jbmusic is offline   Reply With Quote
Old 5th March 2012, 15:38   #7
DrO
 
Join Date: Sep 2003
Posts: 27,873
firstly, NEVER post your authhash publically - it was only by fluke that your post went into auto-moderation.

the log is indicating the YP still cannot see your station and due to that the DNAS is not going to allow client connections. i cannot access 95.97.28.147:8064 either so obviously something is causing that to be determined as the location of the DNAS. and with the additional links you've posted, you've got a v1 DNAS running on stream192.zeewoldefm.nl:8064 so that's not going to be helping things either as you cannot have a v1 and v2 DNAS running from the same location / port.

i would say try to set dstip to be the correct IP / address required, however the YP currently ignores that option from the v2 DNAS so it wouldn't be of any use.

-daz
DrO is offline   Reply With Quote
Old 5th March 2012, 16:07   #8
jbmusic
Junior Member
 
Join Date: Mar 2012
Posts: 11
DrO thanks for your reply.
I had to switch back to the V1 shoutcast, due to the fact that the V2 is not working.

Is there an option that i can setup a dsip in the sc_serv.conf of is this not an option?
The strange thing to me is, that we use V1 now, and when i stop that service and i use the V2, i can connect the remote admin, but the dnas is using the 95.97 adresse..
jbmusic is offline   Reply With Quote
Old 5th March 2012, 16:14   #9
DrO
 
Join Date: Sep 2003
Posts: 27,873
i don't know why things are behaving differently between the two versions.

however, as i said dstip doesn't work (well it does on the DNAS side but doesn't work on the YP side at the moment) so even setting it in the config file (which could be done), it's not going to help out in this instance.

i can only assume that you've either got that in the v1 config already or there's just something about your network setup which causing a different IP to be mapped to the machine since the check the YP does is the same irrespective of the DNAS version being used - the only difference is how dstip is used / obtained from the connection.

-daz
DrO is offline   Reply With Quote
Old 5th March 2012, 16:21   #10
jbmusic
Junior Member
 
Join Date: Mar 2012
Posts: 11
Daz,

thanks for your quick reply. I will ask our datacenter, to see if he can do something about this. The NAT is directly set to this point, but perhapse there is something wronly setup in our sonicwall..
jbmusic is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Tags
network, sam, shoutcast

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump